%global _empty_manifest_terminate_build 0
Name: python-astsearch
Version: 0.2.0
Release: 1
Summary: Intelligently search Python source code
License: MIT License
URL: https://github.com/takluyver/astsearch
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/bf/7f/ab5d4aeeb16fabe8927493eb144b990187f4d320005c1445796575cf3ad2/astsearch-0.2.0.tar.gz
BuildArch: noarch
Requires: python3-astcheck
%description
ASTsearch is an intelligent search tool for Python code.
To get it::
pip install astsearch
To use it::
# astsearch pattern [path]
astsearch "?/?" # Division operations in all files in the current directory
For more details, see `the documentation `_.
%package -n python3-astsearch
Summary: Intelligently search Python source code
Provides: python-astsearch
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-astsearch
ASTsearch is an intelligent search tool for Python code.
To get it::
pip install astsearch
To use it::
# astsearch pattern [path]
astsearch "?/?" # Division operations in all files in the current directory
For more details, see `the documentation `_.
%package help
Summary: Development documents and examples for astsearch
Provides: python3-astsearch-doc
%description help
ASTsearch is an intelligent search tool for Python code.
To get it::
pip install astsearch
To use it::
# astsearch pattern [path]
astsearch "?/?" # Division operations in all files in the current directory
For more details, see `the documentation `_.
%prep
%autosetup -n astsearch-0.2.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-astsearch -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 15 2023 Python_Bot - 0.2.0-1
- Package Spec generated