%global _empty_manifest_terminate_build 0
Name:		python-Conolist
Version:	0.20
Release:	1
Summary:	Surf paths easily from console.
License:	MIT
URL:		https://github.com/E-RROR/conolist
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/14/84/aae0da7345ad237a03cd17d9f729c4c5737d8bc018c78132b50f0c4e7e5e/Conolist-0.20.tar.gz
BuildArch:	noarch


%description
<p align="center">
<img src="https://launchpadlibrarian.net/488250556/rsz_2list.png" width="200" />  
</p>
<h1 align="center">CONO LIST</h1>
<h3 align="center">Surf paths easily from console</h3>
<p align="center">
  <img src="https://img.shields.io/pypi/v/conolist"/>
  <img src="https://img.shields.io/github/issues/E-RROR/conolist"/>
  <img src="https://img.shields.io/pypi/l/conolist" />
</p>
<div align="center">
  <img src="https://github.com/E-RROR/protovpn/raw/master/ezgif.com-crop.gif" />
</div>

# Installation
```
pip3 install conolist
```

# Running
from anywhere in your terminal just run `conolist`

# Keys and features available
| Key | Purpose|
| --- | --- |
| q | quit |
| c  | enter command |
| i  | option menu on folders |
| n  | create new file or folder |
| Key up | go up |
| Key Down  | go down |
| Enter on folder | go to that path |
| Enter on file | option menu for file |




%package -n python3-Conolist
Summary:	Surf paths easily from console.
Provides:	python-Conolist
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-Conolist
<p align="center">
<img src="https://launchpadlibrarian.net/488250556/rsz_2list.png" width="200" />  
</p>
<h1 align="center">CONO LIST</h1>
<h3 align="center">Surf paths easily from console</h3>
<p align="center">
  <img src="https://img.shields.io/pypi/v/conolist"/>
  <img src="https://img.shields.io/github/issues/E-RROR/conolist"/>
  <img src="https://img.shields.io/pypi/l/conolist" />
</p>
<div align="center">
  <img src="https://github.com/E-RROR/protovpn/raw/master/ezgif.com-crop.gif" />
</div>

# Installation
```
pip3 install conolist
```

# Running
from anywhere in your terminal just run `conolist`

# Keys and features available
| Key | Purpose|
| --- | --- |
| q | quit |
| c  | enter command |
| i  | option menu on folders |
| n  | create new file or folder |
| Key up | go up |
| Key Down  | go down |
| Enter on folder | go to that path |
| Enter on file | option menu for file |




%package help
Summary:	Development documents and examples for Conolist
Provides:	python3-Conolist-doc
%description help
<p align="center">
<img src="https://launchpadlibrarian.net/488250556/rsz_2list.png" width="200" />  
</p>
<h1 align="center">CONO LIST</h1>
<h3 align="center">Surf paths easily from console</h3>
<p align="center">
  <img src="https://img.shields.io/pypi/v/conolist"/>
  <img src="https://img.shields.io/github/issues/E-RROR/conolist"/>
  <img src="https://img.shields.io/pypi/l/conolist" />
</p>
<div align="center">
  <img src="https://github.com/E-RROR/protovpn/raw/master/ezgif.com-crop.gif" />
</div>

# Installation
```
pip3 install conolist
```

# Running
from anywhere in your terminal just run `conolist`

# Keys and features available
| Key | Purpose|
| --- | --- |
| q | quit |
| c  | enter command |
| i  | option menu on folders |
| n  | create new file or folder |
| Key up | go up |
| Key Down  | go down |
| Enter on folder | go to that path |
| Enter on file | option menu for file |




%prep
%autosetup -n Conolist-0.20

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-Conolist -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.20-1
- Package Spec generated