%global _empty_manifest_terminate_build 0
Name: python-ColorDetect
Version: 1.6.0
Release: 1
Summary: Detect and recognize colors in images or video
License: MIT
URL: https://github.com/MarvinKweyu/ColorDetect
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/81/2f/a1991ed616b951f306bf9eedbf8e5b811650de76438f375084314be095e0/ColorDetect-1.6.0.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-matplotlib
Requires: python3-opencv-python
Requires: python3-scikit-learn
Requires: python3-webcolors
%description
# ColorDetect
ColorDetect
Documentation |
Package
![Lint workflow](https://github.com/MarvinKweyu/ColorDetect/actions/workflows/lint.yml/badge.svg?branch=master)
[![PyPI version](https://badge.fury.io/py/ColorDetect.svg)](https://pypi.org/project/ColorDetect/)
[![Python](https://img.shields.io/badge/python-3.6%7C3.7%7C3.8%7C3.9-green)](https://pypi.org/project/ColorDetect/)
[![CircleCI](https://circleci.com/gh/MarvinKweyu/ColorDetect.svg?style=svg)](https://circleci.com/gh/MarvinKweyu/ColorDetect)
[![Downloads](https://pepy.tech/badge/colordetect)](https://pypi.org/project/ColorDetect/)
[![Documentation Status](https://readthedocs.org/projects/colordetect/badge/?version=master)](https://colordetect.readthedocs.io/en/master/)
> ColorDetect works to recognize and identify different colors in an image or video.
## Installation
```bash
pip install ColorDetect
```
## Basic Usage
### Images
```python
from colordetect import ColorDetect
user_image = ColorDetect()
# return dictionary of color count. Do anything with this
user_image.get_color_count()
# write color count
user_image.write_color_count()
# optionally, write any text to the image
user_image.write_text(text="any text")
# save the image after using either of the options (write_color_count/write_text) or both
user_image.save_image(,)
```
Resultant image is stored in the string `storage_path` of choice with the `image_name` which will default to the current location and **out.jpg** respectively by default.
### Videos
```python
from colordetect import VideoColor,col_share
user_video = VideoColor()
# return dictionary of color count. Do anything with this result
user_video.get_video_frames(progress=True)
# to order this rather long result and get only a specific number look up the `col_share` module
```
You can also get colors at a specific time and extract the frame at that given time.
## Project Documentation
For further project documentation, visit [ColorDetect's page](https://colordetect.readthedocs.io/en/latest/)
## Contributions
Contributions are welcome.
Do remember to take a look at the project [contribution guidelines](https://github.com/MarvinKweyu/ColorDetect/blob/master/CONTRIBUTING.rst)
### Tests
To run tests:
```bash
pytest
```
### Pre-commit
Pre-commit hooks are used to automate linting
1. Install the git hook scripts
```shell
pre-commit install
```
1. (optional) Run against all the files
```shell
pre-commit run --all-files
```
The installed pre-commit hooks will automatically ensure use of a consistent code format and style whenever one commits
changes using git. For full documentation, view the [pre-commit docs](https://pre-commit.com/).
## Hall of Code
To the amazing human beings and developers that made this possible.
%package -n python3-ColorDetect
Summary: Detect and recognize colors in images or video
Provides: python-ColorDetect
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-ColorDetect
# ColorDetect
ColorDetect
Documentation |
Package
![Lint workflow](https://github.com/MarvinKweyu/ColorDetect/actions/workflows/lint.yml/badge.svg?branch=master)
[![PyPI version](https://badge.fury.io/py/ColorDetect.svg)](https://pypi.org/project/ColorDetect/)
[![Python](https://img.shields.io/badge/python-3.6%7C3.7%7C3.8%7C3.9-green)](https://pypi.org/project/ColorDetect/)
[![CircleCI](https://circleci.com/gh/MarvinKweyu/ColorDetect.svg?style=svg)](https://circleci.com/gh/MarvinKweyu/ColorDetect)
[![Downloads](https://pepy.tech/badge/colordetect)](https://pypi.org/project/ColorDetect/)
[![Documentation Status](https://readthedocs.org/projects/colordetect/badge/?version=master)](https://colordetect.readthedocs.io/en/master/)
> ColorDetect works to recognize and identify different colors in an image or video.
## Installation
```bash
pip install ColorDetect
```
## Basic Usage
### Images
```python
from colordetect import ColorDetect
user_image = ColorDetect()
# return dictionary of color count. Do anything with this
user_image.get_color_count()
# write color count
user_image.write_color_count()
# optionally, write any text to the image
user_image.write_text(text="any text")
# save the image after using either of the options (write_color_count/write_text) or both
user_image.save_image(,)
```
Resultant image is stored in the string `storage_path` of choice with the `image_name` which will default to the current location and **out.jpg** respectively by default.
### Videos
```python
from colordetect import VideoColor,col_share
user_video = VideoColor()
# return dictionary of color count. Do anything with this result
user_video.get_video_frames(progress=True)
# to order this rather long result and get only a specific number look up the `col_share` module
```
You can also get colors at a specific time and extract the frame at that given time.
## Project Documentation
For further project documentation, visit [ColorDetect's page](https://colordetect.readthedocs.io/en/latest/)
## Contributions
Contributions are welcome.
Do remember to take a look at the project [contribution guidelines](https://github.com/MarvinKweyu/ColorDetect/blob/master/CONTRIBUTING.rst)
### Tests
To run tests:
```bash
pytest
```
### Pre-commit
Pre-commit hooks are used to automate linting
1. Install the git hook scripts
```shell
pre-commit install
```
1. (optional) Run against all the files
```shell
pre-commit run --all-files
```
The installed pre-commit hooks will automatically ensure use of a consistent code format and style whenever one commits
changes using git. For full documentation, view the [pre-commit docs](https://pre-commit.com/).
## Hall of Code
To the amazing human beings and developers that made this possible.
%package help
Summary: Development documents and examples for ColorDetect
Provides: python3-ColorDetect-doc
%description help
# ColorDetect
ColorDetect
Documentation |
Package
![Lint workflow](https://github.com/MarvinKweyu/ColorDetect/actions/workflows/lint.yml/badge.svg?branch=master)
[![PyPI version](https://badge.fury.io/py/ColorDetect.svg)](https://pypi.org/project/ColorDetect/)
[![Python](https://img.shields.io/badge/python-3.6%7C3.7%7C3.8%7C3.9-green)](https://pypi.org/project/ColorDetect/)
[![CircleCI](https://circleci.com/gh/MarvinKweyu/ColorDetect.svg?style=svg)](https://circleci.com/gh/MarvinKweyu/ColorDetect)
[![Downloads](https://pepy.tech/badge/colordetect)](https://pypi.org/project/ColorDetect/)
[![Documentation Status](https://readthedocs.org/projects/colordetect/badge/?version=master)](https://colordetect.readthedocs.io/en/master/)
> ColorDetect works to recognize and identify different colors in an image or video.
## Installation
```bash
pip install ColorDetect
```
## Basic Usage
### Images
```python
from colordetect import ColorDetect
user_image = ColorDetect()
# return dictionary of color count. Do anything with this
user_image.get_color_count()
# write color count
user_image.write_color_count()
# optionally, write any text to the image
user_image.write_text(text="any text")
# save the image after using either of the options (write_color_count/write_text) or both
user_image.save_image(,)
```
Resultant image is stored in the string `storage_path` of choice with the `image_name` which will default to the current location and **out.jpg** respectively by default.
### Videos
```python
from colordetect import VideoColor,col_share
user_video = VideoColor()
# return dictionary of color count. Do anything with this result
user_video.get_video_frames(progress=True)
# to order this rather long result and get only a specific number look up the `col_share` module
```
You can also get colors at a specific time and extract the frame at that given time.
## Project Documentation
For further project documentation, visit [ColorDetect's page](https://colordetect.readthedocs.io/en/latest/)
## Contributions
Contributions are welcome.
Do remember to take a look at the project [contribution guidelines](https://github.com/MarvinKweyu/ColorDetect/blob/master/CONTRIBUTING.rst)
### Tests
To run tests:
```bash
pytest
```
### Pre-commit
Pre-commit hooks are used to automate linting
1. Install the git hook scripts
```shell
pre-commit install
```
1. (optional) Run against all the files
```shell
pre-commit run --all-files
```
The installed pre-commit hooks will automatically ensure use of a consistent code format and style whenever one commits
changes using git. For full documentation, view the [pre-commit docs](https://pre-commit.com/).
## Hall of Code
To the amazing human beings and developers that made this possible.
%prep
%autosetup -n ColorDetect-1.6.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-ColorDetect -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 15 2023 Python_Bot - 1.6.0-1
- Package Spec generated