%global _empty_manifest_terminate_build 0
Name:		python-best-of
Version:	0.8.6
Release:	1
Summary:	Generates a ranked list of awesome libraries and tools.
License:	GPLv3
URL:		https://github.com/best-of-lists/best-of-generator
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/f7/d4/07fa6e90edbf218866a4190bad7faa4b53aba6827bf53b2c3210521f38b2/best-of-0.8.6.tar.gz
BuildArch:	noarch

Requires:	python3-pandas
Requires:	python3-numpy
Requires:	python3-click
Requires:	python3-tqdm
Requires:	python3-pybraries
Requires:	python3-requirements-parser
Requires:	python3-pypistats
Requires:	python3-requests
Requires:	python3-addict
Requires:	python3-beautifulsoup4
Requires:	python3-PyYAML
Requires:	python3-dateutil
Requires:	python3-httpx
Requires:	python3-setuptools
Requires:	python3-wheel
Requires:	python3-twine
Requires:	python3-flake8
Requires:	python3-pytest
Requires:	python3-pytest-mock
Requires:	python3-pytest-cov
Requires:	python3-mypy
Requires:	python3-black
Requires:	python3-pydocstyle
Requires:	python3-isort
Requires:	python3-lazydocs
Requires:	python3-types-requests

%description
Licensed **MIT**. Created and maintained with ❤️  by developers from Berlin.

%package -n python3-best-of
Summary:	Generates a ranked list of awesome libraries and tools.
Provides:	python-best-of
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-best-of
Licensed **MIT**. Created and maintained with ❤️  by developers from Berlin.

%package help
Summary:	Development documents and examples for best-of
Provides:	python3-best-of-doc
%description help
Licensed **MIT**. Created and maintained with ❤️  by developers from Berlin.

%prep
%autosetup -n best-of-0.8.6

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-best-of -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8.6-1
- Package Spec generated