%global _empty_manifest_terminate_build 0
Name: python-atelier
Version: 1.1.51
Release: 1
Summary: A collection of tools for software artists
License: GNU Affero General Public License v3
URL: https://gitlab.com/lino-framework/atelier
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d5/97/21335c2c1e3bd5e09a046c73078806a193de4319b6c579d48d8c83d464ff/atelier-1.1.51.tar.gz
BuildArch: noarch
%description
`atelier` is a collection of tools for maintaining your Python software
repositories using a library of `invoke `_ commands.
- Source code: https://gitlab.com/lino-framework/atelier
- Documentation: https://lino-framework.gitlab.io/atelier
%package -n python3-atelier
Summary: A collection of tools for software artists
Provides: python-atelier
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-atelier
`atelier` is a collection of tools for maintaining your Python software
repositories using a library of `invoke `_ commands.
- Source code: https://gitlab.com/lino-framework/atelier
- Documentation: https://lino-framework.gitlab.io/atelier
%package help
Summary: Development documents and examples for atelier
Provides: python3-atelier-doc
%description help
`atelier` is a collection of tools for maintaining your Python software
repositories using a library of `invoke `_ commands.
- Source code: https://gitlab.com/lino-framework/atelier
- Documentation: https://lino-framework.gitlab.io/atelier
%prep
%autosetup -n atelier-1.1.51
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-atelier -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 15 2023 Python_Bot - 1.1.51-1
- Package Spec generated