%global _empty_manifest_terminate_build 0
Name: python-psgtest
Version: 3.4
Release: 1
Summary: Run your Python programs, capture the output, using your choice of interpreters
License: GNU Lesser General Public License v3 or later (LGPLv3+)
URL: https://github.com/PySimpleGUI/psgtest
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/50/ef/c92867043fb8ff472aec87ca46c23bf38d52280055a2e7d4e57a5ad0edb6/psgtest-3.4.tar.gz
BuildArch: noarch
Requires: python3-PySimpleGUI
Requires: python3-psutil
%description
psgtest
Simple Python Testing
Run your Python programs using the interpreter version of your choice, and display the output in a GUI window.
![psgtest 3 0](https://user-images.githubusercontent.com/46163555/233642958-730f19f0-43a9-4bea-833e-9524c2d770ff.gif)
## Installation
### Old-school Straight Pip
pip install psgtest
### pip via `python -m pip` the python recommended way
#### If `python` is your command
`python -m pip install psgtest`
#### If `python3` is your command
`python3 -m pip install psgtest`
## Usage
Once pip installed, you can launch psgtest by typing on the command line:
`psgtest`
You can also create a Windows shortcut by following the instructions below.
## About
This is an example of another utility used in the development of PySimpleGUI that is being released for other PySimpleGUI users to use either as a standalone tool or as example code / design pattern to follow.
It can be challenging to manage multiple versions of Python and the need to test across multiple versions. Virtual Environments are one approach that are often used. psgtest does not use virtual environments. Instead, it invokes the Python interpreter of your choice directly.
The advantage is that changing which version of Python that's used is changed in a single drop-down menu selection as shown in the example GIF above. The session in the GIF shows launching the PySimpleGUI main test harness using multiple versions of Python by selecting the version from the drop-down at the top.
## Executing Multiple Programs
To run multiple programs, select the files to run from the list of files on the left portion of the window. Then click the "Run" button.
## Editing Programs
You can also edit the programs selected by clicking the "Edit" button. You will need to set up your editor using the PySimpleGUI global settings. If you have pip installed a version of PySimpleGUI that's 4.53.0.14 or greater, then you can type `psgsettings` from the command line. You can also change the settings by calling `sg.main()` (or typing from the command line `psgmain`).
## Specifying/Selecting Python Interpreter Locations
The Setup Window is where you enter the path to each version of Python that you want to test with. The settings are stored in a file and thus will be saved from one run to another.
Selecting the version to use can be done in either the settings window or using the drop-down menu in the main window.
## Output
The stdout and stderr from each program you execute are displayed in a tab with a name that matches your filename. Each program you run will open a new tab.
In each tab you'll find 2 buttons that operate on the output shown in that tab.
Use the `Copy To Clipboard` button to copy the contents of the output to the clipboard.
Use the `Clear` button to delete the output.
The `Close Tab` button closes the tab as does the right click menu item `Close`. If you run the program again after closing the tab, the old contents of the tab are retained and shown when the tab is "re-opened". (See the GIF above for an example)
## Make a Windows Shortcut
If you're running Windows, then you can use `psgshortcut` to make a shortcut to the .pyw file (if you download psgtest from GitHub) or the .py file (if you pip installed). The icon for `psgtest` is in this repo and is also included when you pip install psgtest. It's in the same folder as the gui.py file.
You can find the location of psgtest after pip installing it by running psgtest, right clicking, and choosing "File Location". You'll be shown where the `gui.py` file is located (the name of the psgtest program when pip installed). It will usually be located in the `site-packages` folder in a folder named `psgtest`.
Instructions on how to make shortcuts to pip installed PySimpleGUI programs can be found in [description for psgshortcut on PyPI](https://pypi.org/project/psgshortcut/).
## Release Notes
### 3.4 29-Apr-2023
- Allow non-python programs to be run. If the file does not end in .py or .pyw, then the file will be executed directly
### 3.3 23-Apr-2023
- Remove the entry from sp_to_filename when killing process
### 3.2 22-Apr-2023
- Added piped output for regression testing
- Added cleanup of processes when exiting. If any processes are running, they will be killed.
### 3.0 21-Apr-2023
- Greatly expanded the Regression test features
- Made regression multi-threaded
- Added testing across all Python interpreters
- Removed direct calls to Python Thread module and using only PySimpleGUI supplied calls
### 1.13.0
* Run all Interpreters feature added
### 1.12.0
* Addition of a "custom release" of Python entry in setup
* Enables using other "Python flavors" like pypy
* One custom item is allowed
### 1.11.0
* Addition of a "run a single file" option so that you can quickly and easily test one program against many versions of Python
### 1.10.0
* Regression Test Feature - run large sets of tests. Will keep tabs open that have failures and show an error popup
### 1.9.0
* Fix for exception when no settings are initially found. Oy.... bad bug to have released reight away
* Will create a settings file with the currently running version of Python if one is not found
* Added minimum of 4.55.1 requirement for PySimpleGUI to the setup.py file
### 1.8.0
* Support for Python 3.4, 3.5, 3.11 added to settings
* Set the settings filename to be `psgtest` instead of the default filename. This is needed because the file for these psg projects on PyPI are all name gui.py and thus will have all point to the same settings file if not explicitly set
* Only show configured interpreters in the Combo in main window
## License
Licensed under an LGPL3 License
## Designed and Written By
Mike from PySimpleGUI.org
## Contributing
Like the PySimpleGUI project, this project is currently licensed under an open-source license, the project itself is structured like a proprietary product. Pull Requests are not accepted.
## Copyright
Copyright 2021 PySimpleGUI
%package -n python3-psgtest
Summary: Run your Python programs, capture the output, using your choice of interpreters
Provides: python-psgtest
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-psgtest
psgtest
Simple Python Testing
Run your Python programs using the interpreter version of your choice, and display the output in a GUI window.
![psgtest 3 0](https://user-images.githubusercontent.com/46163555/233642958-730f19f0-43a9-4bea-833e-9524c2d770ff.gif)
## Installation
### Old-school Straight Pip
pip install psgtest
### pip via `python -m pip` the python recommended way
#### If `python` is your command
`python -m pip install psgtest`
#### If `python3` is your command
`python3 -m pip install psgtest`
## Usage
Once pip installed, you can launch psgtest by typing on the command line:
`psgtest`
You can also create a Windows shortcut by following the instructions below.
## About
This is an example of another utility used in the development of PySimpleGUI that is being released for other PySimpleGUI users to use either as a standalone tool or as example code / design pattern to follow.
It can be challenging to manage multiple versions of Python and the need to test across multiple versions. Virtual Environments are one approach that are often used. psgtest does not use virtual environments. Instead, it invokes the Python interpreter of your choice directly.
The advantage is that changing which version of Python that's used is changed in a single drop-down menu selection as shown in the example GIF above. The session in the GIF shows launching the PySimpleGUI main test harness using multiple versions of Python by selecting the version from the drop-down at the top.
## Executing Multiple Programs
To run multiple programs, select the files to run from the list of files on the left portion of the window. Then click the "Run" button.
## Editing Programs
You can also edit the programs selected by clicking the "Edit" button. You will need to set up your editor using the PySimpleGUI global settings. If you have pip installed a version of PySimpleGUI that's 4.53.0.14 or greater, then you can type `psgsettings` from the command line. You can also change the settings by calling `sg.main()` (or typing from the command line `psgmain`).
## Specifying/Selecting Python Interpreter Locations
The Setup Window is where you enter the path to each version of Python that you want to test with. The settings are stored in a file and thus will be saved from one run to another.
Selecting the version to use can be done in either the settings window or using the drop-down menu in the main window.
## Output
The stdout and stderr from each program you execute are displayed in a tab with a name that matches your filename. Each program you run will open a new tab.
In each tab you'll find 2 buttons that operate on the output shown in that tab.
Use the `Copy To Clipboard` button to copy the contents of the output to the clipboard.
Use the `Clear` button to delete the output.
The `Close Tab` button closes the tab as does the right click menu item `Close`. If you run the program again after closing the tab, the old contents of the tab are retained and shown when the tab is "re-opened". (See the GIF above for an example)
## Make a Windows Shortcut
If you're running Windows, then you can use `psgshortcut` to make a shortcut to the .pyw file (if you download psgtest from GitHub) or the .py file (if you pip installed). The icon for `psgtest` is in this repo and is also included when you pip install psgtest. It's in the same folder as the gui.py file.
You can find the location of psgtest after pip installing it by running psgtest, right clicking, and choosing "File Location". You'll be shown where the `gui.py` file is located (the name of the psgtest program when pip installed). It will usually be located in the `site-packages` folder in a folder named `psgtest`.
Instructions on how to make shortcuts to pip installed PySimpleGUI programs can be found in [description for psgshortcut on PyPI](https://pypi.org/project/psgshortcut/).
## Release Notes
### 3.4 29-Apr-2023
- Allow non-python programs to be run. If the file does not end in .py or .pyw, then the file will be executed directly
### 3.3 23-Apr-2023
- Remove the entry from sp_to_filename when killing process
### 3.2 22-Apr-2023
- Added piped output for regression testing
- Added cleanup of processes when exiting. If any processes are running, they will be killed.
### 3.0 21-Apr-2023
- Greatly expanded the Regression test features
- Made regression multi-threaded
- Added testing across all Python interpreters
- Removed direct calls to Python Thread module and using only PySimpleGUI supplied calls
### 1.13.0
* Run all Interpreters feature added
### 1.12.0
* Addition of a "custom release" of Python entry in setup
* Enables using other "Python flavors" like pypy
* One custom item is allowed
### 1.11.0
* Addition of a "run a single file" option so that you can quickly and easily test one program against many versions of Python
### 1.10.0
* Regression Test Feature - run large sets of tests. Will keep tabs open that have failures and show an error popup
### 1.9.0
* Fix for exception when no settings are initially found. Oy.... bad bug to have released reight away
* Will create a settings file with the currently running version of Python if one is not found
* Added minimum of 4.55.1 requirement for PySimpleGUI to the setup.py file
### 1.8.0
* Support for Python 3.4, 3.5, 3.11 added to settings
* Set the settings filename to be `psgtest` instead of the default filename. This is needed because the file for these psg projects on PyPI are all name gui.py and thus will have all point to the same settings file if not explicitly set
* Only show configured interpreters in the Combo in main window
## License
Licensed under an LGPL3 License
## Designed and Written By
Mike from PySimpleGUI.org
## Contributing
Like the PySimpleGUI project, this project is currently licensed under an open-source license, the project itself is structured like a proprietary product. Pull Requests are not accepted.
## Copyright
Copyright 2021 PySimpleGUI
%package help
Summary: Development documents and examples for psgtest
Provides: python3-psgtest-doc
%description help
psgtest
Simple Python Testing
Run your Python programs using the interpreter version of your choice, and display the output in a GUI window.
![psgtest 3 0](https://user-images.githubusercontent.com/46163555/233642958-730f19f0-43a9-4bea-833e-9524c2d770ff.gif)
## Installation
### Old-school Straight Pip
pip install psgtest
### pip via `python -m pip` the python recommended way
#### If `python` is your command
`python -m pip install psgtest`
#### If `python3` is your command
`python3 -m pip install psgtest`
## Usage
Once pip installed, you can launch psgtest by typing on the command line:
`psgtest`
You can also create a Windows shortcut by following the instructions below.
## About
This is an example of another utility used in the development of PySimpleGUI that is being released for other PySimpleGUI users to use either as a standalone tool or as example code / design pattern to follow.
It can be challenging to manage multiple versions of Python and the need to test across multiple versions. Virtual Environments are one approach that are often used. psgtest does not use virtual environments. Instead, it invokes the Python interpreter of your choice directly.
The advantage is that changing which version of Python that's used is changed in a single drop-down menu selection as shown in the example GIF above. The session in the GIF shows launching the PySimpleGUI main test harness using multiple versions of Python by selecting the version from the drop-down at the top.
## Executing Multiple Programs
To run multiple programs, select the files to run from the list of files on the left portion of the window. Then click the "Run" button.
## Editing Programs
You can also edit the programs selected by clicking the "Edit" button. You will need to set up your editor using the PySimpleGUI global settings. If you have pip installed a version of PySimpleGUI that's 4.53.0.14 or greater, then you can type `psgsettings` from the command line. You can also change the settings by calling `sg.main()` (or typing from the command line `psgmain`).
## Specifying/Selecting Python Interpreter Locations
The Setup Window is where you enter the path to each version of Python that you want to test with. The settings are stored in a file and thus will be saved from one run to another.
Selecting the version to use can be done in either the settings window or using the drop-down menu in the main window.
## Output
The stdout and stderr from each program you execute are displayed in a tab with a name that matches your filename. Each program you run will open a new tab.
In each tab you'll find 2 buttons that operate on the output shown in that tab.
Use the `Copy To Clipboard` button to copy the contents of the output to the clipboard.
Use the `Clear` button to delete the output.
The `Close Tab` button closes the tab as does the right click menu item `Close`. If you run the program again after closing the tab, the old contents of the tab are retained and shown when the tab is "re-opened". (See the GIF above for an example)
## Make a Windows Shortcut
If you're running Windows, then you can use `psgshortcut` to make a shortcut to the .pyw file (if you download psgtest from GitHub) or the .py file (if you pip installed). The icon for `psgtest` is in this repo and is also included when you pip install psgtest. It's in the same folder as the gui.py file.
You can find the location of psgtest after pip installing it by running psgtest, right clicking, and choosing "File Location". You'll be shown where the `gui.py` file is located (the name of the psgtest program when pip installed). It will usually be located in the `site-packages` folder in a folder named `psgtest`.
Instructions on how to make shortcuts to pip installed PySimpleGUI programs can be found in [description for psgshortcut on PyPI](https://pypi.org/project/psgshortcut/).
## Release Notes
### 3.4 29-Apr-2023
- Allow non-python programs to be run. If the file does not end in .py or .pyw, then the file will be executed directly
### 3.3 23-Apr-2023
- Remove the entry from sp_to_filename when killing process
### 3.2 22-Apr-2023
- Added piped output for regression testing
- Added cleanup of processes when exiting. If any processes are running, they will be killed.
### 3.0 21-Apr-2023
- Greatly expanded the Regression test features
- Made regression multi-threaded
- Added testing across all Python interpreters
- Removed direct calls to Python Thread module and using only PySimpleGUI supplied calls
### 1.13.0
* Run all Interpreters feature added
### 1.12.0
* Addition of a "custom release" of Python entry in setup
* Enables using other "Python flavors" like pypy
* One custom item is allowed
### 1.11.0
* Addition of a "run a single file" option so that you can quickly and easily test one program against many versions of Python
### 1.10.0
* Regression Test Feature - run large sets of tests. Will keep tabs open that have failures and show an error popup
### 1.9.0
* Fix for exception when no settings are initially found. Oy.... bad bug to have released reight away
* Will create a settings file with the currently running version of Python if one is not found
* Added minimum of 4.55.1 requirement for PySimpleGUI to the setup.py file
### 1.8.0
* Support for Python 3.4, 3.5, 3.11 added to settings
* Set the settings filename to be `psgtest` instead of the default filename. This is needed because the file for these psg projects on PyPI are all name gui.py and thus will have all point to the same settings file if not explicitly set
* Only show configured interpreters in the Combo in main window
## License
Licensed under an LGPL3 License
## Designed and Written By
Mike from PySimpleGUI.org
## Contributing
Like the PySimpleGUI project, this project is currently licensed under an open-source license, the project itself is structured like a proprietary product. Pull Requests are not accepted.
## Copyright
Copyright 2021 PySimpleGUI
%prep
%autosetup -n psgtest-3.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-psgtest -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 15 2023 Python_Bot - 3.4-1
- Package Spec generated