%global _empty_manifest_terminate_build 0
Name:		python-budy-api
Version:	0.5.0
Release:	1
Summary:	Budy API Client
License:	Apache License, Version 2.0
URL:		http://budy-api.hive.pt
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/a1/0d/e960039ed6754afb80d1b0fcd7c06aef0d4fcf0e1970b00aa4722519ddee/budy-api-0.5.0.tar.gz
BuildArch:	noarch

Requires:	python3-appier

%description
# [Budy API](http://budy-api.hive.pt)

[Budy](http://budy.hive.pt) API Python client, to be used for simple synchronous integration.

## Configuration

| Name              | Type  | Default                      | Description                                                                                                              |
| ----------------- | ----- | ---------------------------- | ------------------------------------------------------------------------------------------------------------------------ |
| **BUDY_BASE_URL** | `str` | `http://localhost:8080/api/` | The base URL that is going to be used for API connections.                                                               |
| **BUDY_COUNTRY**  | `str` | `US`                         | The country as an ISO 3166-1 to be used for API interactions.                                                            |
| **BUDY_CURRENCY** | `str` | `USD`                        | The [ISO 4217](https://en.wikipedia.org/wiki/ISO_4217) code that describes the currency to be used for API interactions. |
| **BUDY_USERNAME** | `str` | `None`                       | The username to be used for authentication.                                                                              |
| **BUDY_PASSWORD** | `str` | `None`                       | The password to be user for authentication.                                                                              |

## License

Budy API is currently licensed under the [Apache License, Version 2.0](http://www.apache.org/licenses/).

## Build Automation

[![Build Status](https://app.travis-ci.com/hivesolutions/budy-api.svg?branch=master)](https://travis-ci.com/github/hivesolutions/budy-api)
[![Build Status GitHub](https://github.com/hivesolutions/budy-api/workflows/Main%20Workflow/badge.svg)](https://github.com/hivesolutions/budy-api/actions)
[![Coverage Status](https://coveralls.io/repos/hivesolutions/budy-api/badge.svg?branch=master)](https://coveralls.io/r/hivesolutions/budy-api?branch=master)
[![PyPi Status](https://img.shields.io/pypi/v/budy-api.svg)](https://pypi.python.org/pypi/budy-api)
[![License](https://img.shields.io/badge/license-Apache%202.0-blue.svg)](https://www.apache.org/licenses/)




%package -n python3-budy-api
Summary:	Budy API Client
Provides:	python-budy-api
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-budy-api
# [Budy API](http://budy-api.hive.pt)

[Budy](http://budy.hive.pt) API Python client, to be used for simple synchronous integration.

## Configuration

| Name              | Type  | Default                      | Description                                                                                                              |
| ----------------- | ----- | ---------------------------- | ------------------------------------------------------------------------------------------------------------------------ |
| **BUDY_BASE_URL** | `str` | `http://localhost:8080/api/` | The base URL that is going to be used for API connections.                                                               |
| **BUDY_COUNTRY**  | `str` | `US`                         | The country as an ISO 3166-1 to be used for API interactions.                                                            |
| **BUDY_CURRENCY** | `str` | `USD`                        | The [ISO 4217](https://en.wikipedia.org/wiki/ISO_4217) code that describes the currency to be used for API interactions. |
| **BUDY_USERNAME** | `str` | `None`                       | The username to be used for authentication.                                                                              |
| **BUDY_PASSWORD** | `str` | `None`                       | The password to be user for authentication.                                                                              |

## License

Budy API is currently licensed under the [Apache License, Version 2.0](http://www.apache.org/licenses/).

## Build Automation

[![Build Status](https://app.travis-ci.com/hivesolutions/budy-api.svg?branch=master)](https://travis-ci.com/github/hivesolutions/budy-api)
[![Build Status GitHub](https://github.com/hivesolutions/budy-api/workflows/Main%20Workflow/badge.svg)](https://github.com/hivesolutions/budy-api/actions)
[![Coverage Status](https://coveralls.io/repos/hivesolutions/budy-api/badge.svg?branch=master)](https://coveralls.io/r/hivesolutions/budy-api?branch=master)
[![PyPi Status](https://img.shields.io/pypi/v/budy-api.svg)](https://pypi.python.org/pypi/budy-api)
[![License](https://img.shields.io/badge/license-Apache%202.0-blue.svg)](https://www.apache.org/licenses/)




%package help
Summary:	Development documents and examples for budy-api
Provides:	python3-budy-api-doc
%description help
# [Budy API](http://budy-api.hive.pt)

[Budy](http://budy.hive.pt) API Python client, to be used for simple synchronous integration.

## Configuration

| Name              | Type  | Default                      | Description                                                                                                              |
| ----------------- | ----- | ---------------------------- | ------------------------------------------------------------------------------------------------------------------------ |
| **BUDY_BASE_URL** | `str` | `http://localhost:8080/api/` | The base URL that is going to be used for API connections.                                                               |
| **BUDY_COUNTRY**  | `str` | `US`                         | The country as an ISO 3166-1 to be used for API interactions.                                                            |
| **BUDY_CURRENCY** | `str` | `USD`                        | The [ISO 4217](https://en.wikipedia.org/wiki/ISO_4217) code that describes the currency to be used for API interactions. |
| **BUDY_USERNAME** | `str` | `None`                       | The username to be used for authentication.                                                                              |
| **BUDY_PASSWORD** | `str` | `None`                       | The password to be user for authentication.                                                                              |

## License

Budy API is currently licensed under the [Apache License, Version 2.0](http://www.apache.org/licenses/).

## Build Automation

[![Build Status](https://app.travis-ci.com/hivesolutions/budy-api.svg?branch=master)](https://travis-ci.com/github/hivesolutions/budy-api)
[![Build Status GitHub](https://github.com/hivesolutions/budy-api/workflows/Main%20Workflow/badge.svg)](https://github.com/hivesolutions/budy-api/actions)
[![Coverage Status](https://coveralls.io/repos/hivesolutions/budy-api/badge.svg?branch=master)](https://coveralls.io/r/hivesolutions/budy-api?branch=master)
[![PyPi Status](https://img.shields.io/pypi/v/budy-api.svg)](https://pypi.python.org/pypi/budy-api)
[![License](https://img.shields.io/badge/license-Apache%202.0-blue.svg)](https://www.apache.org/licenses/)




%prep
%autosetup -n budy-api-0.5.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-budy-api -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.0-1
- Package Spec generated