%global _empty_manifest_terminate_build 0
Name: python-projpicker
Version: 0.3.2
Release: 1
Summary: ProjPicker (projection picker) allows the user to select all projections whose extent completely contains given points, polylines, polygons, and bounding boxes. The goal is to make it easy and visual to select a desired projection by location.
License: GPLv3+
URL: https://github.com/HuidaeCho/projpicker
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ec/8f/718c314e3a9bf295d752f883350fd395fbf68533b4b3f974f417232debc7/projpicker-0.3.2.tar.gz
BuildArch: noarch
%description
# ProjPicker
[![PyPI version](https://badge.fury.io/py/projpicker.svg)](https://badge.fury.io/py/projpicker)
[![Documentation Status](https://readthedocs.org/projects/projpicker/badge/?version=latest)](https://projpicker.readthedocs.io/en/latest/?badge=latest)
[ProjPicker](https://github.com/HuidaeCho/projpicker) (projection picker) is a
Python module that allows the user to select all coordinate reference systems
(CRSs) whose extent completely contains given points, polylines, polygons, and
bounding boxes using set-theoretic logical operators in a postfix notation. The
goal is to make it easy and visual to select a desired projection by location.
This project was motivated by
[a GRASS GIS feature request](https://github.com/OSGeo/grass/issues/1253).
See [its documentation](https://projpicker.readthedocs.io/en/latest/).
The project uses a copy of [GetOSM](https://github.com/HuidaeCho/getosm) to
download OpenStreetMap tiles.
ProjPicker Web is online at https://projpicker.pythonanywhere.com/.
For [GRASS GIS](https://grass.osgeo.org/), a new module
[g.projpicker](https://grass.osgeo.org/grass78/manuals/addons/g.projpicker.html)
that wraps around this project is available.
![image](https://user-images.githubusercontent.com/7456117/127779380-f8db8904-df17-4418-b7fa-fff17971517d.png)
![image](https://user-images.githubusercontent.com/7456117/127757336-d9bca6e0-b51e-4a68-acfc-265ab58b89f7.png)
## ProjPicker running on Android using [Termux](https://termux.com/)
1. Install [Termux](https://termux.com/) from [F-Droid](https://f-droid.org/packages/com.termux/)
2. Run it from Android
3. Install Python: `pkg install python`
4. Install ProjPicker: `pip install projpicker`
5. Start the ProjPicker web server: `projpicker -S`
6. Open `http://localhost:8000/` in the browser
## Change log
See [here](https://github.com/HuidaeCho/projpicker/blob/main/ChangeLog.md).
## Subprojects
* [ProjPicker ArcGIS Pro toolbox](https://github.com/HuidaeCho/projpicker-arcgispro) (Windows)
* [ProjPicker GUI](https://github.com/HuidaeCho/projpicker-gui) (Linux and macOS; replaced by the core wxPython-based GUI)
* [ProjPicker JavaScript](https://github.com/HuidaeCho/projpicker-js) (not under active development)
## Ideas
1. Client-only web application that doesn't require Python in the backend
2. CRS hints: Crowdsourcing agency and product information? Is usage from PROJ enough?
## Versioning
`N(.N)*[{a|b|rc}N][.postN][.devN]`
* [PEP 440](https://www.python.org/dev/peps/pep-0440/)
* `{a|b|rc|.dev}N` towards and `.postN` away from the release
* Not fully compatible with [semantic versioning](https://semver.org/)
* Not using build numbers marching away from or towards a release, but check
this [interesting
comment](https://github.com/semver/semver/issues/51#issuecomment-9718111).
## Sponsor
This project was kindly funded by [the Institute for Environmental and Spatial
Analysis](https://ung.edu/institute-environmental-spatial-analysis/) (IESA) at
[the University of North Georgia](https://ung.edu/) (UNG).
## License
Copyright (C) 2021 [Huidae Cho](https://faculty.ung.edu/hcho/) and
[Owen Smith](https://www.gaderian.io/)
This program is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation, either version 3 of the License, or
(at your option) any later version.
This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.
You should have received a copy of the GNU General Public License
along with this program. If not, see <>.
%package -n python3-projpicker
Summary: ProjPicker (projection picker) allows the user to select all projections whose extent completely contains given points, polylines, polygons, and bounding boxes. The goal is to make it easy and visual to select a desired projection by location.
Provides: python-projpicker
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-projpicker
# ProjPicker
[![PyPI version](https://badge.fury.io/py/projpicker.svg)](https://badge.fury.io/py/projpicker)
[![Documentation Status](https://readthedocs.org/projects/projpicker/badge/?version=latest)](https://projpicker.readthedocs.io/en/latest/?badge=latest)
[ProjPicker](https://github.com/HuidaeCho/projpicker) (projection picker) is a
Python module that allows the user to select all coordinate reference systems
(CRSs) whose extent completely contains given points, polylines, polygons, and
bounding boxes using set-theoretic logical operators in a postfix notation. The
goal is to make it easy and visual to select a desired projection by location.
This project was motivated by
[a GRASS GIS feature request](https://github.com/OSGeo/grass/issues/1253).
See [its documentation](https://projpicker.readthedocs.io/en/latest/).
The project uses a copy of [GetOSM](https://github.com/HuidaeCho/getosm) to
download OpenStreetMap tiles.
ProjPicker Web is online at https://projpicker.pythonanywhere.com/.
For [GRASS GIS](https://grass.osgeo.org/), a new module
[g.projpicker](https://grass.osgeo.org/grass78/manuals/addons/g.projpicker.html)
that wraps around this project is available.
![image](https://user-images.githubusercontent.com/7456117/127779380-f8db8904-df17-4418-b7fa-fff17971517d.png)
![image](https://user-images.githubusercontent.com/7456117/127757336-d9bca6e0-b51e-4a68-acfc-265ab58b89f7.png)
## ProjPicker running on Android using [Termux](https://termux.com/)
1. Install [Termux](https://termux.com/) from [F-Droid](https://f-droid.org/packages/com.termux/)
2. Run it from Android
3. Install Python: `pkg install python`
4. Install ProjPicker: `pip install projpicker`
5. Start the ProjPicker web server: `projpicker -S`
6. Open `http://localhost:8000/` in the browser
## Change log
See [here](https://github.com/HuidaeCho/projpicker/blob/main/ChangeLog.md).
## Subprojects
* [ProjPicker ArcGIS Pro toolbox](https://github.com/HuidaeCho/projpicker-arcgispro) (Windows)
* [ProjPicker GUI](https://github.com/HuidaeCho/projpicker-gui) (Linux and macOS; replaced by the core wxPython-based GUI)
* [ProjPicker JavaScript](https://github.com/HuidaeCho/projpicker-js) (not under active development)
## Ideas
1. Client-only web application that doesn't require Python in the backend
2. CRS hints: Crowdsourcing agency and product information? Is usage from PROJ enough?
## Versioning
`N(.N)*[{a|b|rc}N][.postN][.devN]`
* [PEP 440](https://www.python.org/dev/peps/pep-0440/)
* `{a|b|rc|.dev}N` towards and `.postN` away from the release
* Not fully compatible with [semantic versioning](https://semver.org/)
* Not using build numbers marching away from or towards a release, but check
this [interesting
comment](https://github.com/semver/semver/issues/51#issuecomment-9718111).
## Sponsor
This project was kindly funded by [the Institute for Environmental and Spatial
Analysis](https://ung.edu/institute-environmental-spatial-analysis/) (IESA) at
[the University of North Georgia](https://ung.edu/) (UNG).
## License
Copyright (C) 2021 [Huidae Cho](https://faculty.ung.edu/hcho/) and
[Owen Smith](https://www.gaderian.io/)
This program is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation, either version 3 of the License, or
(at your option) any later version.
This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.
You should have received a copy of the GNU General Public License
along with this program. If not, see <>.
%package help
Summary: Development documents and examples for projpicker
Provides: python3-projpicker-doc
%description help
# ProjPicker
[![PyPI version](https://badge.fury.io/py/projpicker.svg)](https://badge.fury.io/py/projpicker)
[![Documentation Status](https://readthedocs.org/projects/projpicker/badge/?version=latest)](https://projpicker.readthedocs.io/en/latest/?badge=latest)
[ProjPicker](https://github.com/HuidaeCho/projpicker) (projection picker) is a
Python module that allows the user to select all coordinate reference systems
(CRSs) whose extent completely contains given points, polylines, polygons, and
bounding boxes using set-theoretic logical operators in a postfix notation. The
goal is to make it easy and visual to select a desired projection by location.
This project was motivated by
[a GRASS GIS feature request](https://github.com/OSGeo/grass/issues/1253).
See [its documentation](https://projpicker.readthedocs.io/en/latest/).
The project uses a copy of [GetOSM](https://github.com/HuidaeCho/getosm) to
download OpenStreetMap tiles.
ProjPicker Web is online at https://projpicker.pythonanywhere.com/.
For [GRASS GIS](https://grass.osgeo.org/), a new module
[g.projpicker](https://grass.osgeo.org/grass78/manuals/addons/g.projpicker.html)
that wraps around this project is available.
![image](https://user-images.githubusercontent.com/7456117/127779380-f8db8904-df17-4418-b7fa-fff17971517d.png)
![image](https://user-images.githubusercontent.com/7456117/127757336-d9bca6e0-b51e-4a68-acfc-265ab58b89f7.png)
## ProjPicker running on Android using [Termux](https://termux.com/)
1. Install [Termux](https://termux.com/) from [F-Droid](https://f-droid.org/packages/com.termux/)
2. Run it from Android
3. Install Python: `pkg install python`
4. Install ProjPicker: `pip install projpicker`
5. Start the ProjPicker web server: `projpicker -S`
6. Open `http://localhost:8000/` in the browser
## Change log
See [here](https://github.com/HuidaeCho/projpicker/blob/main/ChangeLog.md).
## Subprojects
* [ProjPicker ArcGIS Pro toolbox](https://github.com/HuidaeCho/projpicker-arcgispro) (Windows)
* [ProjPicker GUI](https://github.com/HuidaeCho/projpicker-gui) (Linux and macOS; replaced by the core wxPython-based GUI)
* [ProjPicker JavaScript](https://github.com/HuidaeCho/projpicker-js) (not under active development)
## Ideas
1. Client-only web application that doesn't require Python in the backend
2. CRS hints: Crowdsourcing agency and product information? Is usage from PROJ enough?
## Versioning
`N(.N)*[{a|b|rc}N][.postN][.devN]`
* [PEP 440](https://www.python.org/dev/peps/pep-0440/)
* `{a|b|rc|.dev}N` towards and `.postN` away from the release
* Not fully compatible with [semantic versioning](https://semver.org/)
* Not using build numbers marching away from or towards a release, but check
this [interesting
comment](https://github.com/semver/semver/issues/51#issuecomment-9718111).
## Sponsor
This project was kindly funded by [the Institute for Environmental and Spatial
Analysis](https://ung.edu/institute-environmental-spatial-analysis/) (IESA) at
[the University of North Georgia](https://ung.edu/) (UNG).
## License
Copyright (C) 2021 [Huidae Cho](https://faculty.ung.edu/hcho/) and
[Owen Smith](https://www.gaderian.io/)
This program is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation, either version 3 of the License, or
(at your option) any later version.
This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.
You should have received a copy of the GNU General Public License
along with this program. If not, see <>.
%prep
%autosetup -n projpicker-0.3.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-projpicker -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon May 15 2023 Python_Bot - 0.3.2-1
- Package Spec generated