%global _empty_manifest_terminate_build 0
Name:		python-csv342
Version:	1.0.1
Release:	1
Summary:	Python 3 like CSV module for Python 2
License:	BSD-3-Clause
URL:		http://pypi.python.org/pypi/csv342/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/ea/a1/fb5743484af7a86e1c41f398aac2885a7ec6f82260e353483b564efcf1a4/csv342-1.0.1.zip
BuildArch:	noarch


%description
csv342 is a Python module similar to the the csv module in the standard
library. Under Python 3, it just calls the standard csv module. Under
Python 2, it provides a Python 3 like interface to reading and writing CSV
files, in particular concerning non ASCII characters.
It is distributed under the BSD license. The source code is available from
https://github.com/roskakori/csv342.

%package -n python3-csv342
Summary:	Python 3 like CSV module for Python 2
Provides:	python-csv342
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-csv342
csv342 is a Python module similar to the the csv module in the standard
library. Under Python 3, it just calls the standard csv module. Under
Python 2, it provides a Python 3 like interface to reading and writing CSV
files, in particular concerning non ASCII characters.
It is distributed under the BSD license. The source code is available from
https://github.com/roskakori/csv342.

%package help
Summary:	Development documents and examples for csv342
Provides:	python3-csv342-doc
%description help
csv342 is a Python module similar to the the csv module in the standard
library. Under Python 3, it just calls the standard csv module. Under
Python 2, it provides a Python 3 like interface to reading and writing CSV
files, in particular concerning non ASCII characters.
It is distributed under the BSD license. The source code is available from
https://github.com/roskakori/csv342.

%prep
%autosetup -n csv342-1.0.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-csv342 -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.1-1
- Package Spec generated