%global _empty_manifest_terminate_build 0
Name:		python-azblob
Version:	1.0.0
Release:	1
Summary:	Download Azure blobs.
License:	MIT License
URL:		https://github.com/plang85/azblob
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/3b/2a/b06f09bc306dfa086e747f87d215e2ac233b6694759bdb3fd6b09b0e2be3/azblob-1.0.0.tar.gz
BuildArch:	noarch


%description
# Azure Blob

[![PyPI version](https://badge.fury.io/py/azblob.svg)](https://badge.fury.io/py/azblob)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/ambv/black)


One-line CLI to download from Azure blob storage. Supports private blobs.


## Installation

To install:

```
$ pip install azblob
```

## CLI

### Download blob (and authentication illustration)
**Anonymous** access, account name from command line
```
$ azblob -n account_url download my_container my_blob
```
where `account_url` is e.g. `https://<storage name>.blob.core.windows.net`
**Anonymous** access, account name from environment
```
$ export AZBLOB_ACCOUNTNAME=account_url
$ azblob download my_container my_blob
```

**Private** container, credentials from command line
```
$ azblob -n account_url -k my_key download my_container my_blob
```

**Private** container, credentials from environment
```
$ export AZBLOB_ACCOUNTNAME=account_url
$ export AZBLOB_ACCOUNTKEY=my_key
$ azblob download my_container my_blob
```

### List blobs
Same authentication mechanism. List blobs in `my_container`
```
azblob list my_container
```

and, as always
```
$ azblob -h
$ azblob download -h
$ azblob list -h
```

%package -n python3-azblob
Summary:	Download Azure blobs.
Provides:	python-azblob
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-azblob
# Azure Blob

[![PyPI version](https://badge.fury.io/py/azblob.svg)](https://badge.fury.io/py/azblob)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/ambv/black)


One-line CLI to download from Azure blob storage. Supports private blobs.


## Installation

To install:

```
$ pip install azblob
```

## CLI

### Download blob (and authentication illustration)
**Anonymous** access, account name from command line
```
$ azblob -n account_url download my_container my_blob
```
where `account_url` is e.g. `https://<storage name>.blob.core.windows.net`
**Anonymous** access, account name from environment
```
$ export AZBLOB_ACCOUNTNAME=account_url
$ azblob download my_container my_blob
```

**Private** container, credentials from command line
```
$ azblob -n account_url -k my_key download my_container my_blob
```

**Private** container, credentials from environment
```
$ export AZBLOB_ACCOUNTNAME=account_url
$ export AZBLOB_ACCOUNTKEY=my_key
$ azblob download my_container my_blob
```

### List blobs
Same authentication mechanism. List blobs in `my_container`
```
azblob list my_container
```

and, as always
```
$ azblob -h
$ azblob download -h
$ azblob list -h
```

%package help
Summary:	Development documents and examples for azblob
Provides:	python3-azblob-doc
%description help
# Azure Blob

[![PyPI version](https://badge.fury.io/py/azblob.svg)](https://badge.fury.io/py/azblob)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/ambv/black)


One-line CLI to download from Azure blob storage. Supports private blobs.


## Installation

To install:

```
$ pip install azblob
```

## CLI

### Download blob (and authentication illustration)
**Anonymous** access, account name from command line
```
$ azblob -n account_url download my_container my_blob
```
where `account_url` is e.g. `https://<storage name>.blob.core.windows.net`
**Anonymous** access, account name from environment
```
$ export AZBLOB_ACCOUNTNAME=account_url
$ azblob download my_container my_blob
```

**Private** container, credentials from command line
```
$ azblob -n account_url -k my_key download my_container my_blob
```

**Private** container, credentials from environment
```
$ export AZBLOB_ACCOUNTNAME=account_url
$ export AZBLOB_ACCOUNTKEY=my_key
$ azblob download my_container my_blob
```

### List blobs
Same authentication mechanism. List blobs in `my_container`
```
azblob list my_container
```

and, as always
```
$ azblob -h
$ azblob download -h
$ azblob list -h
```

%prep
%autosetup -n azblob-1.0.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-azblob -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.0-1
- Package Spec generated