%global _empty_manifest_terminate_build 0
Name:		python-imreg_dft
Version:	2.0.0
Release:	1
Summary:	Image registration utility using algorithms based on discrete Fourier transform (DFT, FFT)
License:	BSD
URL:		https://github.com/matejak/imreg_dft
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/c3/68/57cf1e086e8cc8f75a647e8815d7cb5f9dc4686031687aad5e8e30980ce4/imreg_dft-2.0.0.tar.gz
BuildArch:	noarch


%description
``imreg_dft`` is your first-choice Python image registration utility.
In plain language, it implements means of guessing translation, rotation and scale variation between two images.
The name comes from the fact that it doesn't work with those images directly, but it works with their spectrum (DFT using FFT), and its log-polar transformation [1]_, hence the ``_dft`` after ``imreg``.
Basically, if you want to align two images that have different scale and are rotated and shifted against each other, ``imreg_dft`` is the tool you want to check out.
`Get started <http://pythonhosted.org/imreg_dft/quickstart.html#quickstart>`_ in five minutes and see how it works for you!
  - `Matěj Týč <https://github.com/matejak>`_ `PGP public key <https://keyserver.mattrude.com/pks/lookup?op=get&search=0x607524F854FD905F>`_
  - `Christoph Gohlke <http://www.lfd.uci.edu/~gohlke/>`_
  - Brno University of Technology, Brno, Czech Republic
  - Laboratory for Fluorescence Dynamics, University of California, Irvine
  - 2014-2015, Matěj Týč
  - 2011-2014, Christoph Gohlke

%package -n python3-imreg_dft
Summary:	Image registration utility using algorithms based on discrete Fourier transform (DFT, FFT)
Provides:	python-imreg_dft
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-imreg_dft
``imreg_dft`` is your first-choice Python image registration utility.
In plain language, it implements means of guessing translation, rotation and scale variation between two images.
The name comes from the fact that it doesn't work with those images directly, but it works with their spectrum (DFT using FFT), and its log-polar transformation [1]_, hence the ``_dft`` after ``imreg``.
Basically, if you want to align two images that have different scale and are rotated and shifted against each other, ``imreg_dft`` is the tool you want to check out.
`Get started <http://pythonhosted.org/imreg_dft/quickstart.html#quickstart>`_ in five minutes and see how it works for you!
  - `Matěj Týč <https://github.com/matejak>`_ `PGP public key <https://keyserver.mattrude.com/pks/lookup?op=get&search=0x607524F854FD905F>`_
  - `Christoph Gohlke <http://www.lfd.uci.edu/~gohlke/>`_
  - Brno University of Technology, Brno, Czech Republic
  - Laboratory for Fluorescence Dynamics, University of California, Irvine
  - 2014-2015, Matěj Týč
  - 2011-2014, Christoph Gohlke

%package help
Summary:	Development documents and examples for imreg_dft
Provides:	python3-imreg_dft-doc
%description help
``imreg_dft`` is your first-choice Python image registration utility.
In plain language, it implements means of guessing translation, rotation and scale variation between two images.
The name comes from the fact that it doesn't work with those images directly, but it works with their spectrum (DFT using FFT), and its log-polar transformation [1]_, hence the ``_dft`` after ``imreg``.
Basically, if you want to align two images that have different scale and are rotated and shifted against each other, ``imreg_dft`` is the tool you want to check out.
`Get started <http://pythonhosted.org/imreg_dft/quickstart.html#quickstart>`_ in five minutes and see how it works for you!
  - `Matěj Týč <https://github.com/matejak>`_ `PGP public key <https://keyserver.mattrude.com/pks/lookup?op=get&search=0x607524F854FD905F>`_
  - `Christoph Gohlke <http://www.lfd.uci.edu/~gohlke/>`_
  - Brno University of Technology, Brno, Czech Republic
  - Laboratory for Fluorescence Dynamics, University of California, Irvine
  - 2014-2015, Matěj Týč
  - 2011-2014, Christoph Gohlke

%prep
%autosetup -n imreg_dft-2.0.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-imreg_dft -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0.0-1
- Package Spec generated