%global _empty_manifest_terminate_build 0
Name: python-ARS
Version: 0.5b1
Release: 1
Summary: Physically-accurate robotics simulator
License: UNKNOWN
URL: http://bitbucket.org/glarrain/ars
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/48/75/a0d60af5de900d5e1338397caf942dca4644ac53e812f3247848e599826d/ARS-0.5b1.tar.gz
BuildArch: noarch
%description
ARS is a physically-accurate robotics simulator written in Python.
It's main purpose is to help researchers to develop mobile
manipulators and, in general, any multi-body system. It
is open-source, modular, easy to learn and use,
and can be a valuable tool in the process
of robot design, in the development of control and reasoning algorithms, as
well as in teaching and educational activities.
It will encompass a wide range of tools spanning from kinematics and dynamics
simulation to robot interfacing and control.
ARS uses
`Open Dynamics Engine (ODE) `_
as physics engine, and
`Visualization Toolkit (VTK) `_
as graphics engine.
While both are well regarded and popular open-source software,
ARS was designed to minimize coupling with them
(through included abstraction layers)
to let developers experiment with other alternatives.
%package -n python3-ARS
Summary: Physically-accurate robotics simulator
Provides: python-ARS
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-ARS
ARS is a physically-accurate robotics simulator written in Python.
It's main purpose is to help researchers to develop mobile
manipulators and, in general, any multi-body system. It
is open-source, modular, easy to learn and use,
and can be a valuable tool in the process
of robot design, in the development of control and reasoning algorithms, as
well as in teaching and educational activities.
It will encompass a wide range of tools spanning from kinematics and dynamics
simulation to robot interfacing and control.
ARS uses
`Open Dynamics Engine (ODE) `_
as physics engine, and
`Visualization Toolkit (VTK) `_
as graphics engine.
While both are well regarded and popular open-source software,
ARS was designed to minimize coupling with them
(through included abstraction layers)
to let developers experiment with other alternatives.
%package help
Summary: Development documents and examples for ARS
Provides: python3-ARS-doc
%description help
ARS is a physically-accurate robotics simulator written in Python.
It's main purpose is to help researchers to develop mobile
manipulators and, in general, any multi-body system. It
is open-source, modular, easy to learn and use,
and can be a valuable tool in the process
of robot design, in the development of control and reasoning algorithms, as
well as in teaching and educational activities.
It will encompass a wide range of tools spanning from kinematics and dynamics
simulation to robot interfacing and control.
ARS uses
`Open Dynamics Engine (ODE) `_
as physics engine, and
`Visualization Toolkit (VTK) `_
as graphics engine.
While both are well regarded and popular open-source software,
ARS was designed to minimize coupling with them
(through included abstraction layers)
to let developers experiment with other alternatives.
%prep
%autosetup -n ARS-0.5b1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-ARS -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed May 17 2023 Python_Bot - 0.5b1-1
- Package Spec generated