%global _empty_manifest_terminate_build 0
Name:		python-gcMapExplorer
Version:	1.0.30
Release:	1
Summary:	A platform to visualize and analyze genome contact maps
License:	GNU General Public License v3 (GPLv3)
URL:		https://github.com/rjdkmr/gcMapExplorer
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/62/4b/2ad0eb023179f2f1d1579941a68fcd64dd92a185d04dacaa1f85356d71f7/gcMapExplorer-1.0.30.tar.gz
BuildArch:	noarch

Requires:	python3-appdirs
Requires:	python3-numpy
Requires:	python3-scipy
Requires:	python3-matplotlib
Requires:	python3-dask
Requires:	python3-toolz
Requires:	python3-psutil
Requires:	python3-h5py
Requires:	python3-Cython
Requires:	python3-scikit-learn

%description
It is a platform to visualize and analyze the contact maps that are generated from Hi-C experiments. This package is developed by considering the huge size of contact maps at very fine resolution. It contains
* Graphical user interface - Several windows like applications to perform tasks (See below tables).
* Command Line Interface - Several commands to perform tasks (See below tables).
* `Application Programming Interface <http://gcmapexplorer.readthedocs.io/en/latest/apidoc/summary.html>`_
  - It can be used to perform analysis by any mathematical operations through programming.
**For more details, visit:** `gcMapExplorer Homepage <http://gcmapexplorer.readthedocs.io/>`_
**For Discussion and Questions, visit** `this forum <https://groups.google.com/forum/#!forum/gcmapexplorer>`_

%package -n python3-gcMapExplorer
Summary:	A platform to visualize and analyze genome contact maps
Provides:	python-gcMapExplorer
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-gcMapExplorer
It is a platform to visualize and analyze the contact maps that are generated from Hi-C experiments. This package is developed by considering the huge size of contact maps at very fine resolution. It contains
* Graphical user interface - Several windows like applications to perform tasks (See below tables).
* Command Line Interface - Several commands to perform tasks (See below tables).
* `Application Programming Interface <http://gcmapexplorer.readthedocs.io/en/latest/apidoc/summary.html>`_
  - It can be used to perform analysis by any mathematical operations through programming.
**For more details, visit:** `gcMapExplorer Homepage <http://gcmapexplorer.readthedocs.io/>`_
**For Discussion and Questions, visit** `this forum <https://groups.google.com/forum/#!forum/gcmapexplorer>`_

%package help
Summary:	Development documents and examples for gcMapExplorer
Provides:	python3-gcMapExplorer-doc
%description help
It is a platform to visualize and analyze the contact maps that are generated from Hi-C experiments. This package is developed by considering the huge size of contact maps at very fine resolution. It contains
* Graphical user interface - Several windows like applications to perform tasks (See below tables).
* Command Line Interface - Several commands to perform tasks (See below tables).
* `Application Programming Interface <http://gcmapexplorer.readthedocs.io/en/latest/apidoc/summary.html>`_
  - It can be used to perform analysis by any mathematical operations through programming.
**For more details, visit:** `gcMapExplorer Homepage <http://gcmapexplorer.readthedocs.io/>`_
**For Discussion and Questions, visit** `this forum <https://groups.google.com/forum/#!forum/gcmapexplorer>`_

%prep
%autosetup -n gcMapExplorer-1.0.30

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-gcMapExplorer -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 17 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.30-1
- Package Spec generated