%global _empty_manifest_terminate_build 0
Name:		python-quoters
Version:	0.30
Release:	1
Summary:	Pythonic random quote generator
License:	MIT
URL:		https://github.com/suman-kr/quoters
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/5d/62/afe5c6334cbb41808f7df61f58190bece854988b5adc8528bbd4bddcbf81/quoters-0.30.tar.gz
BuildArch:	noarch


%description
quoters
``A python library that gives you beautiful quotes.``

# To install
``pip install quoters``

# Documentation
``https://github.com/suman-kr/quoters``

%package -n python3-quoters
Summary:	Pythonic random quote generator
Provides:	python-quoters
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-quoters
quoters
``A python library that gives you beautiful quotes.``

# To install
``pip install quoters``

# Documentation
``https://github.com/suman-kr/quoters``

%package help
Summary:	Development documents and examples for quoters
Provides:	python3-quoters-doc
%description help
quoters
``A python library that gives you beautiful quotes.``

# To install
``pip install quoters``

# Documentation
``https://github.com/suman-kr/quoters``

%prep
%autosetup -n quoters-0.30

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-quoters -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed May 17 2023 Python_Bot <Python_Bot@openeuler.org> - 0.30-1
- Package Spec generated