%global _empty_manifest_terminate_build 0
Name:		python-pefile2
Version:	1.2.11
Release:	1
Summary:	Python PE parsing module
License:	UNKNOWN
URL:		http://code.google.com/p/pefile/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/a1/ab/61489e4acfaa41ffb53b821f649646cd79f5787886aadc30c4058fd6ec3c/pefile2-1.2.11.tar.gz
BuildArch:	noarch


%description
pefile, Portable Executable reader module

>>> This is an unofficial mirror of the pefile library in a way that it <<<
>>> can be used by projects and libraries. It mirrors the last properly <<<
>>> working version, namely 1.2.10-139, that in the past would be found <<<
>>> at Google Code. This project is a temporary solution that will have <<<
>>> to make do until the official version is fully functional & tested. <<<
>>>           June 28th 2016, Jurriaan Bremer, jbr@cuckoo.sh            <<<

All the PE file basic structures are available with their default names
as attributes of the instance returned.

Processed elements such as the import table are made available with lowercase
names, to differentiate them from the upper case basic structure names.

pefile has been tested against the limits of valid PE headers, that is, malware.
Lots of packed malware attempt to abuse the format way beyond its standard use.
To the best of my knowledge most of the abuses are handled gracefully.

Copyright (c) 2005-2013 Ero Carrera <ero.carrera@gmail.com>

All rights reserved.

For detailed copyright information see the file COPYING in
the root of the distribution archive.

%package -n python3-pefile2
Summary:	Python PE parsing module
Provides:	python-pefile2
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pefile2
pefile, Portable Executable reader module

>>> This is an unofficial mirror of the pefile library in a way that it <<<
>>> can be used by projects and libraries. It mirrors the last properly <<<
>>> working version, namely 1.2.10-139, that in the past would be found <<<
>>> at Google Code. This project is a temporary solution that will have <<<
>>> to make do until the official version is fully functional & tested. <<<
>>>           June 28th 2016, Jurriaan Bremer, jbr@cuckoo.sh            <<<

All the PE file basic structures are available with their default names
as attributes of the instance returned.

Processed elements such as the import table are made available with lowercase
names, to differentiate them from the upper case basic structure names.

pefile has been tested against the limits of valid PE headers, that is, malware.
Lots of packed malware attempt to abuse the format way beyond its standard use.
To the best of my knowledge most of the abuses are handled gracefully.

Copyright (c) 2005-2013 Ero Carrera <ero.carrera@gmail.com>

All rights reserved.

For detailed copyright information see the file COPYING in
the root of the distribution archive.

%package help
Summary:	Development documents and examples for pefile2
Provides:	python3-pefile2-doc
%description help
pefile, Portable Executable reader module

>>> This is an unofficial mirror of the pefile library in a way that it <<<
>>> can be used by projects and libraries. It mirrors the last properly <<<
>>> working version, namely 1.2.10-139, that in the past would be found <<<
>>> at Google Code. This project is a temporary solution that will have <<<
>>> to make do until the official version is fully functional & tested. <<<
>>>           June 28th 2016, Jurriaan Bremer, jbr@cuckoo.sh            <<<

All the PE file basic structures are available with their default names
as attributes of the instance returned.

Processed elements such as the import table are made available with lowercase
names, to differentiate them from the upper case basic structure names.

pefile has been tested against the limits of valid PE headers, that is, malware.
Lots of packed malware attempt to abuse the format way beyond its standard use.
To the best of my knowledge most of the abuses are handled gracefully.

Copyright (c) 2005-2013 Ero Carrera <ero.carrera@gmail.com>

All rights reserved.

For detailed copyright information see the file COPYING in
the root of the distribution archive.

%prep
%autosetup -n pefile2-1.2.11

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pefile2 -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.11-1
- Package Spec generated