%global _empty_manifest_terminate_build 0
Name: python-webeye
Version: 2.3.12
Release: 1
Summary: A Best Powerful module for making ethical hacking tools easier
License: MIT
URL: https://github.com/Zaeem20/webeye
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/8a/ce/b6c3fb2a4a8f88dc74d3d6ec90ab539f07837e2c01bb75485e07b05390f6/webeye-2.3.12.tar.gz
BuildArch: noarch
Requires: python3-requests
Requires: python3-httpx
Requires: python3-mechanize
Requires: python3-beautifulsoup4
%description
# Webeye
A Powerful Library for making ethical-hacking/pen-testing tools
At your Fingertips, just in 3-5 lines of code...
## Features
• Subdomain Enumerator
• Port scanner
• ReverseDNS Lookup
• ReversIP Lookup
• Banner Grabber
• Firewall Detector
• Honeypot Detector (Based on Honeyscore)
• Pagelinks Extractor
• Shared DNS Scanner
• DNS Lookup
• Whois Lookup
• Geo-IP Lookup
• SiteDown detector
• ROT encoder & decoder from (ROT-1 - ROT-25)
## Installation
```sh
pip install -U webeye
```
## Getting Started
```py
# importing
from webeye import *
# host
host="google.com"
# schema
schema="https://"
# subdomains
subdomains=subenum(host=host)
# dns lookup
dns=fetch_dns(host=host)
# banner grabber
grabbed=grab(host=host,schema=schema)
# check for ports
ports=scan(host=host, port=1025, start=0, dev_mode = False)
# cloudflare
detected=enumerate_waf(host=host)
# honeypot
honeypot=is_honeypot(host=host)
```
## Custom Things
You can also scan specific ports, Iterable type args can also be added...
```py
webeye.scan('google.com', [21,80,443])
```
You can get IP address of subdomain too...
```py
print(webeye.subenum(target, no_ip=False))
```
## Webeye as Asynchronous
```py
from webeye import AsyncHelper
asyncmanner = AsyncHelper()
async def portscan(target):
await asyncmanner.scan(target, 1024)
async def reversedns(target):
await asyncmanner.reversedns(target)
async def whois(target):
await asyncmanner.whois(target)
async def extract_pagelink(target):
await asyncmanner.extract_pagelink(target)
async def shared_dns(target):
await asyncmanner.fetch_shared_dns(target)
async def bannergrabber(target):
await asyncmanner.grab(target)
async def geoip(target):
await asyncmanner.geoip(target)
async def find_subdomains(target):
await asyncmanner.find_subdomains(target)
async def dnslook(target):
await asyncmanner.fetch_dns(target)
async def reversiplook(target):
await asyncmanner.reverseip(target)
async def enumeratefirewall(target):
await asyncmanner.enumerate_firewall(target)
async def is_honeypot(target):
await asyncmanner.is_honeypot(target)
```
## Webeye as CLI
![image](https://user-images.githubusercontent.com/60778335/137212470-c0326195-5fc5-4112-8587-1dbb09e3c0b9.png)
## Support
• **[Discord](https://discord.gg/xmu36SbCXC)**
%package -n python3-webeye
Summary: A Best Powerful module for making ethical hacking tools easier
Provides: python-webeye
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-webeye
# Webeye
A Powerful Library for making ethical-hacking/pen-testing tools
At your Fingertips, just in 3-5 lines of code...
## Features
• Subdomain Enumerator
• Port scanner
• ReverseDNS Lookup
• ReversIP Lookup
• Banner Grabber
• Firewall Detector
• Honeypot Detector (Based on Honeyscore)
• Pagelinks Extractor
• Shared DNS Scanner
• DNS Lookup
• Whois Lookup
• Geo-IP Lookup
• SiteDown detector
• ROT encoder & decoder from (ROT-1 - ROT-25)
## Installation
```sh
pip install -U webeye
```
## Getting Started
```py
# importing
from webeye import *
# host
host="google.com"
# schema
schema="https://"
# subdomains
subdomains=subenum(host=host)
# dns lookup
dns=fetch_dns(host=host)
# banner grabber
grabbed=grab(host=host,schema=schema)
# check for ports
ports=scan(host=host, port=1025, start=0, dev_mode = False)
# cloudflare
detected=enumerate_waf(host=host)
# honeypot
honeypot=is_honeypot(host=host)
```
## Custom Things
You can also scan specific ports, Iterable type args can also be added...
```py
webeye.scan('google.com', [21,80,443])
```
You can get IP address of subdomain too...
```py
print(webeye.subenum(target, no_ip=False))
```
## Webeye as Asynchronous
```py
from webeye import AsyncHelper
asyncmanner = AsyncHelper()
async def portscan(target):
await asyncmanner.scan(target, 1024)
async def reversedns(target):
await asyncmanner.reversedns(target)
async def whois(target):
await asyncmanner.whois(target)
async def extract_pagelink(target):
await asyncmanner.extract_pagelink(target)
async def shared_dns(target):
await asyncmanner.fetch_shared_dns(target)
async def bannergrabber(target):
await asyncmanner.grab(target)
async def geoip(target):
await asyncmanner.geoip(target)
async def find_subdomains(target):
await asyncmanner.find_subdomains(target)
async def dnslook(target):
await asyncmanner.fetch_dns(target)
async def reversiplook(target):
await asyncmanner.reverseip(target)
async def enumeratefirewall(target):
await asyncmanner.enumerate_firewall(target)
async def is_honeypot(target):
await asyncmanner.is_honeypot(target)
```
## Webeye as CLI
![image](https://user-images.githubusercontent.com/60778335/137212470-c0326195-5fc5-4112-8587-1dbb09e3c0b9.png)
## Support
• **[Discord](https://discord.gg/xmu36SbCXC)**
%package help
Summary: Development documents and examples for webeye
Provides: python3-webeye-doc
%description help
# Webeye
A Powerful Library for making ethical-hacking/pen-testing tools
At your Fingertips, just in 3-5 lines of code...
## Features
• Subdomain Enumerator
• Port scanner
• ReverseDNS Lookup
• ReversIP Lookup
• Banner Grabber
• Firewall Detector
• Honeypot Detector (Based on Honeyscore)
• Pagelinks Extractor
• Shared DNS Scanner
• DNS Lookup
• Whois Lookup
• Geo-IP Lookup
• SiteDown detector
• ROT encoder & decoder from (ROT-1 - ROT-25)
## Installation
```sh
pip install -U webeye
```
## Getting Started
```py
# importing
from webeye import *
# host
host="google.com"
# schema
schema="https://"
# subdomains
subdomains=subenum(host=host)
# dns lookup
dns=fetch_dns(host=host)
# banner grabber
grabbed=grab(host=host,schema=schema)
# check for ports
ports=scan(host=host, port=1025, start=0, dev_mode = False)
# cloudflare
detected=enumerate_waf(host=host)
# honeypot
honeypot=is_honeypot(host=host)
```
## Custom Things
You can also scan specific ports, Iterable type args can also be added...
```py
webeye.scan('google.com', [21,80,443])
```
You can get IP address of subdomain too...
```py
print(webeye.subenum(target, no_ip=False))
```
## Webeye as Asynchronous
```py
from webeye import AsyncHelper
asyncmanner = AsyncHelper()
async def portscan(target):
await asyncmanner.scan(target, 1024)
async def reversedns(target):
await asyncmanner.reversedns(target)
async def whois(target):
await asyncmanner.whois(target)
async def extract_pagelink(target):
await asyncmanner.extract_pagelink(target)
async def shared_dns(target):
await asyncmanner.fetch_shared_dns(target)
async def bannergrabber(target):
await asyncmanner.grab(target)
async def geoip(target):
await asyncmanner.geoip(target)
async def find_subdomains(target):
await asyncmanner.find_subdomains(target)
async def dnslook(target):
await asyncmanner.fetch_dns(target)
async def reversiplook(target):
await asyncmanner.reverseip(target)
async def enumeratefirewall(target):
await asyncmanner.enumerate_firewall(target)
async def is_honeypot(target):
await asyncmanner.is_honeypot(target)
```
## Webeye as CLI
![image](https://user-images.githubusercontent.com/60778335/137212470-c0326195-5fc5-4112-8587-1dbb09e3c0b9.png)
## Support
• **[Discord](https://discord.gg/xmu36SbCXC)**
%prep
%autosetup -n webeye-2.3.12
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-webeye -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu May 18 2023 Python_Bot - 2.3.12-1
- Package Spec generated