%global _empty_manifest_terminate_build 0
Name:		python-cryptlex.lexfloatclient
Version:	4.7.4
Release:	1
Summary:	LexFloatClient API wrapper for Python
License:	MIT License
URL:		https://github.com/cryptlex/lexfloatclient-python
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/64/20/227444ef09716ed0be0609533b8db0c0cc11f847a94b53ae86a59ecc7575/cryptlex.lexfloatclient-4.7.4.tar.gz
BuildArch:	noarch


%description
![Publish cryptlex.lexfloatclient package](https://github.com/cryptlex/lexfloatclient-python/workflows/Publish%20cryptlex.lexfloatclient%20package/badge.svg)

# cryptlex.lexfloatclient

Cryptlex lets you license your software apps effortlessly. You can easily generate license keys using the REST API or Dashboard and validate the license keys in your software apps using LexActivator (Cryptlex client library), implement floating licenses using LexFloatClient library.

Additionally, you can offer trials, subscriptions, floating licenses and much more.

**cryptlex.lexfloatclient** is a Python wrapper for LexFloatClient licensing library.

## Installation

    pip install cryptlex.lexfloatclient

Then you can include it in your code:

	from cryptlex.lexfloatclient import LexFloatClient, LexFloatStatusCodes, LexFloatClientException


## Usage
Refer to following for documentation:

https://docs.cryptlex.com/floating-licenses/on-premise-floating-licenses/using-lexfloatclient/using-lexfloatclient-with-python


%package -n python3-cryptlex.lexfloatclient
Summary:	LexFloatClient API wrapper for Python
Provides:	python-cryptlex.lexfloatclient
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-cryptlex.lexfloatclient
![Publish cryptlex.lexfloatclient package](https://github.com/cryptlex/lexfloatclient-python/workflows/Publish%20cryptlex.lexfloatclient%20package/badge.svg)

# cryptlex.lexfloatclient

Cryptlex lets you license your software apps effortlessly. You can easily generate license keys using the REST API or Dashboard and validate the license keys in your software apps using LexActivator (Cryptlex client library), implement floating licenses using LexFloatClient library.

Additionally, you can offer trials, subscriptions, floating licenses and much more.

**cryptlex.lexfloatclient** is a Python wrapper for LexFloatClient licensing library.

## Installation

    pip install cryptlex.lexfloatclient

Then you can include it in your code:

	from cryptlex.lexfloatclient import LexFloatClient, LexFloatStatusCodes, LexFloatClientException


## Usage
Refer to following for documentation:

https://docs.cryptlex.com/floating-licenses/on-premise-floating-licenses/using-lexfloatclient/using-lexfloatclient-with-python


%package help
Summary:	Development documents and examples for cryptlex.lexfloatclient
Provides:	python3-cryptlex.lexfloatclient-doc
%description help
![Publish cryptlex.lexfloatclient package](https://github.com/cryptlex/lexfloatclient-python/workflows/Publish%20cryptlex.lexfloatclient%20package/badge.svg)

# cryptlex.lexfloatclient

Cryptlex lets you license your software apps effortlessly. You can easily generate license keys using the REST API or Dashboard and validate the license keys in your software apps using LexActivator (Cryptlex client library), implement floating licenses using LexFloatClient library.

Additionally, you can offer trials, subscriptions, floating licenses and much more.

**cryptlex.lexfloatclient** is a Python wrapper for LexFloatClient licensing library.

## Installation

    pip install cryptlex.lexfloatclient

Then you can include it in your code:

	from cryptlex.lexfloatclient import LexFloatClient, LexFloatStatusCodes, LexFloatClientException


## Usage
Refer to following for documentation:

https://docs.cryptlex.com/floating-licenses/on-premise-floating-licenses/using-lexfloatclient/using-lexfloatclient-with-python


%prep
%autosetup -n cryptlex.lexfloatclient-4.7.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-cryptlex.lexfloatclient -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 4.7.4-1
- Package Spec generated