%global _empty_manifest_terminate_build 0
Name: python-yfpy
Version: 9.1.0
Release: 1
Summary: Python API wrapper for the Yahoo Fantasy Sports public API.
License: GNU General Public License v3 (GPLv3)
URL: https://github.com/uberfastman/yfpy
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/76/e2/99b72206e6efdc9534b1a867044589345d23f5605e3d3b9f332cec235af8/yfpy-9.1.0.tar.gz
BuildArch: noarch
Requires: python3-bandit
Requires: python3-coverage
Requires: python3-flake8
Requires: python3-pytest
Requires: python3-dotenv
Requires: python3-requests
Requires: python3-stringcase
Requires: python3-yahoo-oauth
%description
***Do you like the YFPY API wrapper? Star the repository on GitHub and please consider helping support its ongoing development:***
[
](https://www.paypal.com/cgi-bin/webscr?cmd=_donations&business=VZZCNLRHH9BQS) [
](https://share.trustwallet.com/ZoAkTpY1I9) [
](https://share.trustwallet.com/MF8YBO01I9)
| Cryptocurrency | Address |
|----------------------------------------------------------------------------------------------------:|:----------------------------------------------------------------------------------------------------------------------------------------:|
| Bitcoin (BTC) | `bc1qataspvklhewtswm357m0677q4raag5new2xt3e` |
| Ethereum (ETH) | `0x5eAa522e66a90577D49e9E72f253EC952CDB4059` |
%package -n python3-yfpy
Summary: Python API wrapper for the Yahoo Fantasy Sports public API.
Provides: python-yfpy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-yfpy
***Do you like the YFPY API wrapper? Star the repository on GitHub and please consider helping support its ongoing development:***
[
](https://www.paypal.com/cgi-bin/webscr?cmd=_donations&business=VZZCNLRHH9BQS) [
](https://share.trustwallet.com/ZoAkTpY1I9) [
](https://share.trustwallet.com/MF8YBO01I9)
| Cryptocurrency | Address |
|----------------------------------------------------------------------------------------------------:|:----------------------------------------------------------------------------------------------------------------------------------------:|
| Bitcoin (BTC) | `bc1qataspvklhewtswm357m0677q4raag5new2xt3e` |
| Ethereum (ETH) | `0x5eAa522e66a90577D49e9E72f253EC952CDB4059` |
%package help
Summary: Development documents and examples for yfpy
Provides: python3-yfpy-doc
%description help
***Do you like the YFPY API wrapper? Star the repository on GitHub and please consider helping support its ongoing development:***
[
](https://www.paypal.com/cgi-bin/webscr?cmd=_donations&business=VZZCNLRHH9BQS) [
](https://share.trustwallet.com/ZoAkTpY1I9) [
](https://share.trustwallet.com/MF8YBO01I9)
| Cryptocurrency | Address |
|----------------------------------------------------------------------------------------------------:|:----------------------------------------------------------------------------------------------------------------------------------------:|
| Bitcoin (BTC) | `bc1qataspvklhewtswm357m0677q4raag5new2xt3e` |
| Ethereum (ETH) | `0x5eAa522e66a90577D49e9E72f253EC952CDB4059` |
%prep
%autosetup -n yfpy-9.1.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-yfpy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu May 18 2023 Python_Bot - 9.1.0-1
- Package Spec generated