%global _empty_manifest_terminate_build 0
Name:		python-adversarial-vision-challenge
Version:	1.0.5
Release:	1
Summary:	Tools for the NIPS Adversarial Vision Challenge. Includes an HTTP server and client that provides access to Foolbox models and attacks.
License:	MIT
URL:		https://github.com/bethgelab/adversarial-vision-challenge
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/36/0f/01f8c24d1bae354879f6ed17cc1575ebb52921165794b9404f929489d772/adversarial_vision_challenge-1.0.5.tar.gz
BuildArch:	noarch

Requires:	python3-bson
Requires:	python3-flask
Requires:	python3-foolbox
Requires:	python3-numpy
Requires:	python3-pillow
Requires:	python3-requests
Requires:	python3-setuptools
Requires:	python3-pyyaml
Requires:	python3-crowdai-api
Requires:	python3-GitPython
Requires:	python3-packaging
Requires:	python3-future
Requires:	python3-tqdm
Requires:	python3-crowdai-repo2docker
Requires:	python3-pytest
Requires:	python3-pytest-cov
Requires:	python3-tensorflow

%description


%package -n python3-adversarial-vision-challenge
Summary:	Tools for the NIPS Adversarial Vision Challenge. Includes an HTTP server and client that provides access to Foolbox models and attacks.
Provides:	python-adversarial-vision-challenge
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-adversarial-vision-challenge


%package help
Summary:	Development documents and examples for adversarial-vision-challenge
Provides:	python3-adversarial-vision-challenge-doc
%description help


%prep
%autosetup -n adversarial-vision-challenge-1.0.5

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-adversarial-vision-challenge -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.5-1
- Package Spec generated