%global _empty_manifest_terminate_build 0
Name: python-AxmlParserPY
Version: 0.01
Release: 1
Summary: Python support for extract information from android 'apk' package
License: UNKNOWN
URL: https://github.com/kzjeef/AxmlParserPY.git
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/fb/5c/2e5a89fda7c21b71913ba554c775f9d1a545b14d7343eabbfdb909080171/AxmlParserPY-0.01.tar.gz
BuildArch: noarch
%description
# -------------------------------------------------------------------
# AndroidXMLParser was created by Anthony Desnos and is taken from
# the Androguard Project.
# -------------------------------------------------------------------
# This program is free software: you can redistribute it and/or
# modify it under the terms of the GNU General Public License as
# published by the Free Software Foundation, either version 3 of the
# License, or (at your option) any later version.
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with this program.
# If not, see .
# -------------------------------------------------------------------
# Contributors:
# -------------------------------------------------------------------
# Anthony Desnos
# Antitree
# pee spam this
# algorythm
# Jiejing Zhang // for package to pip
# -------------------------------------------------------------------
# version: 0.0.1
# -------------------------------------------------------------------
Example:
1. convert apk binary manifest to string manifest.
import axmlparserpy.axmlprinter as axmlprinter
ap = axmlprinter.AXMLPrinter(open('example/binary/AndroidManifest.xml', 'rb').read())
buff = minidom.parseString(ap.getBuff()).toxml()
print(buff)
2. get apk information
import axmlparserpy.apk as apk
ap = apk.APK('_PATH_TO_APK')
print ap.get_package()
print ap.get_androidversion_name()
%package -n python3-AxmlParserPY
Summary: Python support for extract information from android 'apk' package
Provides: python-AxmlParserPY
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-AxmlParserPY
# -------------------------------------------------------------------
# AndroidXMLParser was created by Anthony Desnos and is taken from
# the Androguard Project.
# -------------------------------------------------------------------
# This program is free software: you can redistribute it and/or
# modify it under the terms of the GNU General Public License as
# published by the Free Software Foundation, either version 3 of the
# License, or (at your option) any later version.
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with this program.
# If not, see .
# -------------------------------------------------------------------
# Contributors:
# -------------------------------------------------------------------
# Anthony Desnos
# Antitree
# pee spam this
# algorythm
# Jiejing Zhang // for package to pip
# -------------------------------------------------------------------
# version: 0.0.1
# -------------------------------------------------------------------
Example:
1. convert apk binary manifest to string manifest.
import axmlparserpy.axmlprinter as axmlprinter
ap = axmlprinter.AXMLPrinter(open('example/binary/AndroidManifest.xml', 'rb').read())
buff = minidom.parseString(ap.getBuff()).toxml()
print(buff)
2. get apk information
import axmlparserpy.apk as apk
ap = apk.APK('_PATH_TO_APK')
print ap.get_package()
print ap.get_androidversion_name()
%package help
Summary: Development documents and examples for AxmlParserPY
Provides: python3-AxmlParserPY-doc
%description help
# -------------------------------------------------------------------
# AndroidXMLParser was created by Anthony Desnos and is taken from
# the Androguard Project.
# -------------------------------------------------------------------
# This program is free software: you can redistribute it and/or
# modify it under the terms of the GNU General Public License as
# published by the Free Software Foundation, either version 3 of the
# License, or (at your option) any later version.
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with this program.
# If not, see .
# -------------------------------------------------------------------
# Contributors:
# -------------------------------------------------------------------
# Anthony Desnos
# Antitree
# pee spam this
# algorythm
# Jiejing Zhang // for package to pip
# -------------------------------------------------------------------
# version: 0.0.1
# -------------------------------------------------------------------
Example:
1. convert apk binary manifest to string manifest.
import axmlparserpy.axmlprinter as axmlprinter
ap = axmlprinter.AXMLPrinter(open('example/binary/AndroidManifest.xml', 'rb').read())
buff = minidom.parseString(ap.getBuff()).toxml()
print(buff)
2. get apk information
import axmlparserpy.apk as apk
ap = apk.APK('_PATH_TO_APK')
print ap.get_package()
print ap.get_androidversion_name()
%prep
%autosetup -n AxmlParserPY-0.01
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-AxmlParserPY -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu May 18 2023 Python_Bot - 0.01-1
- Package Spec generated