%global _empty_manifest_terminate_build 0
Name: python-combine
Version: 2.14.0
Release: 1
Summary: A straightforward static site builder.
License: MIT
URL: https://combine.dropseed.dev
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/5f/43/37269e525b79ae2b1fdb298bfcbafdfed18f0396562deb1d0fd6642c98e0/combine-2.14.0.tar.gz
BuildArch: noarch
Requires: python3-Jinja2
Requires: python3-click
Requires: python3-beautifulsoup4
Requires: python3-Pygments
Requires: python3-markdown
Requires: python3-frontmatter
Requires: python3-typing-extensions
Requires: python3-PyYAML
Requires: python3-barrel
Requires: python3-honcho
Requires: python3-repaint
Requires: python3-watchfiles
%description
# Combine
**Build a straightforward marketing or documentation website with the power of [Jinja](http://jinja.pocoo.org/).
No fancy JavaScript here — this is just like the good old days.**
Put your site into the "content" directory and Combine will:
- Render files using Jinja
- Create pretty URLs ("file-system routing")
- Inject variables
- Run custom build steps (like building Tailwind)
Most sites follow a simple pattern.
Create a `base.template.html`:
```html+jinja
My site
{% block content %}{% endblock %}
```
And use it (ex. `pricing.html`):
```html+jinja
{% extends "base.template.html" %}
{% block content %}
{% endblock %}
```
In the end, you get a static HTML site that can be deployed almost anywhere.
%package -n python3-combine
Summary: A straightforward static site builder.
Provides: python-combine
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-combine
# Combine
**Build a straightforward marketing or documentation website with the power of [Jinja](http://jinja.pocoo.org/).
No fancy JavaScript here — this is just like the good old days.**
Put your site into the "content" directory and Combine will:
- Render files using Jinja
- Create pretty URLs ("file-system routing")
- Inject variables
- Run custom build steps (like building Tailwind)
Most sites follow a simple pattern.
Create a `base.template.html`:
```html+jinja
My site
{% block content %}{% endblock %}
```
And use it (ex. `pricing.html`):
```html+jinja
{% extends "base.template.html" %}
{% block content %}
{% endblock %}
```
In the end, you get a static HTML site that can be deployed almost anywhere.
%package help
Summary: Development documents and examples for combine
Provides: python3-combine-doc
%description help
# Combine
**Build a straightforward marketing or documentation website with the power of [Jinja](http://jinja.pocoo.org/).
No fancy JavaScript here — this is just like the good old days.**
Put your site into the "content" directory and Combine will:
- Render files using Jinja
- Create pretty URLs ("file-system routing")
- Inject variables
- Run custom build steps (like building Tailwind)
Most sites follow a simple pattern.
Create a `base.template.html`:
```html+jinja
My site
{% block content %}{% endblock %}
```
And use it (ex. `pricing.html`):
```html+jinja
{% extends "base.template.html" %}
{% block content %}
{% endblock %}
```
In the end, you get a static HTML site that can be deployed almost anywhere.
%prep
%autosetup -n combine-2.14.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-combine -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu May 18 2023 Python_Bot - 2.14.0-1
- Package Spec generated