%global _empty_manifest_terminate_build 0
Name: python-realesrgan
Version: 0.3.0
Release: 1
Summary: Real-ESRGAN aims at developing Practical Algorithms for General Image Restoration
License: BSD-3-Clause License
URL: https://github.com/xinntao/Real-ESRGAN
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/75/40/4af728ed9c48ac65634976535f36afd421de39315920e5f740049a6524a6/realesrgan-0.3.0.tar.gz
BuildArch: noarch
Requires: python3-basicsr
Requires: python3-facexlib
Requires: python3-gfpgan
Requires: python3-numpy
Requires: python3-opencv-python
Requires: python3-Pillow
Requires: python3-torch
Requires: python3-torchvision
Requires: python3-tqdm
%description
If Real-ESRGAN is helpful, please help to ⭐ this repo or recommend it to your friends 😊
Other recommended projects:
▶️ [GFPGAN](https://github.com/TencentARC/GFPGAN): A practical algorithm for real-world face restoration
▶️ [BasicSR](https://github.com/xinntao/BasicSR): An open-source image and video restoration toolbox
▶️ [facexlib](https://github.com/xinntao/facexlib): A collection that provides useful face-relation functions.
▶️ [HandyView](https://github.com/xinntao/HandyView): A PyQt5-based image viewer that is handy for view and comparison
%package -n python3-realesrgan
Summary: Real-ESRGAN aims at developing Practical Algorithms for General Image Restoration
Provides: python-realesrgan
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-realesrgan
If Real-ESRGAN is helpful, please help to ⭐ this repo or recommend it to your friends 😊
Other recommended projects:
▶️ [GFPGAN](https://github.com/TencentARC/GFPGAN): A practical algorithm for real-world face restoration
▶️ [BasicSR](https://github.com/xinntao/BasicSR): An open-source image and video restoration toolbox
▶️ [facexlib](https://github.com/xinntao/facexlib): A collection that provides useful face-relation functions.
▶️ [HandyView](https://github.com/xinntao/HandyView): A PyQt5-based image viewer that is handy for view and comparison
%package help
Summary: Development documents and examples for realesrgan
Provides: python3-realesrgan-doc
%description help
If Real-ESRGAN is helpful, please help to ⭐ this repo or recommend it to your friends 😊
Other recommended projects:
▶️ [GFPGAN](https://github.com/TencentARC/GFPGAN): A practical algorithm for real-world face restoration
▶️ [BasicSR](https://github.com/xinntao/BasicSR): An open-source image and video restoration toolbox
▶️ [facexlib](https://github.com/xinntao/facexlib): A collection that provides useful face-relation functions.
▶️ [HandyView](https://github.com/xinntao/HandyView): A PyQt5-based image viewer that is handy for view and comparison
%prep
%autosetup -n realesrgan-0.3.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-realesrgan -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu May 18 2023 Python_Bot - 0.3.0-1
- Package Spec generated