%global _empty_manifest_terminate_build 0
Name: python-PyEyeTrack
Version: 1.0.1
Release: 1
Summary: PyEyeTrack is a python-based pupil-tracking library. The library tracks eyes with the commodity webcam and gives a real-time stream of eye coordinates. It provides the functionality of eye-tracking and blink detection and encapsulates these in a generic interface that allows clients to use these functionalities in a variety of use-cases.
License: MIT
URL: https://github.com/algoasylum/PyEyeTrack
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ab/53/40ec2c2f09cb6fbc4182fde3ea2f7561c1c93c9c2944a81d06558bc42062/PyEyeTrack-1.0.1.tar.gz
BuildArch: noarch
%description
# PyEyeTrack - The Python eYe Tracking Library
[![license](https://img.shields.io/github/license/DAVFoundation/captain-n3m0.svg?style=flat-square)](https://github.com/algoasylum/pyEyeTrack/blob/master/LICENSE)
*pyEyeTrack* is a python-based pupil-tracking library. The library tracks eyes with the commodity webcam and gives a real-time stream of eye coordinates. It provides the functionality of eye-tracking and blink detection and encapsulates these in a generic interface that allows clients to use these functionalities in a variety of use-cases.
Features
- Real-time Pupil Tracking
- Real-time Blink Detection
- Customizable and modularized design
- Concurrent
Documentation
Find the official documentation [here](https://algoasylum.github.io/PyTrack/).
%package -n python3-PyEyeTrack
Summary: PyEyeTrack is a python-based pupil-tracking library. The library tracks eyes with the commodity webcam and gives a real-time stream of eye coordinates. It provides the functionality of eye-tracking and blink detection and encapsulates these in a generic interface that allows clients to use these functionalities in a variety of use-cases.
Provides: python-PyEyeTrack
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-PyEyeTrack
# PyEyeTrack - The Python eYe Tracking Library
[![license](https://img.shields.io/github/license/DAVFoundation/captain-n3m0.svg?style=flat-square)](https://github.com/algoasylum/pyEyeTrack/blob/master/LICENSE)
*pyEyeTrack* is a python-based pupil-tracking library. The library tracks eyes with the commodity webcam and gives a real-time stream of eye coordinates. It provides the functionality of eye-tracking and blink detection and encapsulates these in a generic interface that allows clients to use these functionalities in a variety of use-cases.
Features
- Real-time Pupil Tracking
- Real-time Blink Detection
- Customizable and modularized design
- Concurrent
Documentation
Find the official documentation [here](https://algoasylum.github.io/PyTrack/).
%package help
Summary: Development documents and examples for PyEyeTrack
Provides: python3-PyEyeTrack-doc
%description help
# PyEyeTrack - The Python eYe Tracking Library
[![license](https://img.shields.io/github/license/DAVFoundation/captain-n3m0.svg?style=flat-square)](https://github.com/algoasylum/pyEyeTrack/blob/master/LICENSE)
*pyEyeTrack* is a python-based pupil-tracking library. The library tracks eyes with the commodity webcam and gives a real-time stream of eye coordinates. It provides the functionality of eye-tracking and blink detection and encapsulates these in a generic interface that allows clients to use these functionalities in a variety of use-cases.
Features
- Real-time Pupil Tracking
- Real-time Blink Detection
- Customizable and modularized design
- Concurrent
Documentation
Find the official documentation [here](https://algoasylum.github.io/PyTrack/).
%prep
%autosetup -n PyEyeTrack-1.0.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-PyEyeTrack -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu May 18 2023 Python_Bot - 1.0.1-1
- Package Spec generated