%global _empty_manifest_terminate_build 0
Name:		python-redset
Version:	0.5.1
Release:	1
Summary:	Simple, distributed sorted sets with redis
License:	see LICENSE
URL:		https://github.com/percolate/redset
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/f5/cf/aabbe231b78a8b50a3e7779d03b5a2493e040e470f26f99b7e10644fa49f/redset-0.5.1.tar.gz
BuildArch:	noarch


%description
|PyPI version| |build status| |Coverage Status|
You may not need heavyweights like Celery or RQ. Maintaing an AMQP server 
might be overkill. There's a simpler, easier way to distribute work.
Redset provides simple, generic sorted sets backed by Redis that can be used to
coordinate distributed systems and parcel out work. Unlike more common
distribution libraries like Celery or RQ, redset avoids duplicate work for
certain use-cases by maintaining a set of tasks instead of a list or queue.
And it does so with a dead-simple interface that feels natural for Python.
Redset is currently used in the wild to do things like
- maintain a high-throughput work queue of streaming updates to be processed
- power a multi-producer, multi-consumer scraping architecture that won't do
  the same work twice
- maintain a simple, cross-process set of "seen" items that each have a 
  TTL
- schedule non-duplicate, periodic polling of analytics on social services

%package -n python3-redset
Summary:	Simple, distributed sorted sets with redis
Provides:	python-redset
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-redset
|PyPI version| |build status| |Coverage Status|
You may not need heavyweights like Celery or RQ. Maintaing an AMQP server 
might be overkill. There's a simpler, easier way to distribute work.
Redset provides simple, generic sorted sets backed by Redis that can be used to
coordinate distributed systems and parcel out work. Unlike more common
distribution libraries like Celery or RQ, redset avoids duplicate work for
certain use-cases by maintaining a set of tasks instead of a list or queue.
And it does so with a dead-simple interface that feels natural for Python.
Redset is currently used in the wild to do things like
- maintain a high-throughput work queue of streaming updates to be processed
- power a multi-producer, multi-consumer scraping architecture that won't do
  the same work twice
- maintain a simple, cross-process set of "seen" items that each have a 
  TTL
- schedule non-duplicate, periodic polling of analytics on social services

%package help
Summary:	Development documents and examples for redset
Provides:	python3-redset-doc
%description help
|PyPI version| |build status| |Coverage Status|
You may not need heavyweights like Celery or RQ. Maintaing an AMQP server 
might be overkill. There's a simpler, easier way to distribute work.
Redset provides simple, generic sorted sets backed by Redis that can be used to
coordinate distributed systems and parcel out work. Unlike more common
distribution libraries like Celery or RQ, redset avoids duplicate work for
certain use-cases by maintaining a set of tasks instead of a list or queue.
And it does so with a dead-simple interface that feels natural for Python.
Redset is currently used in the wild to do things like
- maintain a high-throughput work queue of streaming updates to be processed
- power a multi-producer, multi-consumer scraping architecture that won't do
  the same work twice
- maintain a simple, cross-process set of "seen" items that each have a 
  TTL
- schedule non-duplicate, periodic polling of analytics on social services

%prep
%autosetup -n redset-0.5.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-redset -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.1-1
- Package Spec generated