%global _empty_manifest_terminate_build 0
Name:		python-cellfinder-napari
Version:	0.0.20
Release:	1
Summary:	Efficient cell detection in large images
License:	BSD-3-Clause
URL:		https://brainglobe.info/cellfinder
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/00/a6/45255a896a87ce798ede6bd65fa4ced614090092b7c351e62bfe1a8d7534/cellfinder-napari-0.0.20.tar.gz
BuildArch:	noarch

Requires:	python3-napari
Requires:	python3-napari-plugin-engine
Requires:	python3-napari-ndtiffs
Requires:	python3-brainglobe-napari-io
Requires:	python3-cellfinder-core
Requires:	python3-pooch
Requires:	python3-black
Requires:	python3-bump2version
Requires:	python3-gitpython
Requires:	python3-pre-commit
Requires:	python3-pytest
Requires:	python3-pytest-cov
Requires:	python3-pytest-qt

%description
![raw](https://raw.githubusercontent.com/brainglobe/cellfinder-napari/master/resources/cellfinder-napari.gif)

%package -n python3-cellfinder-napari
Summary:	Efficient cell detection in large images
Provides:	python-cellfinder-napari
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-cellfinder-napari
![raw](https://raw.githubusercontent.com/brainglobe/cellfinder-napari/master/resources/cellfinder-napari.gif)

%package help
Summary:	Development documents and examples for cellfinder-napari
Provides:	python3-cellfinder-napari-doc
%description help
![raw](https://raw.githubusercontent.com/brainglobe/cellfinder-napari/master/resources/cellfinder-napari.gif)

%prep
%autosetup -n cellfinder-napari-0.0.20

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-cellfinder-napari -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.20-1
- Package Spec generated