%global _empty_manifest_terminate_build 0
Name:		python-pykeops
Version:	2.1.2
Release:	1
Summary:	Python bindings of KeOps: KErnel OPerationS, on CPUs and GPUs, with autodiff and without memory overflows
License:	MIT License
URL:		http://www.kernel-operations.io/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/40/b5/076d3ff0070d011a8e04210cf7851450e8063d5f01926d7f0ecdc6edeefc/pykeops-2.1.2.tar.gz
BuildArch:	noarch


%description
![logo pykeops](http://www.kernel-operations.io/keops/_images/pykeops_logo.png)

PyKeOps contains the python bindings (numpy and pytorch) for the cpp/cuda library [KeOps](https://www.kernel-operations.io/). It provides
standard python functions that can be used in any **python 3** codes.

For a full documentation you may read:

* [Installation](https://www.kernel-operations.io/keops/introduction/installation.html)
* [Documentation](https://www.kernel-operations.io/)
* [Learning KeOps syntax with examples](https://www.kernel-operations.io/keops/_auto_examples/index.html)
* [Tutorials gallery](https://www.kernel-operations.io/keops/_auto_tutorials/index.html)

# Authors

- [Benjamin Charlier](https://imag.umontpellier.fr/~charlier/)
- [Jean Feydy](https://www.math.ens.fr/~feydy/)
- [Joan Alexis Glaunès](https://www.mi.parisdescartes.fr/~glaunes/)


%package -n python3-pykeops
Summary:	Python bindings of KeOps: KErnel OPerationS, on CPUs and GPUs, with autodiff and without memory overflows
Provides:	python-pykeops
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pykeops
![logo pykeops](http://www.kernel-operations.io/keops/_images/pykeops_logo.png)

PyKeOps contains the python bindings (numpy and pytorch) for the cpp/cuda library [KeOps](https://www.kernel-operations.io/). It provides
standard python functions that can be used in any **python 3** codes.

For a full documentation you may read:

* [Installation](https://www.kernel-operations.io/keops/introduction/installation.html)
* [Documentation](https://www.kernel-operations.io/)
* [Learning KeOps syntax with examples](https://www.kernel-operations.io/keops/_auto_examples/index.html)
* [Tutorials gallery](https://www.kernel-operations.io/keops/_auto_tutorials/index.html)

# Authors

- [Benjamin Charlier](https://imag.umontpellier.fr/~charlier/)
- [Jean Feydy](https://www.math.ens.fr/~feydy/)
- [Joan Alexis Glaunès](https://www.mi.parisdescartes.fr/~glaunes/)


%package help
Summary:	Development documents and examples for pykeops
Provides:	python3-pykeops-doc
%description help
![logo pykeops](http://www.kernel-operations.io/keops/_images/pykeops_logo.png)

PyKeOps contains the python bindings (numpy and pytorch) for the cpp/cuda library [KeOps](https://www.kernel-operations.io/). It provides
standard python functions that can be used in any **python 3** codes.

For a full documentation you may read:

* [Installation](https://www.kernel-operations.io/keops/introduction/installation.html)
* [Documentation](https://www.kernel-operations.io/)
* [Learning KeOps syntax with examples](https://www.kernel-operations.io/keops/_auto_examples/index.html)
* [Tutorials gallery](https://www.kernel-operations.io/keops/_auto_tutorials/index.html)

# Authors

- [Benjamin Charlier](https://imag.umontpellier.fr/~charlier/)
- [Jean Feydy](https://www.math.ens.fr/~feydy/)
- [Joan Alexis Glaunès](https://www.mi.parisdescartes.fr/~glaunes/)


%prep
%autosetup -n pykeops-2.1.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pykeops -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 2.1.2-1
- Package Spec generated