%global _empty_manifest_terminate_build 0
Name:		python-Asset_Allocation
Version:	1.3.3
Release:	1
Summary:	Asset Allocation project
License:	GPL version 3
URL:		https://github.com/MisterY/Asset-Allocation
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/01/d7/51648f4eb86d2be0a30b9f65b8c4df26ee13a958e4b15c5b55765345b6d9/Asset_Allocation-1.3.3.tar.gz
BuildArch:	noarch


%description
ToC:
- [Asset-Allocation](#asset-allocation)
    - [Introduction](#introduction)
- [Development](#development)
    - [Configuration](#configuration)
    - [Data Store](#data-store)
- [Tests](#tests)
- [Distribution](#distribution)
    - [Test Site](#test-site)
    - [Production Site](#production-site)

# Asset-Allocation
Asset Allocation implementation in Python

## Introduction 

The idea here is to encapsulate Asset Allocation logic into a separate component and make it available to other projects (GnuCash Portfolio, and Android apps).

This will include its own data storage.

Dependencies will include:
- price database, for calculation of current value
- transaction database for securities, for calculation of current value

# Development

Requirements are generated with _pipreqs_. Install requirements from requirements.txt.

## Configuration

On the first run, a config file will be created in the user's directory, based on the template in project's data directory.

## Data Store

Data storage is in a SQLite database, which allows for portability, easy queries and relatively easy editing.
The sample data file is in "data" folder.

# Tests

To lint the code, execute `pylint` from the project root directory.
To run tests, execute `pytest` from the project root directory.

# Distribution

## Test Site

```console
python setup.py sdist upload -r test
```

## Production Site

```console
python setup.py sdist upload -r pypi
```

%package -n python3-Asset_Allocation
Summary:	Asset Allocation project
Provides:	python-Asset_Allocation
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-Asset_Allocation
ToC:
- [Asset-Allocation](#asset-allocation)
    - [Introduction](#introduction)
- [Development](#development)
    - [Configuration](#configuration)
    - [Data Store](#data-store)
- [Tests](#tests)
- [Distribution](#distribution)
    - [Test Site](#test-site)
    - [Production Site](#production-site)

# Asset-Allocation
Asset Allocation implementation in Python

## Introduction 

The idea here is to encapsulate Asset Allocation logic into a separate component and make it available to other projects (GnuCash Portfolio, and Android apps).

This will include its own data storage.

Dependencies will include:
- price database, for calculation of current value
- transaction database for securities, for calculation of current value

# Development

Requirements are generated with _pipreqs_. Install requirements from requirements.txt.

## Configuration

On the first run, a config file will be created in the user's directory, based on the template in project's data directory.

## Data Store

Data storage is in a SQLite database, which allows for portability, easy queries and relatively easy editing.
The sample data file is in "data" folder.

# Tests

To lint the code, execute `pylint` from the project root directory.
To run tests, execute `pytest` from the project root directory.

# Distribution

## Test Site

```console
python setup.py sdist upload -r test
```

## Production Site

```console
python setup.py sdist upload -r pypi
```

%package help
Summary:	Development documents and examples for Asset_Allocation
Provides:	python3-Asset_Allocation-doc
%description help
ToC:
- [Asset-Allocation](#asset-allocation)
    - [Introduction](#introduction)
- [Development](#development)
    - [Configuration](#configuration)
    - [Data Store](#data-store)
- [Tests](#tests)
- [Distribution](#distribution)
    - [Test Site](#test-site)
    - [Production Site](#production-site)

# Asset-Allocation
Asset Allocation implementation in Python

## Introduction 

The idea here is to encapsulate Asset Allocation logic into a separate component and make it available to other projects (GnuCash Portfolio, and Android apps).

This will include its own data storage.

Dependencies will include:
- price database, for calculation of current value
- transaction database for securities, for calculation of current value

# Development

Requirements are generated with _pipreqs_. Install requirements from requirements.txt.

## Configuration

On the first run, a config file will be created in the user's directory, based on the template in project's data directory.

## Data Store

Data storage is in a SQLite database, which allows for portability, easy queries and relatively easy editing.
The sample data file is in "data" folder.

# Tests

To lint the code, execute `pylint` from the project root directory.
To run tests, execute `pytest` from the project root directory.

# Distribution

## Test Site

```console
python setup.py sdist upload -r test
```

## Production Site

```console
python setup.py sdist upload -r pypi
```

%prep
%autosetup -n Asset_Allocation-1.3.3

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-Asset_Allocation -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.3-1
- Package Spec generated