%global _empty_manifest_terminate_build 0
Name:		python-rfapi
Version:	2.6.0
Release:	1
Summary:	API access to the Recorded Future API.
License:	Apache 2
URL:		https://github.com/recordedfuture/rfapi-python
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/aa/20/9e23bf6921da3121c0e846eaea94829c82428bdb0ba9e7e17219d0d0b0e8/rfapi-2.6.0.tar.gz
BuildArch:	noarch


%description
Python 2/3 library for using the Recorded Future API
Recorded Future's API enables you to build analytic applications and
perform analysis which is aware of events happening around the globe
24x7. You can perform queries and receive results from the Recorded
Future Temporal Analytics Engine across a vast set of events,
entities, and time points spanning from the far past into the future.
See `GitHub source <https://github.com/recordedfuture/rfapi-python>`__
for further details and example usage.
To install with pip run ``pip install rfapi``

%package -n python3-rfapi
Summary:	API access to the Recorded Future API.
Provides:	python-rfapi
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-rfapi
Python 2/3 library for using the Recorded Future API
Recorded Future's API enables you to build analytic applications and
perform analysis which is aware of events happening around the globe
24x7. You can perform queries and receive results from the Recorded
Future Temporal Analytics Engine across a vast set of events,
entities, and time points spanning from the far past into the future.
See `GitHub source <https://github.com/recordedfuture/rfapi-python>`__
for further details and example usage.
To install with pip run ``pip install rfapi``

%package help
Summary:	Development documents and examples for rfapi
Provides:	python3-rfapi-doc
%description help
Python 2/3 library for using the Recorded Future API
Recorded Future's API enables you to build analytic applications and
perform analysis which is aware of events happening around the globe
24x7. You can perform queries and receive results from the Recorded
Future Temporal Analytics Engine across a vast set of events,
entities, and time points spanning from the far past into the future.
See `GitHub source <https://github.com/recordedfuture/rfapi-python>`__
for further details and example usage.
To install with pip run ``pip install rfapi``

%prep
%autosetup -n rfapi-2.6.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-rfapi -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 2.6.0-1
- Package Spec generated