%global _empty_manifest_terminate_build 0
Name:		python-lib-platform
Version:	1.2.7
Release:	1
Summary:	some platform related functions, which also work correctly on wine
License:	MIT License
URL:		https://github.com/bitranox/lib_platform
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/b0/cd/0e436bd9c4100a654267e4538a4416390b6129811cc7f86aad642ba4db82/lib_platform-1.2.7.tar.gz
BuildArch:	noarch

Requires:	python3-click
Requires:	python3-cli-exit-tools
Requires:	python3-lib-registry

%description
Version v1.2.7 as of 2020-10-09 see `Changelog`_
|travis_build| |license| |jupyter| |pypi|
|codecov| |better_code| |cc_maintain| |cc_issues| |cc_coverage| |snyk|

%package -n python3-lib-platform
Summary:	some platform related functions, which also work correctly on wine
Provides:	python-lib-platform
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-lib-platform
Version v1.2.7 as of 2020-10-09 see `Changelog`_
|travis_build| |license| |jupyter| |pypi|
|codecov| |better_code| |cc_maintain| |cc_issues| |cc_coverage| |snyk|

%package help
Summary:	Development documents and examples for lib-platform
Provides:	python3-lib-platform-doc
%description help
Version v1.2.7 as of 2020-10-09 see `Changelog`_
|travis_build| |license| |jupyter| |pypi|
|codecov| |better_code| |cc_maintain| |cc_issues| |cc_coverage| |snyk|

%prep
%autosetup -n lib-platform-1.2.7

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-lib-platform -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.7-1
- Package Spec generated