%global _empty_manifest_terminate_build 0
Name:		python-replay-trajectory-classification
Version:	1.3.10
Release:	1
Summary:	Classify replay trajectories.
License:	MIT
URL:		https://github.com/Eden-Kramer-Lab/replay_trajectory_classification
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/c5/f0/a6e4a0bade0ee6aa0d26ae00429fe7f6b36896674426318ab56e0cd41cfb/replay_trajectory_classification-1.3.10.tar.gz
BuildArch:	noarch

Requires:	python3-numpy
Requires:	python3-statsmodels
Requires:	python3-numba
Requires:	python3-matplotlib
Requires:	python3-pandas
Requires:	python3-xarray
Requires:	python3-scipy
Requires:	python3-scikit-learn
Requires:	python3-scikit-image
Requires:	python3-regularized-glm
Requires:	python3-dask
Requires:	python3-patsy
Requires:	python3-networkx
Requires:	python3-joblib
Requires:	python3-track-linearization
Requires:	python3-tqdm
Requires:	python3-seaborn

%description


%package -n python3-replay-trajectory-classification
Summary:	Classify replay trajectories.
Provides:	python-replay-trajectory-classification
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-replay-trajectory-classification


%package help
Summary:	Development documents and examples for replay-trajectory-classification
Provides:	python3-replay-trajectory-classification-doc
%description help


%prep
%autosetup -n replay-trajectory-classification-1.3.10

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-replay-trajectory-classification -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.10-1
- Package Spec generated