%global _empty_manifest_terminate_build 0
Name:		python-pdip
Version:	0.6.6
Release:	1
Summary:	Python Data Integrator infrastructures package
License:	MIT
URL:		https://github.com/ahmetcagriakca/pdip
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/59/2f/7b644a0a3d7d208073b72593023cff8bc9ab4d08734b2a931d64244193fa/pdip-0.6.6.tar.gz
BuildArch:	noarch

Requires:	python3-PyYAML
Requires:	python3-injector
Requires:	python3-jsonpickle
Requires:	python3-Fernet
Requires:	python3-cryptography
Requires:	python3-SQLAlchemy
Requires:	python3-rpyc
Requires:	python3-Flask
Requires:	python3-Flask-Cors
Requires:	python3-Flask-Ext
Requires:	python3-Flask-Injector
Requires:	python3-flask-restx
Requires:	python3-Werkzeug
Requires:	python3-dataclasses
Requires:	python3-dataclasses-json
Requires:	python3-requests
Requires:	python3-kafka-python
Requires:	python3-pandas
Requires:	python3-coverage
Requires:	python3-func-timeout

%description
<p align="left">
	<a href="https://pypi.org/project/pdip" target="_blank">
			<img src="https://img.shields.io/pypi/v/pdip?color=%2334D058&label=pypi%20package" alt="Package version">
	</a>
</p>

# Introduction

This package aim to perform the integration processes easily 



%package -n python3-pdip
Summary:	Python Data Integrator infrastructures package
Provides:	python-pdip
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pdip
<p align="left">
	<a href="https://pypi.org/project/pdip" target="_blank">
			<img src="https://img.shields.io/pypi/v/pdip?color=%2334D058&label=pypi%20package" alt="Package version">
	</a>
</p>

# Introduction

This package aim to perform the integration processes easily 



%package help
Summary:	Development documents and examples for pdip
Provides:	python3-pdip-doc
%description help
<p align="left">
	<a href="https://pypi.org/project/pdip" target="_blank">
			<img src="https://img.shields.io/pypi/v/pdip?color=%2334D058&label=pypi%20package" alt="Package version">
	</a>
</p>

# Introduction

This package aim to perform the integration processes easily 



%prep
%autosetup -n pdip-0.6.6

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pdip -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.6.6-1
- Package Spec generated