%global _empty_manifest_terminate_build 0
Name: python-ASAPPpy
Version: 0.2b1
Release: 1
Summary: Semantic Textual Similarity and Dialogue System package for Python
License: MIT License
URL: https://pypi.org/project/ASAPPpy/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/5f/1f/44acd08d953fe5c922022863e3b2d3ec74c937fb06580202ddb771162e3d/ASAPPpy-0.2b1.tar.gz
BuildArch: noarch
Requires: python3-setuptools
Requires: python3-imbalanced-learn
Requires: python3-scikit-learn
Requires: python3-pandas
Requires: python3-requests
Requires: python3-slackclient
Requires: python3-slackeventsapi
Requires: python3-nltk
Requires: python3-NLPyPort
Requires: python3-spacy
Requires: python3-gensim
Requires: python3-joblib
Requires: python3-num2words
Requires: python3-Whoosh
Requires: python3-Keras
Requires: python3-tensorflow
Requires: python3-cufflinks
Requires: python3-matplotlib
Requires: python3-seaborn
%description
## ASAPPpy
ASAPPpy is a Python package for developing models to compute the Semantic Textual Similarity (STS) between texts in Portuguese. These models follow a supervised learning approach to learn an STS function from annotated sentence pairs, considering a variety of lexical, syntactic, semantic and distributional features.
ASAPPpy can also be used to develop STS based dialogue agents and deploy them to Slack.
### Development
If you want to contribute to this project, please follow the [Google Python Style Guide](https://google.github.io/styleguide/pyguide.html).
### Installation
Before getting started, verify that pip >= 20.3.3. If not, update it with this command:
```bash
pip install --upgrade pip
```
To install the latest version of ASAPPpy use the following command:
```bash
pip install ASAPPpy
```
After finishing the installation, you might need to download the word embeddings models. Given that they were obtained from various sources, we collected them and they can be downloaded at once by running the Python interpreter in your terminal followed by these commands:
```python
import ASAPPpy
ASAPPpy.download()
```
Finally, if you have never used [spaCy](https://spacy.io) before and you want to use the dependency parsing features, you will need to run the next command in the terminal:
```bash
python -m spacy download pt_core_news_sm
```
Alternatively, you can check the latest version of ASAPPpy using this command:
```bash
git clone https://github.com/ZPedroP/ASAPPpy.git
```
### Project History
ASAP(P) is the name of a collection of systems developed by the [Natural Language Processing group](http://nlp.dei.uc.pt) at [CISUC](https://www.cisuc.uc.pt/home) for computing STS based on a regression method and a set of lexical, syntactic, semantic and distributional features extracted from text.
It was used to participate in several STS evaluation tasks, for English and Portuguese, but was only recently integrated into two single independent frameworks: ASAPPpy (available here), in Python, and ASAPPj, in Java.
### Help and Support
#### Documentation
Coming soon...
#### Communication
If you have any questions feel free to open a new issue and we will respond as soon as possible.
#### Citation
When [citing ASAPPpy in academic papers and theses](http://ceur-ws.org/Vol-2583/2_ASAPPpy.pdf), please use the following BibTeX entry:
@inproceedings{santos_etal:assin2020,
title = {ASAPPpy: a Python Framework for Portuguese STS},
author = {José Santos and Ana Alves and Hugo {Gonçalo Oliveira}},
url = {http://ceur-ws.org/Vol-2583/2_ASAPPpy.pdf},
year = {2020},
date = {2020-01-01},
booktitle = {Proceedings of the ASSIN 2 Shared Task: Evaluating Semantic Textual Similarity and Textual Entailment in Portuguese},
volume = {2583},
pages = {14--26},
publisher = {CEUR-WS.org},
series = {CEUR Workshop Proceedings},
keywords = {aia, asap, sts},
pubstate = {published},
tppubtype = {inproceedings}
}
%package -n python3-ASAPPpy
Summary: Semantic Textual Similarity and Dialogue System package for Python
Provides: python-ASAPPpy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-ASAPPpy
## ASAPPpy
ASAPPpy is a Python package for developing models to compute the Semantic Textual Similarity (STS) between texts in Portuguese. These models follow a supervised learning approach to learn an STS function from annotated sentence pairs, considering a variety of lexical, syntactic, semantic and distributional features.
ASAPPpy can also be used to develop STS based dialogue agents and deploy them to Slack.
### Development
If you want to contribute to this project, please follow the [Google Python Style Guide](https://google.github.io/styleguide/pyguide.html).
### Installation
Before getting started, verify that pip >= 20.3.3. If not, update it with this command:
```bash
pip install --upgrade pip
```
To install the latest version of ASAPPpy use the following command:
```bash
pip install ASAPPpy
```
After finishing the installation, you might need to download the word embeddings models. Given that they were obtained from various sources, we collected them and they can be downloaded at once by running the Python interpreter in your terminal followed by these commands:
```python
import ASAPPpy
ASAPPpy.download()
```
Finally, if you have never used [spaCy](https://spacy.io) before and you want to use the dependency parsing features, you will need to run the next command in the terminal:
```bash
python -m spacy download pt_core_news_sm
```
Alternatively, you can check the latest version of ASAPPpy using this command:
```bash
git clone https://github.com/ZPedroP/ASAPPpy.git
```
### Project History
ASAP(P) is the name of a collection of systems developed by the [Natural Language Processing group](http://nlp.dei.uc.pt) at [CISUC](https://www.cisuc.uc.pt/home) for computing STS based on a regression method and a set of lexical, syntactic, semantic and distributional features extracted from text.
It was used to participate in several STS evaluation tasks, for English and Portuguese, but was only recently integrated into two single independent frameworks: ASAPPpy (available here), in Python, and ASAPPj, in Java.
### Help and Support
#### Documentation
Coming soon...
#### Communication
If you have any questions feel free to open a new issue and we will respond as soon as possible.
#### Citation
When [citing ASAPPpy in academic papers and theses](http://ceur-ws.org/Vol-2583/2_ASAPPpy.pdf), please use the following BibTeX entry:
@inproceedings{santos_etal:assin2020,
title = {ASAPPpy: a Python Framework for Portuguese STS},
author = {José Santos and Ana Alves and Hugo {Gonçalo Oliveira}},
url = {http://ceur-ws.org/Vol-2583/2_ASAPPpy.pdf},
year = {2020},
date = {2020-01-01},
booktitle = {Proceedings of the ASSIN 2 Shared Task: Evaluating Semantic Textual Similarity and Textual Entailment in Portuguese},
volume = {2583},
pages = {14--26},
publisher = {CEUR-WS.org},
series = {CEUR Workshop Proceedings},
keywords = {aia, asap, sts},
pubstate = {published},
tppubtype = {inproceedings}
}
%package help
Summary: Development documents and examples for ASAPPpy
Provides: python3-ASAPPpy-doc
%description help
## ASAPPpy
ASAPPpy is a Python package for developing models to compute the Semantic Textual Similarity (STS) between texts in Portuguese. These models follow a supervised learning approach to learn an STS function from annotated sentence pairs, considering a variety of lexical, syntactic, semantic and distributional features.
ASAPPpy can also be used to develop STS based dialogue agents and deploy them to Slack.
### Development
If you want to contribute to this project, please follow the [Google Python Style Guide](https://google.github.io/styleguide/pyguide.html).
### Installation
Before getting started, verify that pip >= 20.3.3. If not, update it with this command:
```bash
pip install --upgrade pip
```
To install the latest version of ASAPPpy use the following command:
```bash
pip install ASAPPpy
```
After finishing the installation, you might need to download the word embeddings models. Given that they were obtained from various sources, we collected them and they can be downloaded at once by running the Python interpreter in your terminal followed by these commands:
```python
import ASAPPpy
ASAPPpy.download()
```
Finally, if you have never used [spaCy](https://spacy.io) before and you want to use the dependency parsing features, you will need to run the next command in the terminal:
```bash
python -m spacy download pt_core_news_sm
```
Alternatively, you can check the latest version of ASAPPpy using this command:
```bash
git clone https://github.com/ZPedroP/ASAPPpy.git
```
### Project History
ASAP(P) is the name of a collection of systems developed by the [Natural Language Processing group](http://nlp.dei.uc.pt) at [CISUC](https://www.cisuc.uc.pt/home) for computing STS based on a regression method and a set of lexical, syntactic, semantic and distributional features extracted from text.
It was used to participate in several STS evaluation tasks, for English and Portuguese, but was only recently integrated into two single independent frameworks: ASAPPpy (available here), in Python, and ASAPPj, in Java.
### Help and Support
#### Documentation
Coming soon...
#### Communication
If you have any questions feel free to open a new issue and we will respond as soon as possible.
#### Citation
When [citing ASAPPpy in academic papers and theses](http://ceur-ws.org/Vol-2583/2_ASAPPpy.pdf), please use the following BibTeX entry:
@inproceedings{santos_etal:assin2020,
title = {ASAPPpy: a Python Framework for Portuguese STS},
author = {José Santos and Ana Alves and Hugo {Gonçalo Oliveira}},
url = {http://ceur-ws.org/Vol-2583/2_ASAPPpy.pdf},
year = {2020},
date = {2020-01-01},
booktitle = {Proceedings of the ASSIN 2 Shared Task: Evaluating Semantic Textual Similarity and Textual Entailment in Portuguese},
volume = {2583},
pages = {14--26},
publisher = {CEUR-WS.org},
series = {CEUR Workshop Proceedings},
keywords = {aia, asap, sts},
pubstate = {published},
tppubtype = {inproceedings}
}
%prep
%autosetup -n ASAPPpy-0.2b1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-ASAPPpy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 0.2b1-1
- Package Spec generated