%global _empty_manifest_terminate_build 0
Name: python-fakeproj-nightly
Version: 20210427
Release: 1
Summary: Mostly useless code to demonstrate Python DevOps tools
License: MIT License
URL: https://github.com/lazyoracle/fakeproj
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/81/60/b77c0786a1983507509dbaf973816ae4f2e52fb9831a89a48e314fb8321f/fakeproj-nightly-20210427.tar.gz
BuildArch: noarch
Requires: python3-numpy
%description
# fakeproj: DevOps for Dummies
![unit test](https://github.com/lazyoracle/fakeproj/workflows/Unit%20Testing/badge.svg)
![integration test](https://github.com/lazyoracle/fakeproj/workflows/Integration%20Testing/badge.svg)
![coverage](https://github.com/lazyoracle/fakeproj/workflows/Code%20Coverage/badge.svg)
[![codecov](https://codecov.io/gh/lazyoracle/fakeproj/branch/master/graph/badge.svg)](https://codecov.io/gh/lazyoracle/fakeproj)
![complexity test](https://github.com/lazyoracle/fakeproj/workflows/Code%20Complexity/badge.svg)
![build test](https://github.com/lazyoracle/fakeproj/workflows/Python%20package%20Build/badge.svg)
[![Documentation Status](https://readthedocs.org/projects/fakeproj/badge/?version=latest)](https://fakeproj.readthedocs.io/en/latest/?badge=latest)
[![Maintenance](https://img.shields.io/badge/Maintained%3F-yes-green.svg)](https://GitHub.com/lazyoracle/fakeproj/graphs/commit-activity)
[![GitHub issues](https://img.shields.io/github/issues/lazyoracle/fakeproj.svg)](https://GitHub.com/lazyoracle/fakeproj/issues/)
[![PRs Welcome](https://img.shields.io/badge/PRs-welcome-brightgreen.svg)](http://makeapullrequest.com)
[![PyPI version fury.io](https://badge.fury.io/py/fakeproj.svg)](https://pypi.python.org/pypi/fakeproj/)
[![PyPI license](https://img.shields.io/pypi/l/fakeproj.svg)](https://pypi.python.org/pypi/fakeproj/)
[![PyPI pyversions](https://img.shields.io/pypi/pyversions/fakeproj.svg)](https://pypi.python.org/pypi/fakeproj/)
[![GitHub release](https://img.shields.io/github/release/lazyoracle/fakeproj.svg)](https://GitHub.com/lazyoracle/fakeproj/releases/)
A dummy project to introduce various DevOps tools and Best Practices to Python developers. Follow along with the tutorial on [fakeproj.readthedocs.io](https://fakeproj.readthedocs.io)
## Installation
```bash
pip install .
```
### Developer Setup
```bash
pip install -r requirements.txt
```
### Testing
```bash
pytest -s -v --cov=fakeproj test/
```
There are markers for individual modules from the library, eg,
```bash
pytest -v -m "goodmodule" --cov=fakeproj test/
```
### Benchmarks
Benchmarks can be run locally using `asv run`, followed by `asv publish` and `asv preview`.
The benchmarks are also available to view online at [here](https://lazyoracle.github.io/fakeproj/).
To update the online dashboard by pushing the latest benchmarks, use `asv gh-pages`
### Complexity
```bash
radon cc -a .
xenon --max-absolute B --max-modules B --max-average A .
```
### Docstrings
```bash
docstr-coverage .
```
### GitHub Actions
* Unit Testing (Python 3.6, 3.7, 3.8 on ubuntu:latest)
* Code Coverage
* Code Complexity (Maximum CC of B/B/A)
* Build Testing (Python 3.6, 3.7, 3.8 on {ubuntu, macos, windows}:latest)
### Code Formatting
This project uses [Black](https://black.readthedocs.io/en/stable/) for Code Formatting
## To-Do
- [ ] Populate Docs
%package -n python3-fakeproj-nightly
Summary: Mostly useless code to demonstrate Python DevOps tools
Provides: python-fakeproj-nightly
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-fakeproj-nightly
# fakeproj: DevOps for Dummies
![unit test](https://github.com/lazyoracle/fakeproj/workflows/Unit%20Testing/badge.svg)
![integration test](https://github.com/lazyoracle/fakeproj/workflows/Integration%20Testing/badge.svg)
![coverage](https://github.com/lazyoracle/fakeproj/workflows/Code%20Coverage/badge.svg)
[![codecov](https://codecov.io/gh/lazyoracle/fakeproj/branch/master/graph/badge.svg)](https://codecov.io/gh/lazyoracle/fakeproj)
![complexity test](https://github.com/lazyoracle/fakeproj/workflows/Code%20Complexity/badge.svg)
![build test](https://github.com/lazyoracle/fakeproj/workflows/Python%20package%20Build/badge.svg)
[![Documentation Status](https://readthedocs.org/projects/fakeproj/badge/?version=latest)](https://fakeproj.readthedocs.io/en/latest/?badge=latest)
[![Maintenance](https://img.shields.io/badge/Maintained%3F-yes-green.svg)](https://GitHub.com/lazyoracle/fakeproj/graphs/commit-activity)
[![GitHub issues](https://img.shields.io/github/issues/lazyoracle/fakeproj.svg)](https://GitHub.com/lazyoracle/fakeproj/issues/)
[![PRs Welcome](https://img.shields.io/badge/PRs-welcome-brightgreen.svg)](http://makeapullrequest.com)
[![PyPI version fury.io](https://badge.fury.io/py/fakeproj.svg)](https://pypi.python.org/pypi/fakeproj/)
[![PyPI license](https://img.shields.io/pypi/l/fakeproj.svg)](https://pypi.python.org/pypi/fakeproj/)
[![PyPI pyversions](https://img.shields.io/pypi/pyversions/fakeproj.svg)](https://pypi.python.org/pypi/fakeproj/)
[![GitHub release](https://img.shields.io/github/release/lazyoracle/fakeproj.svg)](https://GitHub.com/lazyoracle/fakeproj/releases/)
A dummy project to introduce various DevOps tools and Best Practices to Python developers. Follow along with the tutorial on [fakeproj.readthedocs.io](https://fakeproj.readthedocs.io)
## Installation
```bash
pip install .
```
### Developer Setup
```bash
pip install -r requirements.txt
```
### Testing
```bash
pytest -s -v --cov=fakeproj test/
```
There are markers for individual modules from the library, eg,
```bash
pytest -v -m "goodmodule" --cov=fakeproj test/
```
### Benchmarks
Benchmarks can be run locally using `asv run`, followed by `asv publish` and `asv preview`.
The benchmarks are also available to view online at [here](https://lazyoracle.github.io/fakeproj/).
To update the online dashboard by pushing the latest benchmarks, use `asv gh-pages`
### Complexity
```bash
radon cc -a .
xenon --max-absolute B --max-modules B --max-average A .
```
### Docstrings
```bash
docstr-coverage .
```
### GitHub Actions
* Unit Testing (Python 3.6, 3.7, 3.8 on ubuntu:latest)
* Code Coverage
* Code Complexity (Maximum CC of B/B/A)
* Build Testing (Python 3.6, 3.7, 3.8 on {ubuntu, macos, windows}:latest)
### Code Formatting
This project uses [Black](https://black.readthedocs.io/en/stable/) for Code Formatting
## To-Do
- [ ] Populate Docs
%package help
Summary: Development documents and examples for fakeproj-nightly
Provides: python3-fakeproj-nightly-doc
%description help
# fakeproj: DevOps for Dummies
![unit test](https://github.com/lazyoracle/fakeproj/workflows/Unit%20Testing/badge.svg)
![integration test](https://github.com/lazyoracle/fakeproj/workflows/Integration%20Testing/badge.svg)
![coverage](https://github.com/lazyoracle/fakeproj/workflows/Code%20Coverage/badge.svg)
[![codecov](https://codecov.io/gh/lazyoracle/fakeproj/branch/master/graph/badge.svg)](https://codecov.io/gh/lazyoracle/fakeproj)
![complexity test](https://github.com/lazyoracle/fakeproj/workflows/Code%20Complexity/badge.svg)
![build test](https://github.com/lazyoracle/fakeproj/workflows/Python%20package%20Build/badge.svg)
[![Documentation Status](https://readthedocs.org/projects/fakeproj/badge/?version=latest)](https://fakeproj.readthedocs.io/en/latest/?badge=latest)
[![Maintenance](https://img.shields.io/badge/Maintained%3F-yes-green.svg)](https://GitHub.com/lazyoracle/fakeproj/graphs/commit-activity)
[![GitHub issues](https://img.shields.io/github/issues/lazyoracle/fakeproj.svg)](https://GitHub.com/lazyoracle/fakeproj/issues/)
[![PRs Welcome](https://img.shields.io/badge/PRs-welcome-brightgreen.svg)](http://makeapullrequest.com)
[![PyPI version fury.io](https://badge.fury.io/py/fakeproj.svg)](https://pypi.python.org/pypi/fakeproj/)
[![PyPI license](https://img.shields.io/pypi/l/fakeproj.svg)](https://pypi.python.org/pypi/fakeproj/)
[![PyPI pyversions](https://img.shields.io/pypi/pyversions/fakeproj.svg)](https://pypi.python.org/pypi/fakeproj/)
[![GitHub release](https://img.shields.io/github/release/lazyoracle/fakeproj.svg)](https://GitHub.com/lazyoracle/fakeproj/releases/)
A dummy project to introduce various DevOps tools and Best Practices to Python developers. Follow along with the tutorial on [fakeproj.readthedocs.io](https://fakeproj.readthedocs.io)
## Installation
```bash
pip install .
```
### Developer Setup
```bash
pip install -r requirements.txt
```
### Testing
```bash
pytest -s -v --cov=fakeproj test/
```
There are markers for individual modules from the library, eg,
```bash
pytest -v -m "goodmodule" --cov=fakeproj test/
```
### Benchmarks
Benchmarks can be run locally using `asv run`, followed by `asv publish` and `asv preview`.
The benchmarks are also available to view online at [here](https://lazyoracle.github.io/fakeproj/).
To update the online dashboard by pushing the latest benchmarks, use `asv gh-pages`
### Complexity
```bash
radon cc -a .
xenon --max-absolute B --max-modules B --max-average A .
```
### Docstrings
```bash
docstr-coverage .
```
### GitHub Actions
* Unit Testing (Python 3.6, 3.7, 3.8 on ubuntu:latest)
* Code Coverage
* Code Complexity (Maximum CC of B/B/A)
* Build Testing (Python 3.6, 3.7, 3.8 on {ubuntu, macos, windows}:latest)
### Code Formatting
This project uses [Black](https://black.readthedocs.io/en/stable/) for Code Formatting
## To-Do
- [ ] Populate Docs
%prep
%autosetup -n fakeproj-nightly-20210427
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-fakeproj-nightly -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 20210427-1
- Package Spec generated