%global _empty_manifest_terminate_build 0
Name:		python-osducli
Version:	0.0.37
Release:	1
Summary:	OSDU command line
License:	Apache
URL:		https://community.opengroup.org/osdu/platform/data-flow/data-loading/osdu-cli
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/04/29/c6e4ff0f7dc3aaa72b8af8c7c5c4f4356e6db9c750456e8a098e8ae84235/osducli-0.0.37.tar.gz
BuildArch:	noarch

Requires:	python3-click
Requires:	python3-jmespath
Requires:	python3-osdu-sdk
Requires:	python3-requests
Requires:	python3-tabulate
Requires:	python3-msal

%description
Command-line interface for interacting with OSDU.

%package -n python3-osducli
Summary:	OSDU command line
Provides:	python-osducli
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-osducli
Command-line interface for interacting with OSDU.

%package help
Summary:	Development documents and examples for osducli
Provides:	python3-osducli-doc
%description help
Command-line interface for interacting with OSDU.

%prep
%autosetup -n osducli-0.0.37

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-osducli -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.37-1
- Package Spec generated