%global _empty_manifest_terminate_build 0
Name:		python-pyisic
Version:	0.1.16
Release:	1
Summary:	Standard industrial classification standardization
License:	MIT
URL:		https://github.com/sayari-analytics/pyisic
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/ae/98/dd8729e1bdabb34240cdd407826ad85317c2acc72d16c4f5970be75399ca/pyisic-0.1.16.tar.gz
BuildArch:	noarch

Requires:	python3-networkx
Requires:	python3-pytest
Requires:	python3-pytest-cov
Requires:	python3-black
Requires:	python3-pre-commit
Requires:	python3-sphinx
Requires:	python3-sphinx-rtd-theme

%description
******
Pyisic
******
.. image:: https://github.com/sayari-analytics/pyisic/actions/workflows/main.yaml/badge.svg?branch=main

.. image:: https://img.shields.io/codecov/c/github/sayari-analytics/pyisic/master.svg
   :target: https://codecov.io/github/sayari-analytics/pyisic?branch=master
   :alt: Coverage report

.. image:: https://img.shields.io/pypi/v/pyisic.svg
   :target: https://pypi.python.org/pypi/pyisic
   :alt: PyPI Version

.. image:: https://img.shields.io/pypi/pyversions/pyisic.svg
   :target: https://pypi.python.org/pypi/pyisic
   :alt: Supported Python Versions

.. image:: https://img.shields.io/pypi/l/pyisic.svg
   :target: https://github.com/sayari-analytics/pyisic/blob/main/LICENSE
   :alt: License

Overview
########
Pyisic defines industrial classification standards and concordances between standards.

.. pull-quote::
    The `International Standard Industrial Classification of All Economic Activities (ISIC) <https://unstats.un.org/unsd/classifications/Econ/ISIC.cshtml>`_ is the international reference classification of productive activities. Its main purpose is to provide a set of activity categories that can be utilized for the collection and reporting of statistics according to such activities. Since the adoption of the original version of ISIC in 1948, the majority of countries around the world have used ISIC as their national activity classification or have developed national classifications derived from ISIC.

Usage
+++++

.. code-block:: python

    >>> import pyisic
    >>> pyisic.NAICS2017['927110']
    {'code': '927110', 'description': 'Space Research and Technology', 'category': None}

    >>> pyisic.NAICS2017_to_ISIC4.concordant("927110")
    {(<Standard.ISIC4: 'ISIC4'>, '5120'), (<Standard.ISIC4: 'ISIC4'>, '8413')}

Install
#######

.. code-block:: bash

    pip install pyisic


Documentation
#############

The official documentation is hosted on readthedocs.org: `pyisic.readthedocs.io <https://pyisic.readthedocs.io>`_

Contributing
############
Issues and pull requests are welcome!

Refer to `CONTRIBUTING.rst <https://github.com/sayari-analytics/pyisic/blob/main/CONTRIBUTING.rst>`_ for more details about the workflow and hints on how to prepare your pull request.


%package -n python3-pyisic
Summary:	Standard industrial classification standardization
Provides:	python-pyisic
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pyisic
******
Pyisic
******
.. image:: https://github.com/sayari-analytics/pyisic/actions/workflows/main.yaml/badge.svg?branch=main

.. image:: https://img.shields.io/codecov/c/github/sayari-analytics/pyisic/master.svg
   :target: https://codecov.io/github/sayari-analytics/pyisic?branch=master
   :alt: Coverage report

.. image:: https://img.shields.io/pypi/v/pyisic.svg
   :target: https://pypi.python.org/pypi/pyisic
   :alt: PyPI Version

.. image:: https://img.shields.io/pypi/pyversions/pyisic.svg
   :target: https://pypi.python.org/pypi/pyisic
   :alt: Supported Python Versions

.. image:: https://img.shields.io/pypi/l/pyisic.svg
   :target: https://github.com/sayari-analytics/pyisic/blob/main/LICENSE
   :alt: License

Overview
########
Pyisic defines industrial classification standards and concordances between standards.

.. pull-quote::
    The `International Standard Industrial Classification of All Economic Activities (ISIC) <https://unstats.un.org/unsd/classifications/Econ/ISIC.cshtml>`_ is the international reference classification of productive activities. Its main purpose is to provide a set of activity categories that can be utilized for the collection and reporting of statistics according to such activities. Since the adoption of the original version of ISIC in 1948, the majority of countries around the world have used ISIC as their national activity classification or have developed national classifications derived from ISIC.

Usage
+++++

.. code-block:: python

    >>> import pyisic
    >>> pyisic.NAICS2017['927110']
    {'code': '927110', 'description': 'Space Research and Technology', 'category': None}

    >>> pyisic.NAICS2017_to_ISIC4.concordant("927110")
    {(<Standard.ISIC4: 'ISIC4'>, '5120'), (<Standard.ISIC4: 'ISIC4'>, '8413')}

Install
#######

.. code-block:: bash

    pip install pyisic


Documentation
#############

The official documentation is hosted on readthedocs.org: `pyisic.readthedocs.io <https://pyisic.readthedocs.io>`_

Contributing
############
Issues and pull requests are welcome!

Refer to `CONTRIBUTING.rst <https://github.com/sayari-analytics/pyisic/blob/main/CONTRIBUTING.rst>`_ for more details about the workflow and hints on how to prepare your pull request.


%package help
Summary:	Development documents and examples for pyisic
Provides:	python3-pyisic-doc
%description help
******
Pyisic
******
.. image:: https://github.com/sayari-analytics/pyisic/actions/workflows/main.yaml/badge.svg?branch=main

.. image:: https://img.shields.io/codecov/c/github/sayari-analytics/pyisic/master.svg
   :target: https://codecov.io/github/sayari-analytics/pyisic?branch=master
   :alt: Coverage report

.. image:: https://img.shields.io/pypi/v/pyisic.svg
   :target: https://pypi.python.org/pypi/pyisic
   :alt: PyPI Version

.. image:: https://img.shields.io/pypi/pyversions/pyisic.svg
   :target: https://pypi.python.org/pypi/pyisic
   :alt: Supported Python Versions

.. image:: https://img.shields.io/pypi/l/pyisic.svg
   :target: https://github.com/sayari-analytics/pyisic/blob/main/LICENSE
   :alt: License

Overview
########
Pyisic defines industrial classification standards and concordances between standards.

.. pull-quote::
    The `International Standard Industrial Classification of All Economic Activities (ISIC) <https://unstats.un.org/unsd/classifications/Econ/ISIC.cshtml>`_ is the international reference classification of productive activities. Its main purpose is to provide a set of activity categories that can be utilized for the collection and reporting of statistics according to such activities. Since the adoption of the original version of ISIC in 1948, the majority of countries around the world have used ISIC as their national activity classification or have developed national classifications derived from ISIC.

Usage
+++++

.. code-block:: python

    >>> import pyisic
    >>> pyisic.NAICS2017['927110']
    {'code': '927110', 'description': 'Space Research and Technology', 'category': None}

    >>> pyisic.NAICS2017_to_ISIC4.concordant("927110")
    {(<Standard.ISIC4: 'ISIC4'>, '5120'), (<Standard.ISIC4: 'ISIC4'>, '8413')}

Install
#######

.. code-block:: bash

    pip install pyisic


Documentation
#############

The official documentation is hosted on readthedocs.org: `pyisic.readthedocs.io <https://pyisic.readthedocs.io>`_

Contributing
############
Issues and pull requests are welcome!

Refer to `CONTRIBUTING.rst <https://github.com/sayari-analytics/pyisic/blob/main/CONTRIBUTING.rst>`_ for more details about the workflow and hints on how to prepare your pull request.


%prep
%autosetup -n pyisic-0.1.16

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pyisic -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.16-1
- Package Spec generated