generalfile
Easily manage files cross platform.
Table of Contents
generalfile
├─ Dependency Diagram for ManderaGeneral
├─ Installation showing dependencies
├─ Information
├─ Attributes
├─ Contributions
└─ Todo
Dependency Diagram for ManderaGeneral
```mermaid
flowchart LR
1([library]) --> 4([packager])
2([file]) --> 4([packager])
1([library]) --> 2([file])
0([import]) --> 1([library])
0([import]) --> 2([file])
1([library]) --> 3([vector])
click 0 "https://github.com/ManderaGeneral/generalimport"
click 1 "https://github.com/ManderaGeneral/generallibrary"
click 2 "https://github.com/ManderaGeneral/generalfile"
click 3 "https://github.com/ManderaGeneral/generalvector"
click 4 "https://github.com/ManderaGeneral/generalpackager"
style 2 fill:#482
```
Installation showing dependencies
| `pip install` | `generalfile` | `generalfile[spreadsheet]` | `generalfile[full]` |
|:---------------------------------------------------------------------|:----------------|:-----------------------------|:----------------------|
| generalimport | ✔️ | ✔️ | ✔️ |
| generallibrary | ✔️ | ✔️ | ✔️ |
| send2trash | ✔️ | ✔️ | ✔️ |
| appdirs | ✔️ | ✔️ | ✔️ |
| dill | ✔️ | ✔️ | ✔️ |
| pandas | ❌ | ✔️ | ✔️ |
Information
| Package | Ver | Latest Release | Python | Platform | Cover |
|:-------------------------------------------------------------|:------------------------------------------------|:----------------------|:-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------|:----------------|:--------|
| [generalfile](https://github.com/ManderaGeneral/generalfile) | [2.5.14](https://pypi.org/project/generalfile/) | 2022-10-27 16:21 CEST | [3.8](https://www.python.org/downloads/release/python-380/), [3.9](https://www.python.org/downloads/release/python-390/), [3.10](https://www.python.org/downloads/release/python-3100/), [3.11](https://www.python.org/downloads/release/python-3110/) | Windows, Ubuntu | 72.2 % |
Attributes
Module: generalfile
├─ Class: CaseSensitivityError
├─ Class: ConfigFile
│ ├─ Method: exists
│ ├─ Method: get_custom_serializers
│ ├─ Method: get_field_dict_serializable
│ ├─ Method: halt_getattr
│ ├─ Method: read_hook_post
│ ├─ Method: read_hook_pre
│ ├─ Method: safe_equals
│ ├─ Method: write_config
│ ├─ Method: write_hook_post
│ └─ Method: write_hook_pre
├─ Class: InvalidCharacterError
└─ Class: Path
├─ Class: Path
├─ Method: absolute
├─ Method: as_working_dir
├─ Property: cfg
├─ Method: contains
├─ Method: copy
├─ Method: copy_to_folder
├─ Method: create_folder
├─ Method: delete
├─ Method: delete_folder_content
├─ Method: empty
├─ Method: encode
├─ Method: endswith
├─ Method: exists
├─ Method: forward_slash
├─ Method: from_alternative
├─ Method: get_active_venv
├─ Method: get_cache_dir
├─ Method: get_differing_files
├─ Method: get_lock_dir
├─ Method: get_lock_path
├─ Method: get_parent_package
├─ Method: get_parent_repo
├─ Method: get_parent_venv
├─ Method: get_working_dir
├─ Method: is_absolute
├─ Method: is_file
├─ Method: is_folder
├─ Method: is_identical
├─ Method: is_package
├─ Method: is_relative
├─ Method: is_repo
├─ Method: is_root
├─ Method: is_venv
├─ Method: lock
├─ Method: match
├─ Method: mirror_path
├─ Method: move
├─ Method: name
├─ Method: open_folder
├─ Method: open_operation
├─ Method: pack
├─ Method: parts
├─ Property: pickle
├─ Method: read
├─ Method: relative
├─ Method: remove_end
├─ Method: remove_start
├─ Method: rename
├─ Method: root
├─ Method: same_destination
├─ Method: scrub
├─ Method: seconds_since_creation
├─ Method: seconds_since_modified
├─ Method: set_working_dir
├─ Method: size
├─ Method: spawn_children
├─ Method: spawn_parents
├─ Property: spreadsheet
├─ Method: startswith
├─ Method: stem
├─ Method: suffix
├─ Method: suffixes
├─ Property: text
├─ Method: to_alternative
├─ Method: trash
├─ Method: trash_folder_content
├─ Method: true_stem
├─ Method: unpack
├─ Method: view_paths
├─ Method: with_name
├─ Method: with_stem
├─ Method: with_suffix
├─ Method: with_suffixes
├─ Method: with_true_stem
├─ Method: without_file
└─ Method: write
Contributions
Issue-creation and discussions are most welcome!
Pull requests are not wanted, please discuss with me before investing any time
Todo
| Module | Message |
|:-------------------------------------------------------------------------------------------------------------------------------------------------------|:--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------|
| path_spreadsheet.py | Support DataFrame and Series with spreadsheet.append() |
| path.py | Binary extension. |
| path_lock.py | Lock the optional extra paths. |
| path_operations.py | Fix contains() using raw open() |
| configfile.py | Handle custom serializers within iterable for ConfigFile. |
Generated 2022-10-27 16:21 CEST for commit 14b028f3.
%package -n python3-generalfile
Summary: Easily manage files cross platform.
Provides: python-generalfile
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-generalfile