%global _empty_manifest_terminate_build 0
Name:		python-vat-format-checker
Version:	0.0.4
Release:	1
Summary:	A library for checking on European VAT formats
License:	MIT License
URL:		https://github.com/agilegeeks/pyVat
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/c8/2c/4195d2dd3a4b122ad391b1084385372190e5213a7f21d456fdc431c9f395/vat-format-checker-0.0.4.tar.gz
BuildArch:	noarch


%description
# A library for checking on European VAT formats

[![Build Status](https://api.travis-ci.com/agilegeeks/pyVat.svg?branch=master)](https://travis-ci.com/agilegeeks/pyVat)

pyVat is a complete library that validates vat number formats in EU member countries. The algorithms used are described in /doc/VIES-VAT Validation Routines-v15.0.doc

## Compatibility
Python >= 2.6

## Installation
    $ pip install vat-format-checker

## Usage
```python
from pyVat.api import Validator
validator = Validator('ATU10223006')
if validator.validate() is True:
    print ("The VAT number has a valid format")
else:
    print ("Invalid VAT number format for country %s" % validator.country_code)

```
## Issues
- The Croatian format is missing the algorithm. The validations is done purely based on regular expressions.




%package -n python3-vat-format-checker
Summary:	A library for checking on European VAT formats
Provides:	python-vat-format-checker
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-vat-format-checker
# A library for checking on European VAT formats

[![Build Status](https://api.travis-ci.com/agilegeeks/pyVat.svg?branch=master)](https://travis-ci.com/agilegeeks/pyVat)

pyVat is a complete library that validates vat number formats in EU member countries. The algorithms used are described in /doc/VIES-VAT Validation Routines-v15.0.doc

## Compatibility
Python >= 2.6

## Installation
    $ pip install vat-format-checker

## Usage
```python
from pyVat.api import Validator
validator = Validator('ATU10223006')
if validator.validate() is True:
    print ("The VAT number has a valid format")
else:
    print ("Invalid VAT number format for country %s" % validator.country_code)

```
## Issues
- The Croatian format is missing the algorithm. The validations is done purely based on regular expressions.




%package help
Summary:	Development documents and examples for vat-format-checker
Provides:	python3-vat-format-checker-doc
%description help
# A library for checking on European VAT formats

[![Build Status](https://api.travis-ci.com/agilegeeks/pyVat.svg?branch=master)](https://travis-ci.com/agilegeeks/pyVat)

pyVat is a complete library that validates vat number formats in EU member countries. The algorithms used are described in /doc/VIES-VAT Validation Routines-v15.0.doc

## Compatibility
Python >= 2.6

## Installation
    $ pip install vat-format-checker

## Usage
```python
from pyVat.api import Validator
validator = Validator('ATU10223006')
if validator.validate() is True:
    print ("The VAT number has a valid format")
else:
    print ("Invalid VAT number format for country %s" % validator.country_code)

```
## Issues
- The Croatian format is missing the algorithm. The validations is done purely based on regular expressions.




%prep
%autosetup -n vat-format-checker-0.0.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-vat-format-checker -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.4-1
- Package Spec generated