%global _empty_manifest_terminate_build 0
Name:		python-sxdm
Version:	1.0.0
Release:	1
Summary:	Tools for analyzing Scanning X-ray Diffraction Microscopy data
License:	GNU General Public License v3 or later (GPLv3+)
URL:		https://github.com/WilliamJudge94/sxdm
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/a6/d7/b6acf764f12f59f098d33cb5c66f05b1960e77c11dc491da3961404cd485/sxdm-1.0.0.tar.gz
BuildArch:	noarch

Requires:	python3-h5py
Requires:	python3-matplotlib
Requires:	python3-psutil
Requires:	python3-numpy
Requires:	python3-tqdm
Requires:	python3-tifffile
Requires:	python3-miniutils
Requires:	python3-imageio
Requires:	python3-nose
Requires:	python3-progressbar
Requires:	python3-scipy
Requires:	python3-opencv-python
Requires:	python3-PyQt5
Requires:	python3-pyparsing
Requires:	python3-docutils

%description
SXDM is a library for analyzing Scanning X-Ray Diffraction Microscopy data
for materials science, chemistry and similar fields. The major focus is on
Scanning Microscopy frames collected at multiple incident angles. One can
import, retrieve, and analyze 26 - ID - C datasets, including X-ray
Fluorescence data, all from a Python format.

%package -n python3-sxdm
Summary:	Tools for analyzing Scanning X-ray Diffraction Microscopy data
Provides:	python-sxdm
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-sxdm
SXDM is a library for analyzing Scanning X-Ray Diffraction Microscopy data
for materials science, chemistry and similar fields. The major focus is on
Scanning Microscopy frames collected at multiple incident angles. One can
import, retrieve, and analyze 26 - ID - C datasets, including X-ray
Fluorescence data, all from a Python format.

%package help
Summary:	Development documents and examples for sxdm
Provides:	python3-sxdm-doc
%description help
SXDM is a library for analyzing Scanning X-Ray Diffraction Microscopy data
for materials science, chemistry and similar fields. The major focus is on
Scanning Microscopy frames collected at multiple incident angles. One can
import, retrieve, and analyze 26 - ID - C datasets, including X-ray
Fluorescence data, all from a Python format.

%prep
%autosetup -n sxdm-1.0.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-sxdm -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.0-1
- Package Spec generated