%global _empty_manifest_terminate_build 0
Name: python-BioClients
Version: 0.2.11
Release: 1
Summary: Clients for online biomedical resources, usually REST APIs.
License: MIT License
URL: https://github.com/jeremyjyang/BioClients
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/5b/3b/d8e72d59166c43ba184fb4ea3d040a6b5b0b6408d88e2e232c882aa53d92/BioClients-0.2.11.tar.gz
BuildArch: noarch
%description
# `BioClients`
Python package for access to online biomedical resources,
usually via REST APIs. Modules generally include
`Client.py` for command-line use and `Utils.py` for
integration into other code. With the advent of HTTP web services,
first SOAP/XML and then mostly REST/JSON, many online APIs
require very similar methods for data search, requests
and transforms into usable formats, often TSV.
## Availability and installation
Source at ;
releases available via `pypi.org`:
(`pip3 install BioClients`).
However, current development snapshot recommended.
___(First download or clone.)___
```
$ cd BioClients
$ python3 setup.py install
```
## Dependencies
* Python 3.7+
* Python packages: `pandas`, `requests`, `urllib`, `json`, `xml`, `yaml`, `psycopg2`, `tqdm`, etc.
## Modules
[__Allen__](doc/allen.md) • [__AMP-T2D__](doc/amp__t2d.md) • [__BindingDb__](doc/bindingdb.md) • [__BioGrid__](doc/biogrid.md) • [__Bioregistry__](doc/bioregistry.md) • [__BRENDA__](doc/brenda.md) • [__CAS__](doc/cas.md) • [__CDC__](doc/cdc.md) • [__CFDE__](doc/cfde.md) • [__Chem2Bio2RDF__](doc/chem2bio2rdf.md) • [__ChEBI__](doc/chebi.md) • [__ChEMBL__](doc/chembl.md) • [__ChemIdPlus__](doc/chemidplus.md) • [__ClinicalTrials.gov__](doc/clinicaltrials.md) • [__Disease Ontology__](doc/diseaseontology.md) • [__DisGeNet__](doc/disgenet.md) • [__DNorm__](doc/dnorm.md) • [__DrugCentral__](doc/drugcentral.md) • [__EMBL-EBI__](doc/emblebi.md) • [__EnsEMBL__](doc/ensembl.md) • [__FDA__](doc/fda.md) • [__Gene Ontology__](doc/geneontology.md) • [__GTEx__](doc/gtex.md) • [__GWAS Catalog__](doc/gwascatalog.md) • [__HUGO__](doc/hugo.md) • [__HumanBase__](doc/humanbase.md) • [__iCite__](doc/icite.md) • [__IDG__](doc/idg.md) • [__JensenLab__](doc/jensenlab.md) • [__LINCS__](doc/lincs.md) • [__MaayanLab__](doc/maayanlab.md) • [__Medline__](doc/medline.md) • [__MeSH__](doc/mesh.md) • [__MONARCH__](doc/monarch.md) • [__MyGene__](doc/mygene.md) • [__NCBO__](doc/ncbo.md) • [__NCATS__](doc/ncats.md) • [__OMIM__](doc/omim.md) • [__Open Targets__](doc/opentargets.md) • [__Panther__](doc/panther.md) • [__PDB__](doc/pdb.md) • [__PubChem__](doc/pubchem.md) • [__PubMed__](doc/pubmed.md) • [__PubTator__](doc/pubtator.md) • [__Reactome__](doc/reactome.md) • [__RXNorm__](doc/rxnorm.md) • [__STRINGDB__](doc/stringdb.md) • [__TCGA__](doc/tcga.md) • [__UMLS__](doc/umls.md) • [__UniProt__](doc/uniprot.md) • [__Wikidata__](doc/wikidata.md) • [__WikiPathways__](doc/wikipathways.md)
Miscellaneous utilities: [__UTIL__](doc/util.md)
## Usage Example
```
$ python3 -m BioClients.pubchem.Client -h
```
## Design pattern
Generally each module includes command-line app `Client.py` which calls
functions in a corresponding `Utils.py`, providing all capabilities
by import of the module. Command-line apps not API clients are generally
named `App.py`. Functions can write to an output file
or return a Pandas dataframe (if output file unspecified).
## Data structures and formats, XML, JSON, and TSV
BioClients is designed to be simple and practical, and XML, JSON
and TSV are likewise simple in many respects, yet a great deal
of conceptual and technological progress is reflected. XML and JSON
can represent arbitrarily complex data objects, comprised of nested lists,
dictionaries, and trees of primary types. TSV represents tables of
rows and columns, related by common keys, reflecting the development
of SQL and relational databases. Transforming JSON to TSV, as these
clients generally do, projects data objects to tables useful for many
applications (e.g. machine learning).
%package -n python3-BioClients
Summary: Clients for online biomedical resources, usually REST APIs.
Provides: python-BioClients
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-BioClients
# `BioClients`
Python package for access to online biomedical resources,
usually via REST APIs. Modules generally include
`Client.py` for command-line use and `Utils.py` for
integration into other code. With the advent of HTTP web services,
first SOAP/XML and then mostly REST/JSON, many online APIs
require very similar methods for data search, requests
and transforms into usable formats, often TSV.
## Availability and installation
Source at ;
releases available via `pypi.org`:
(`pip3 install BioClients`).
However, current development snapshot recommended.
___(First download or clone.)___
```
$ cd BioClients
$ python3 setup.py install
```
## Dependencies
* Python 3.7+
* Python packages: `pandas`, `requests`, `urllib`, `json`, `xml`, `yaml`, `psycopg2`, `tqdm`, etc.
## Modules
[__Allen__](doc/allen.md) • [__AMP-T2D__](doc/amp__t2d.md) • [__BindingDb__](doc/bindingdb.md) • [__BioGrid__](doc/biogrid.md) • [__Bioregistry__](doc/bioregistry.md) • [__BRENDA__](doc/brenda.md) • [__CAS__](doc/cas.md) • [__CDC__](doc/cdc.md) • [__CFDE__](doc/cfde.md) • [__Chem2Bio2RDF__](doc/chem2bio2rdf.md) • [__ChEBI__](doc/chebi.md) • [__ChEMBL__](doc/chembl.md) • [__ChemIdPlus__](doc/chemidplus.md) • [__ClinicalTrials.gov__](doc/clinicaltrials.md) • [__Disease Ontology__](doc/diseaseontology.md) • [__DisGeNet__](doc/disgenet.md) • [__DNorm__](doc/dnorm.md) • [__DrugCentral__](doc/drugcentral.md) • [__EMBL-EBI__](doc/emblebi.md) • [__EnsEMBL__](doc/ensembl.md) • [__FDA__](doc/fda.md) • [__Gene Ontology__](doc/geneontology.md) • [__GTEx__](doc/gtex.md) • [__GWAS Catalog__](doc/gwascatalog.md) • [__HUGO__](doc/hugo.md) • [__HumanBase__](doc/humanbase.md) • [__iCite__](doc/icite.md) • [__IDG__](doc/idg.md) • [__JensenLab__](doc/jensenlab.md) • [__LINCS__](doc/lincs.md) • [__MaayanLab__](doc/maayanlab.md) • [__Medline__](doc/medline.md) • [__MeSH__](doc/mesh.md) • [__MONARCH__](doc/monarch.md) • [__MyGene__](doc/mygene.md) • [__NCBO__](doc/ncbo.md) • [__NCATS__](doc/ncats.md) • [__OMIM__](doc/omim.md) • [__Open Targets__](doc/opentargets.md) • [__Panther__](doc/panther.md) • [__PDB__](doc/pdb.md) • [__PubChem__](doc/pubchem.md) • [__PubMed__](doc/pubmed.md) • [__PubTator__](doc/pubtator.md) • [__Reactome__](doc/reactome.md) • [__RXNorm__](doc/rxnorm.md) • [__STRINGDB__](doc/stringdb.md) • [__TCGA__](doc/tcga.md) • [__UMLS__](doc/umls.md) • [__UniProt__](doc/uniprot.md) • [__Wikidata__](doc/wikidata.md) • [__WikiPathways__](doc/wikipathways.md)
Miscellaneous utilities: [__UTIL__](doc/util.md)
## Usage Example
```
$ python3 -m BioClients.pubchem.Client -h
```
## Design pattern
Generally each module includes command-line app `Client.py` which calls
functions in a corresponding `Utils.py`, providing all capabilities
by import of the module. Command-line apps not API clients are generally
named `App.py`. Functions can write to an output file
or return a Pandas dataframe (if output file unspecified).
## Data structures and formats, XML, JSON, and TSV
BioClients is designed to be simple and practical, and XML, JSON
and TSV are likewise simple in many respects, yet a great deal
of conceptual and technological progress is reflected. XML and JSON
can represent arbitrarily complex data objects, comprised of nested lists,
dictionaries, and trees of primary types. TSV represents tables of
rows and columns, related by common keys, reflecting the development
of SQL and relational databases. Transforming JSON to TSV, as these
clients generally do, projects data objects to tables useful for many
applications (e.g. machine learning).
%package help
Summary: Development documents and examples for BioClients
Provides: python3-BioClients-doc
%description help
# `BioClients`
Python package for access to online biomedical resources,
usually via REST APIs. Modules generally include
`Client.py` for command-line use and `Utils.py` for
integration into other code. With the advent of HTTP web services,
first SOAP/XML and then mostly REST/JSON, many online APIs
require very similar methods for data search, requests
and transforms into usable formats, often TSV.
## Availability and installation
Source at ;
releases available via `pypi.org`:
(`pip3 install BioClients`).
However, current development snapshot recommended.
___(First download or clone.)___
```
$ cd BioClients
$ python3 setup.py install
```
## Dependencies
* Python 3.7+
* Python packages: `pandas`, `requests`, `urllib`, `json`, `xml`, `yaml`, `psycopg2`, `tqdm`, etc.
## Modules
[__Allen__](doc/allen.md) • [__AMP-T2D__](doc/amp__t2d.md) • [__BindingDb__](doc/bindingdb.md) • [__BioGrid__](doc/biogrid.md) • [__Bioregistry__](doc/bioregistry.md) • [__BRENDA__](doc/brenda.md) • [__CAS__](doc/cas.md) • [__CDC__](doc/cdc.md) • [__CFDE__](doc/cfde.md) • [__Chem2Bio2RDF__](doc/chem2bio2rdf.md) • [__ChEBI__](doc/chebi.md) • [__ChEMBL__](doc/chembl.md) • [__ChemIdPlus__](doc/chemidplus.md) • [__ClinicalTrials.gov__](doc/clinicaltrials.md) • [__Disease Ontology__](doc/diseaseontology.md) • [__DisGeNet__](doc/disgenet.md) • [__DNorm__](doc/dnorm.md) • [__DrugCentral__](doc/drugcentral.md) • [__EMBL-EBI__](doc/emblebi.md) • [__EnsEMBL__](doc/ensembl.md) • [__FDA__](doc/fda.md) • [__Gene Ontology__](doc/geneontology.md) • [__GTEx__](doc/gtex.md) • [__GWAS Catalog__](doc/gwascatalog.md) • [__HUGO__](doc/hugo.md) • [__HumanBase__](doc/humanbase.md) • [__iCite__](doc/icite.md) • [__IDG__](doc/idg.md) • [__JensenLab__](doc/jensenlab.md) • [__LINCS__](doc/lincs.md) • [__MaayanLab__](doc/maayanlab.md) • [__Medline__](doc/medline.md) • [__MeSH__](doc/mesh.md) • [__MONARCH__](doc/monarch.md) • [__MyGene__](doc/mygene.md) • [__NCBO__](doc/ncbo.md) • [__NCATS__](doc/ncats.md) • [__OMIM__](doc/omim.md) • [__Open Targets__](doc/opentargets.md) • [__Panther__](doc/panther.md) • [__PDB__](doc/pdb.md) • [__PubChem__](doc/pubchem.md) • [__PubMed__](doc/pubmed.md) • [__PubTator__](doc/pubtator.md) • [__Reactome__](doc/reactome.md) • [__RXNorm__](doc/rxnorm.md) • [__STRINGDB__](doc/stringdb.md) • [__TCGA__](doc/tcga.md) • [__UMLS__](doc/umls.md) • [__UniProt__](doc/uniprot.md) • [__Wikidata__](doc/wikidata.md) • [__WikiPathways__](doc/wikipathways.md)
Miscellaneous utilities: [__UTIL__](doc/util.md)
## Usage Example
```
$ python3 -m BioClients.pubchem.Client -h
```
## Design pattern
Generally each module includes command-line app `Client.py` which calls
functions in a corresponding `Utils.py`, providing all capabilities
by import of the module. Command-line apps not API clients are generally
named `App.py`. Functions can write to an output file
or return a Pandas dataframe (if output file unspecified).
## Data structures and formats, XML, JSON, and TSV
BioClients is designed to be simple and practical, and XML, JSON
and TSV are likewise simple in many respects, yet a great deal
of conceptual and technological progress is reflected. XML and JSON
can represent arbitrarily complex data objects, comprised of nested lists,
dictionaries, and trees of primary types. TSV represents tables of
rows and columns, related by common keys, reflecting the development
of SQL and relational databases. Transforming JSON to TSV, as these
clients generally do, projects data objects to tables useful for many
applications (e.g. machine learning).
%prep
%autosetup -n BioClients-0.2.11
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-BioClients -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 0.2.11-1
- Package Spec generated