%global _empty_manifest_terminate_build 0
Name:		python-ultra-rest-client
Version:	2.1.1
Release:	1
Summary:	A sample Python client for communicating with the UltraDNS REST API
License:	Apache Software License
URL:		https://github.com/ultradns/python_rest_api_client
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/2a/42/66ee8fc2f4bc6e611efcbd636c1b96daf3432f081fcb9496d18501c358a8/ultra_rest_client-2.1.1.tar.gz
BuildArch:	noarch

Requires:	python3-requests

%description
A sample Python client for communicating with the UltraDNS REST API

%package -n python3-ultra-rest-client
Summary:	A sample Python client for communicating with the UltraDNS REST API
Provides:	python-ultra-rest-client
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-ultra-rest-client
A sample Python client for communicating with the UltraDNS REST API

%package help
Summary:	Development documents and examples for ultra-rest-client
Provides:	python3-ultra-rest-client-doc
%description help
A sample Python client for communicating with the UltraDNS REST API

%prep
%autosetup -n ultra-rest-client-2.1.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-ultra-rest-client -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 2.1.1-1
- Package Spec generated