%global _empty_manifest_terminate_build 0
Name: python-YesssSMS
Version: 0.8.1
Release: 1
Summary: YesssSMS let's you send SMS via yesss.at's website.
License: MIT
URL: https://gitlab.com/flowolf/yessssms
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/56/29/2721692810fbd113118787d2af9f737bf9e50c2f74caa0490fdd24956d9f/YesssSMS-0.8.1.tar.gz
BuildArch: noarch
Requires: python3-requests
Requires: python3-beautifulsoup4
%description
# YesssSMS
[![Package status](https://img.shields.io/badge/status-broken-red)](https://gitlab.com/flowolf/yessssms/#status) [![Python version](https://img.shields.io/pypi/pyversions/yessssms.svg)](https://gitlab.com/flowolf/yessssms) [![Gitlab CI Badge](https://gitlab.com/flowolf/yessssms/badges/master/pipeline.svg)](https://gitlab.com/flowolf/yessssms/pipelines) [![coverage report](https://gitlab.com/flowolf/yessssms/badges/master/coverage.svg)](https://gitlab.com/flowolf/yessssms/commits/master) [![pypi version](https://img.shields.io/pypi/v/yessssms.svg?color=blue)](https://pypi.org/project/yessssms) [![dev version](https://img.shields.io/badge/dynamic/json?color=yellow&label=dev&query=version&url=https%3A%2F%2Fgitlab.com%2Fflowolf%2Fyessssms%2Fraw%2Fmaster%2FYesssSMS%2Fversion.json&prefix=v)](https://gitlab.com/flowolf/yessssms) [![license](https://img.shields.io/pypi/l/yessssms.svg)](https://gitlab.com/flowolf/yessssms/blob/master/LICENSE.txt) [![documentation](https://img.shields.io/badge/sphinx-docs-blue)](https://flowolf.gitlab.io/yessssms/) [![downloads](https://img.shields.io/pypi/dm/yessssms)](https://pypi.org/project/yessssms)
## Status
It appears that Yesss has pulled the web SMS feature from their customer page in February 2023. This unfortunately breaks YesssSMS. Other MVNOs are probably also broken.
## YesssSMS
YesssSMS let's you send SMS via yesss.at's website. Regular rates apply and a
contract or prepaid plan is needed.
Alternatively you can use MVNOs (Mobile Virtual Network Operators) that use the kontomanager.at web interface.
These include:
- YESSS
- billitel
- EDUCOM
- fenercell
- georg
- goood
- kronemobile
- kuriermobil
- SIMfonie
- teleplanet
- WOWWW
- yooopi
Use your website login and password.
use the `--mvno` flag to set your provider, or define it in the config file.
This module is not suitable for batch SMS sending.
Each send() call logs in and out of your provider's website.
Currently the library supports Python 3.8+, and is [tested against Python 3.8 to 3.11](https://gitlab.com/flowolf/yessssms/-/jobs).
### Install
```bash
> pip3 install YesssSMS
```
### Usage
```python
>>> from YesssSMS import YesssSMS
>>> sms = YesssSMS(YOUR_LOGIN, YOUR_PASSWORD)
>>> sms.send(TO_NUMBER, "Message")
>>> # or with a different MVNO:
>>> sms = YesssSMS(YOUR_LOGIN, YOUR_PASSWORD, provider="goood")
>>> sms.send(TO_NUMBER, "Message")
```
```python
# login environment variables set
>>> from YesssSMS import YesssSMS
>>> sms = YesssSMS()
>>> sms.send("06641234567", "hello future self, your pipeline failed :(")
```
```python
# sending multiple SMS
from YesssSMS import YesssSMS
import requests
sms = YesssSMS()
with sms._login(requests.Session()) as sess:
sms._send(session=sess, recipient="06641234567", message="hi! I have a new number +43650-555-1234")
sms._send(session=sess, recipient="06509876543", message="Meine neue Handynummer: +43650-555-1234")
sms._send(session=sess, recipient="06760001256", message="I changed my number to +43650-555-1234")
sms._logout()
```
### Command Line Usage
```bash
> yessssms --print-config-file > ~/.config/yessssms.conf
# edit the config file, set a login, password, default recipient, and MVNO
> vi ~/.config/yessssms.conf
> yessssms --test # test your setup, send yourself a message
> yessssms -t 0664123123123 -m "sending SMS from the command line :)"
> # if a default recipient is defined, you can omit the -t flag
> # the message can be piped into yessssms (it will be cut to max 3 SMS, 3*160 chars)
> echo "important message!" | yessssms -m -
> # MVNO
> yessssms --to 06501234567 --mvno educom -m "sending SMS using a MVNO"
```
```bash
# set environment variables to avoid parameters or config files;
# great for pipelines
> export YESSSSMS_LOGIN=06641234567
> export YESSSSMS_PASSWD=myverysecretsecret
> export YESSSSMS_PROVIDER=wowww
> export YESSSSMS_RECIPIENT=06641234567
# use in python script or in command line
> yessssms -T
ok: login data is valid.
> yessssms -m "sending SMS from github and gitlab pipelines... so much cloud"
```
%package -n python3-YesssSMS
Summary: YesssSMS let's you send SMS via yesss.at's website.
Provides: python-YesssSMS
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-YesssSMS
# YesssSMS
[![Package status](https://img.shields.io/badge/status-broken-red)](https://gitlab.com/flowolf/yessssms/#status) [![Python version](https://img.shields.io/pypi/pyversions/yessssms.svg)](https://gitlab.com/flowolf/yessssms) [![Gitlab CI Badge](https://gitlab.com/flowolf/yessssms/badges/master/pipeline.svg)](https://gitlab.com/flowolf/yessssms/pipelines) [![coverage report](https://gitlab.com/flowolf/yessssms/badges/master/coverage.svg)](https://gitlab.com/flowolf/yessssms/commits/master) [![pypi version](https://img.shields.io/pypi/v/yessssms.svg?color=blue)](https://pypi.org/project/yessssms) [![dev version](https://img.shields.io/badge/dynamic/json?color=yellow&label=dev&query=version&url=https%3A%2F%2Fgitlab.com%2Fflowolf%2Fyessssms%2Fraw%2Fmaster%2FYesssSMS%2Fversion.json&prefix=v)](https://gitlab.com/flowolf/yessssms) [![license](https://img.shields.io/pypi/l/yessssms.svg)](https://gitlab.com/flowolf/yessssms/blob/master/LICENSE.txt) [![documentation](https://img.shields.io/badge/sphinx-docs-blue)](https://flowolf.gitlab.io/yessssms/) [![downloads](https://img.shields.io/pypi/dm/yessssms)](https://pypi.org/project/yessssms)
## Status
It appears that Yesss has pulled the web SMS feature from their customer page in February 2023. This unfortunately breaks YesssSMS. Other MVNOs are probably also broken.
## YesssSMS
YesssSMS let's you send SMS via yesss.at's website. Regular rates apply and a
contract or prepaid plan is needed.
Alternatively you can use MVNOs (Mobile Virtual Network Operators) that use the kontomanager.at web interface.
These include:
- YESSS
- billitel
- EDUCOM
- fenercell
- georg
- goood
- kronemobile
- kuriermobil
- SIMfonie
- teleplanet
- WOWWW
- yooopi
Use your website login and password.
use the `--mvno` flag to set your provider, or define it in the config file.
This module is not suitable for batch SMS sending.
Each send() call logs in and out of your provider's website.
Currently the library supports Python 3.8+, and is [tested against Python 3.8 to 3.11](https://gitlab.com/flowolf/yessssms/-/jobs).
### Install
```bash
> pip3 install YesssSMS
```
### Usage
```python
>>> from YesssSMS import YesssSMS
>>> sms = YesssSMS(YOUR_LOGIN, YOUR_PASSWORD)
>>> sms.send(TO_NUMBER, "Message")
>>> # or with a different MVNO:
>>> sms = YesssSMS(YOUR_LOGIN, YOUR_PASSWORD, provider="goood")
>>> sms.send(TO_NUMBER, "Message")
```
```python
# login environment variables set
>>> from YesssSMS import YesssSMS
>>> sms = YesssSMS()
>>> sms.send("06641234567", "hello future self, your pipeline failed :(")
```
```python
# sending multiple SMS
from YesssSMS import YesssSMS
import requests
sms = YesssSMS()
with sms._login(requests.Session()) as sess:
sms._send(session=sess, recipient="06641234567", message="hi! I have a new number +43650-555-1234")
sms._send(session=sess, recipient="06509876543", message="Meine neue Handynummer: +43650-555-1234")
sms._send(session=sess, recipient="06760001256", message="I changed my number to +43650-555-1234")
sms._logout()
```
### Command Line Usage
```bash
> yessssms --print-config-file > ~/.config/yessssms.conf
# edit the config file, set a login, password, default recipient, and MVNO
> vi ~/.config/yessssms.conf
> yessssms --test # test your setup, send yourself a message
> yessssms -t 0664123123123 -m "sending SMS from the command line :)"
> # if a default recipient is defined, you can omit the -t flag
> # the message can be piped into yessssms (it will be cut to max 3 SMS, 3*160 chars)
> echo "important message!" | yessssms -m -
> # MVNO
> yessssms --to 06501234567 --mvno educom -m "sending SMS using a MVNO"
```
```bash
# set environment variables to avoid parameters or config files;
# great for pipelines
> export YESSSSMS_LOGIN=06641234567
> export YESSSSMS_PASSWD=myverysecretsecret
> export YESSSSMS_PROVIDER=wowww
> export YESSSSMS_RECIPIENT=06641234567
# use in python script or in command line
> yessssms -T
ok: login data is valid.
> yessssms -m "sending SMS from github and gitlab pipelines... so much cloud"
```
%package help
Summary: Development documents and examples for YesssSMS
Provides: python3-YesssSMS-doc
%description help
# YesssSMS
[![Package status](https://img.shields.io/badge/status-broken-red)](https://gitlab.com/flowolf/yessssms/#status) [![Python version](https://img.shields.io/pypi/pyversions/yessssms.svg)](https://gitlab.com/flowolf/yessssms) [![Gitlab CI Badge](https://gitlab.com/flowolf/yessssms/badges/master/pipeline.svg)](https://gitlab.com/flowolf/yessssms/pipelines) [![coverage report](https://gitlab.com/flowolf/yessssms/badges/master/coverage.svg)](https://gitlab.com/flowolf/yessssms/commits/master) [![pypi version](https://img.shields.io/pypi/v/yessssms.svg?color=blue)](https://pypi.org/project/yessssms) [![dev version](https://img.shields.io/badge/dynamic/json?color=yellow&label=dev&query=version&url=https%3A%2F%2Fgitlab.com%2Fflowolf%2Fyessssms%2Fraw%2Fmaster%2FYesssSMS%2Fversion.json&prefix=v)](https://gitlab.com/flowolf/yessssms) [![license](https://img.shields.io/pypi/l/yessssms.svg)](https://gitlab.com/flowolf/yessssms/blob/master/LICENSE.txt) [![documentation](https://img.shields.io/badge/sphinx-docs-blue)](https://flowolf.gitlab.io/yessssms/) [![downloads](https://img.shields.io/pypi/dm/yessssms)](https://pypi.org/project/yessssms)
## Status
It appears that Yesss has pulled the web SMS feature from their customer page in February 2023. This unfortunately breaks YesssSMS. Other MVNOs are probably also broken.
## YesssSMS
YesssSMS let's you send SMS via yesss.at's website. Regular rates apply and a
contract or prepaid plan is needed.
Alternatively you can use MVNOs (Mobile Virtual Network Operators) that use the kontomanager.at web interface.
These include:
- YESSS
- billitel
- EDUCOM
- fenercell
- georg
- goood
- kronemobile
- kuriermobil
- SIMfonie
- teleplanet
- WOWWW
- yooopi
Use your website login and password.
use the `--mvno` flag to set your provider, or define it in the config file.
This module is not suitable for batch SMS sending.
Each send() call logs in and out of your provider's website.
Currently the library supports Python 3.8+, and is [tested against Python 3.8 to 3.11](https://gitlab.com/flowolf/yessssms/-/jobs).
### Install
```bash
> pip3 install YesssSMS
```
### Usage
```python
>>> from YesssSMS import YesssSMS
>>> sms = YesssSMS(YOUR_LOGIN, YOUR_PASSWORD)
>>> sms.send(TO_NUMBER, "Message")
>>> # or with a different MVNO:
>>> sms = YesssSMS(YOUR_LOGIN, YOUR_PASSWORD, provider="goood")
>>> sms.send(TO_NUMBER, "Message")
```
```python
# login environment variables set
>>> from YesssSMS import YesssSMS
>>> sms = YesssSMS()
>>> sms.send("06641234567", "hello future self, your pipeline failed :(")
```
```python
# sending multiple SMS
from YesssSMS import YesssSMS
import requests
sms = YesssSMS()
with sms._login(requests.Session()) as sess:
sms._send(session=sess, recipient="06641234567", message="hi! I have a new number +43650-555-1234")
sms._send(session=sess, recipient="06509876543", message="Meine neue Handynummer: +43650-555-1234")
sms._send(session=sess, recipient="06760001256", message="I changed my number to +43650-555-1234")
sms._logout()
```
### Command Line Usage
```bash
> yessssms --print-config-file > ~/.config/yessssms.conf
# edit the config file, set a login, password, default recipient, and MVNO
> vi ~/.config/yessssms.conf
> yessssms --test # test your setup, send yourself a message
> yessssms -t 0664123123123 -m "sending SMS from the command line :)"
> # if a default recipient is defined, you can omit the -t flag
> # the message can be piped into yessssms (it will be cut to max 3 SMS, 3*160 chars)
> echo "important message!" | yessssms -m -
> # MVNO
> yessssms --to 06501234567 --mvno educom -m "sending SMS using a MVNO"
```
```bash
# set environment variables to avoid parameters or config files;
# great for pipelines
> export YESSSSMS_LOGIN=06641234567
> export YESSSSMS_PASSWD=myverysecretsecret
> export YESSSSMS_PROVIDER=wowww
> export YESSSSMS_RECIPIENT=06641234567
# use in python script or in command line
> yessssms -T
ok: login data is valid.
> yessssms -m "sending SMS from github and gitlab pipelines... so much cloud"
```
%prep
%autosetup -n YesssSMS-0.8.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-YesssSMS -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 0.8.1-1
- Package Spec generated