%global _empty_manifest_terminate_build 0
Name: python-log3
Version: 0.1.7
Release: 1
Summary: High level logging client builtin support for colored terminal output
License: MIT License
URL: https://github.com/orlandodiaz/log3
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/4e/1e/5c29e2a929598f48c940101ebde70bdef0eea726594719d89939ebab7e26/log3-0.1.7.tar.gz
BuildArch: noarch
Requires: python3-colorama
%description
# Log3
[![image](https://img.shields.io/pypi/v/log3.svg)](https://pypi.org/project/log3/)
[![image](https://img.shields.io/pypi/pyversions/log3.svg)](https://pypi.org/project/log3/)
[![codecov](https://codecov.io/gh/orlandodiaz/log3/branch/master/graph/badge.svg)](https://codecov.io/gh/orlandodiaz/log3)
[![Build Status](https://travis-ci.com/orlandodiaz/log3.svg?branch=master)](https://travis-ci.com/orlandodiaz/log3)
![GitHub](https://img.shields.io/github/license/mashape/apistatus.svg)
`Log3` makes it easier to log messages in Python. It comes with a strong default
logging configuration system so you don't configure them yourself.
Here are it's main highlights:
- **Easy to use**. Just import the module and start using it. This will work for most cases. Unless your logging settings are very specialized
you won't have to tinker much with the configuration.
- **Strong defaults**. The default formatter and date formatter will work for just about anyone. It includes the date, time, filename, level, and message. If you need to use a different formatter you can
also do so just as easily.
- **New logging methods**. In addition to `log.info`, `log.debug`, etc `log3` also comes with `log.success` to log out successful messages
- **Colored output for terminals**. If you're working with the terminal the messages will be colored by default without any additional configuration
- **Easier file logging**. No need to create a file handler with new date formatting, and formatting and attach to the logger. The same configuration for `STDERR`
also applies to the log. Just import `log_to_file` and specify the path of the log as the argument.
## Installation
You can install `Log3` using pip:
pip install log3
## Usage
To start logging it is as simple as importing the `log` logger object and issuing the logging
commands:
```python
from log3 import log
log.info("Hello world")
log.success("This message was successful")
log.debug("This is a debug message")
log.warning("This is a warning")
log.error("This is an error")
log.critical("This is a critical error")
```
#### Log to file
The `log_to_file` function will allow you to add a file handler to yor logging configuration.
First import it
from log3 import log_to_file
Now you can do:
log_to_file('file')
log.info('logged to file')
#### Disable logging
You can quickly disable logging rather than hardcoding it into your logging
configuration file.
log.disable_logging()
To enable logging again it is also that simple:
log.enable_logging()
## Author(s)
- orlandodiaz
## Copyright
Copyright (c) 2018 Orlando Diaz
For more info see LICENSE
%package -n python3-log3
Summary: High level logging client builtin support for colored terminal output
Provides: python-log3
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-log3
# Log3
[![image](https://img.shields.io/pypi/v/log3.svg)](https://pypi.org/project/log3/)
[![image](https://img.shields.io/pypi/pyversions/log3.svg)](https://pypi.org/project/log3/)
[![codecov](https://codecov.io/gh/orlandodiaz/log3/branch/master/graph/badge.svg)](https://codecov.io/gh/orlandodiaz/log3)
[![Build Status](https://travis-ci.com/orlandodiaz/log3.svg?branch=master)](https://travis-ci.com/orlandodiaz/log3)
![GitHub](https://img.shields.io/github/license/mashape/apistatus.svg)
`Log3` makes it easier to log messages in Python. It comes with a strong default
logging configuration system so you don't configure them yourself.
Here are it's main highlights:
- **Easy to use**. Just import the module and start using it. This will work for most cases. Unless your logging settings are very specialized
you won't have to tinker much with the configuration.
- **Strong defaults**. The default formatter and date formatter will work for just about anyone. It includes the date, time, filename, level, and message. If you need to use a different formatter you can
also do so just as easily.
- **New logging methods**. In addition to `log.info`, `log.debug`, etc `log3` also comes with `log.success` to log out successful messages
- **Colored output for terminals**. If you're working with the terminal the messages will be colored by default without any additional configuration
- **Easier file logging**. No need to create a file handler with new date formatting, and formatting and attach to the logger. The same configuration for `STDERR`
also applies to the log. Just import `log_to_file` and specify the path of the log as the argument.
## Installation
You can install `Log3` using pip:
pip install log3
## Usage
To start logging it is as simple as importing the `log` logger object and issuing the logging
commands:
```python
from log3 import log
log.info("Hello world")
log.success("This message was successful")
log.debug("This is a debug message")
log.warning("This is a warning")
log.error("This is an error")
log.critical("This is a critical error")
```
#### Log to file
The `log_to_file` function will allow you to add a file handler to yor logging configuration.
First import it
from log3 import log_to_file
Now you can do:
log_to_file('file')
log.info('logged to file')
#### Disable logging
You can quickly disable logging rather than hardcoding it into your logging
configuration file.
log.disable_logging()
To enable logging again it is also that simple:
log.enable_logging()
## Author(s)
- orlandodiaz
## Copyright
Copyright (c) 2018 Orlando Diaz
For more info see LICENSE
%package help
Summary: Development documents and examples for log3
Provides: python3-log3-doc
%description help
# Log3
[![image](https://img.shields.io/pypi/v/log3.svg)](https://pypi.org/project/log3/)
[![image](https://img.shields.io/pypi/pyversions/log3.svg)](https://pypi.org/project/log3/)
[![codecov](https://codecov.io/gh/orlandodiaz/log3/branch/master/graph/badge.svg)](https://codecov.io/gh/orlandodiaz/log3)
[![Build Status](https://travis-ci.com/orlandodiaz/log3.svg?branch=master)](https://travis-ci.com/orlandodiaz/log3)
![GitHub](https://img.shields.io/github/license/mashape/apistatus.svg)
`Log3` makes it easier to log messages in Python. It comes with a strong default
logging configuration system so you don't configure them yourself.
Here are it's main highlights:
- **Easy to use**. Just import the module and start using it. This will work for most cases. Unless your logging settings are very specialized
you won't have to tinker much with the configuration.
- **Strong defaults**. The default formatter and date formatter will work for just about anyone. It includes the date, time, filename, level, and message. If you need to use a different formatter you can
also do so just as easily.
- **New logging methods**. In addition to `log.info`, `log.debug`, etc `log3` also comes with `log.success` to log out successful messages
- **Colored output for terminals**. If you're working with the terminal the messages will be colored by default without any additional configuration
- **Easier file logging**. No need to create a file handler with new date formatting, and formatting and attach to the logger. The same configuration for `STDERR`
also applies to the log. Just import `log_to_file` and specify the path of the log as the argument.
## Installation
You can install `Log3` using pip:
pip install log3
## Usage
To start logging it is as simple as importing the `log` logger object and issuing the logging
commands:
```python
from log3 import log
log.info("Hello world")
log.success("This message was successful")
log.debug("This is a debug message")
log.warning("This is a warning")
log.error("This is an error")
log.critical("This is a critical error")
```
#### Log to file
The `log_to_file` function will allow you to add a file handler to yor logging configuration.
First import it
from log3 import log_to_file
Now you can do:
log_to_file('file')
log.info('logged to file')
#### Disable logging
You can quickly disable logging rather than hardcoding it into your logging
configuration file.
log.disable_logging()
To enable logging again it is also that simple:
log.enable_logging()
## Author(s)
- orlandodiaz
## Copyright
Copyright (c) 2018 Orlando Diaz
For more info see LICENSE
%prep
%autosetup -n log3-0.1.7
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-log3 -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 0.1.7-1
- Package Spec generated