%global _empty_manifest_terminate_build 0
Name: python-colour-demosaicing
Version: 0.2.3
Release: 1
Summary: CFA (Colour Filter Array) Demosaicing Algorithms for Python
License: BSD-3-Clause
URL: https://www.colour-science.org/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/82/94/747f803f1bfbf04b801f61549b7a044051db24c78a2b8fe4225c01422c9f/colour_demosaicing-0.2.3.tar.gz
BuildArch: noarch
Requires: python3-biblib-simple
Requires: python3-black
Requires: python3-blackdoc
Requires: python3-colour-science
Requires: python3-coverage
Requires: python3-coveralls
Requires: python3-flake8
Requires: python3-flynt
Requires: python3-imageio
Requires: python3-invoke
Requires: python3-jupyter
Requires: python3-matplotlib
Requires: python3-mypy
Requires: python3-numpy
Requires: python3-pre-commit
Requires: python3-pydata-sphinx-theme
Requires: python3-pydocstyle
Requires: python3-pytest-cov
Requires: python3-pytest-xdist
Requires: python3-pytest
Requires: python3-pyupgrade
Requires: python3-restructuredtext-lint
Requires: python3-scipy
Requires: python3-sphinx
Requires: python3-sphinxcontrib-bibtex
Requires: python3-toml
Requires: python3-twine
Requires: python3-typing-extensions
%description
|actions| |coveralls| |codacy| |version|
A `Python `__ package implementing various
CFA (Colour Filter Array) demosaicing algorithms and related utilities.
It is open source and freely available under the
`New BSD License `__ terms.
%package -n python3-colour-demosaicing
Summary: CFA (Colour Filter Array) Demosaicing Algorithms for Python
Provides: python-colour-demosaicing
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-colour-demosaicing
|actions| |coveralls| |codacy| |version|
A `Python `__ package implementing various
CFA (Colour Filter Array) demosaicing algorithms and related utilities.
It is open source and freely available under the
`New BSD License `__ terms.
%package help
Summary: Development documents and examples for colour-demosaicing
Provides: python3-colour-demosaicing-doc
%description help
|actions| |coveralls| |codacy| |version|
A `Python `__ package implementing various
CFA (Colour Filter Array) demosaicing algorithms and related utilities.
It is open source and freely available under the
`New BSD License `__ terms.
%prep
%autosetup -n colour-demosaicing-0.2.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-colour-demosaicing -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 0.2.3-1
- Package Spec generated