%global _empty_manifest_terminate_build 0
Name: python-jet-bridge-base
Version: 1.7.17
Release: 1
Summary: please add a summary manually as the author left a blank one
License: MIT
URL: https://github.com/jet-admin/jet-bridge-base
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/eb/6b/29d6ff1ff1012048866b967d7fe89f46a08a17cf095ffb39961d9ed65d76/jet-bridge-base-1.7.17.tar.gz
BuildArch: noarch
Requires: python3-sqlalchemy
Requires: python3-six
Requires: python3-requests
Requires: python3-Pillow
Requires: python3-dateparser
Requires: python3-social-auth-core
Requires: python3-prompt-toolkit
Requires: python3-graphene
%description
* About Jet Admin: https://www.jetadmin.io
* **Live Demo**: https://app.jetadmin.io/demo
* Documentation: https://docs.jetadmin.io/
* Support: support@jetadmin.io
**Jet Admin** is a SaaS service that automatically generates extendable back office for your application.
**Jet Bridge** is a standalone app which generates REST API thought which your SQL database is connected to **Jet Admin**.
This project has been designed to fit requirements of small startups and mature companies.
- **Data Privacy**. Jet does not access your data: its transferred directly from browser to your application.
- **Customizable Interface**. With WYSIWYG interface customization your can change almost every part of interface.
- **Extendable**. Flex Features allows you to create your custom Actions, Views, Fields and other.
- **Works with any technology**. The interface is generated automatically based on an analysis of the data and data structure of your database.
- **Quick installation**. All you need is to install Jet Bridge and connect it to your database.
This is a complete remake of our popular [Django Jet](https://github.com/geex-arts/django-jet) admin interface.
%package -n python3-jet-bridge-base
Summary: please add a summary manually as the author left a blank one
Provides: python-jet-bridge-base
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-jet-bridge-base
* About Jet Admin: https://www.jetadmin.io
* **Live Demo**: https://app.jetadmin.io/demo
* Documentation: https://docs.jetadmin.io/
* Support: support@jetadmin.io
**Jet Admin** is a SaaS service that automatically generates extendable back office for your application.
**Jet Bridge** is a standalone app which generates REST API thought which your SQL database is connected to **Jet Admin**.
This project has been designed to fit requirements of small startups and mature companies.
- **Data Privacy**. Jet does not access your data: its transferred directly from browser to your application.
- **Customizable Interface**. With WYSIWYG interface customization your can change almost every part of interface.
- **Extendable**. Flex Features allows you to create your custom Actions, Views, Fields and other.
- **Works with any technology**. The interface is generated automatically based on an analysis of the data and data structure of your database.
- **Quick installation**. All you need is to install Jet Bridge and connect it to your database.
This is a complete remake of our popular [Django Jet](https://github.com/geex-arts/django-jet) admin interface.
%package help
Summary: Development documents and examples for jet-bridge-base
Provides: python3-jet-bridge-base-doc
%description help
* About Jet Admin: https://www.jetadmin.io
* **Live Demo**: https://app.jetadmin.io/demo
* Documentation: https://docs.jetadmin.io/
* Support: support@jetadmin.io
**Jet Admin** is a SaaS service that automatically generates extendable back office for your application.
**Jet Bridge** is a standalone app which generates REST API thought which your SQL database is connected to **Jet Admin**.
This project has been designed to fit requirements of small startups and mature companies.
- **Data Privacy**. Jet does not access your data: its transferred directly from browser to your application.
- **Customizable Interface**. With WYSIWYG interface customization your can change almost every part of interface.
- **Extendable**. Flex Features allows you to create your custom Actions, Views, Fields and other.
- **Works with any technology**. The interface is generated automatically based on an analysis of the data and data structure of your database.
- **Quick installation**. All you need is to install Jet Bridge and connect it to your database.
This is a complete remake of our popular [Django Jet](https://github.com/geex-arts/django-jet) admin interface.
%prep
%autosetup -n jet-bridge-base-1.7.17
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-jet-bridge-base -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 1.7.17-1
- Package Spec generated