%global _empty_manifest_terminate_build 0
Name: python-md-environ
Version: 0.1.0
Release: 1
Summary: This is an extension to Python-Markdown which allows environment variables to be used in the text.
License: UNKNOWN
URL: https://github.com/cmacmackin/md-environ/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/68/a9/86666edbf0d3929d5b3be3347c153881139aa1e28af38f6496edcc034003/md-environ-0.1.0.tar.gz
BuildArch: noarch
%description
This is an extension to
`Python-Markdown `__ which allows
environment variables to be inserted into the text. I originally wrote
it for my `FORD `__ Fortran
auto-documentation generator.
%package -n python3-md-environ
Summary: This is an extension to Python-Markdown which allows environment variables to be used in the text.
Provides: python-md-environ
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-md-environ
This is an extension to
`Python-Markdown `__ which allows
environment variables to be inserted into the text. I originally wrote
it for my `FORD `__ Fortran
auto-documentation generator.
%package help
Summary: Development documents and examples for md-environ
Provides: python3-md-environ-doc
%description help
This is an extension to
`Python-Markdown `__ which allows
environment variables to be inserted into the text. I originally wrote
it for my `FORD `__ Fortran
auto-documentation generator.
%prep
%autosetup -n md-environ-0.1.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-md-environ -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 0.1.0-1
- Package Spec generated