%global _empty_manifest_terminate_build 0
Name: python-ZopeSkel
Version: 2.21.2
Release: 1
Summary: Templates and code generator for quickstarting Plone / Zope projects.
License: MIT
URL: http://svn.plone.org/svn/collective/ZopeSkel/trunk
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c1/de/1976cbdfba34fc555cb2f5699dc2b2d40a3ca1641fbf191f0fc10ada7e00/ZopeSkel-2.21.2.zip
BuildArch: noarch
%description
ZopeSkel provides a collection of project templates for Plone and Zope
development projects.
ZopeSkel uses the `paster `_ Python library
internally.
%package -n python3-ZopeSkel
Summary: Templates and code generator for quickstarting Plone / Zope projects.
Provides: python-ZopeSkel
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-ZopeSkel
ZopeSkel provides a collection of project templates for Plone and Zope
development projects.
ZopeSkel uses the `paster `_ Python library
internally.
%package help
Summary: Development documents and examples for ZopeSkel
Provides: python3-ZopeSkel-doc
%description help
ZopeSkel provides a collection of project templates for Plone and Zope
development projects.
ZopeSkel uses the `paster `_ Python library
internally.
%prep
%autosetup -n ZopeSkel-2.21.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-ZopeSkel -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 2.21.2-1
- Package Spec generated