%global _empty_manifest_terminate_build 0
Name:		python-pylab-sdk
Version:	1.3.2
Release:	1
Summary:	A development kit that collects simple utilities.
License:	MIT
URL:		https://github.com/PyLabCo/pylab-sdk
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/e4/50/bb1d72e38676472805ea7b44bbbf13ca203273e296f3a89deedb4d6b3ed4/pylab-sdk-1.3.2.tar.gz
BuildArch:	noarch


%description
# pylab-sdk
A development kit that collects simple utilities.

## Installation

```bash
pip install pylab-sdk
```

## Example
```
import pylab


# Get your public IP
ip = pylab.get_ip()

# Get latest user agent of modern browser
agents = pylab.get_latest_agents()
assert agents['macOS'] == pylab.get_latest_agents('macOS')

# Similar to netcat, webcat running over the http protocol helps you keep a log that you can check anywhere.
pylab.wc('hello world', source='discord-bot')

```




%package -n python3-pylab-sdk
Summary:	A development kit that collects simple utilities.
Provides:	python-pylab-sdk
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pylab-sdk
# pylab-sdk
A development kit that collects simple utilities.

## Installation

```bash
pip install pylab-sdk
```

## Example
```
import pylab


# Get your public IP
ip = pylab.get_ip()

# Get latest user agent of modern browser
agents = pylab.get_latest_agents()
assert agents['macOS'] == pylab.get_latest_agents('macOS')

# Similar to netcat, webcat running over the http protocol helps you keep a log that you can check anywhere.
pylab.wc('hello world', source='discord-bot')

```




%package help
Summary:	Development documents and examples for pylab-sdk
Provides:	python3-pylab-sdk-doc
%description help
# pylab-sdk
A development kit that collects simple utilities.

## Installation

```bash
pip install pylab-sdk
```

## Example
```
import pylab


# Get your public IP
ip = pylab.get_ip()

# Get latest user agent of modern browser
agents = pylab.get_latest_agents()
assert agents['macOS'] == pylab.get_latest_agents('macOS')

# Similar to netcat, webcat running over the http protocol helps you keep a log that you can check anywhere.
pylab.wc('hello world', source='discord-bot')

```




%prep
%autosetup -n pylab-sdk-1.3.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pylab-sdk -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.2-1
- Package Spec generated