%global _empty_manifest_terminate_build 0
Name: python-pysat
Version: 3.0.6
Release: 1
Summary: 'Supports science analysis across disparate data platforms'
License: BSD License
URL: https://github.com/pysat/pysat
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/3c/c8/8bb01d050632832fb9477056da59ff6d25b3fcce67d77c1260ff56eaebd3/pysat-3.0.6.tar.gz
BuildArch: noarch
%description
# pysat: Python Satellite Data Analysis Toolkit
[![PyPI Package latest release](https://img.shields.io/pypi/v/pysat.svg)](https://pypi.python.org/pypi/pysat)
[![Build Status](https://github.com/pysat/pysat/actions/workflows/main.yml/badge.svg)](https://github.com/pysat/pysat/actions/workflows/main.yml/badge.svg)
[![Documentation Status](https://readthedocs.org/projects/pysat/badge/?version=latest)](http://pysat.readthedocs.io/en/latest/?badge=latest)
[![Coverage Status](https://coveralls.io/repos/github/pysat/pysat/badge.svg?branch=main)](https://coveralls.io/github/pysat/pysat?branch=main)
[![DOI](https://zenodo.org/badge/33449914.svg)](https://zenodo.org/badge/latestdoi/33449914)
The Python Satellite Data Analysis Toolkit (pysat) is a package providing a
simple and flexible interface for downloading, loading, cleaning, managing,
processing, and analyzing scientific measurements. Although pysat was initially
designed for in situ satellite observations, it now supports many different
types of ground- and space-based measurements.
Full [Documentation](http://pysat.readthedocs.io/en/latest/index.html)
JGR-Space Physics [Publication](https://doi.org/10.1029/2018JA025297)
[Citation Info](https://pysat.readthedocs.io/en/latest/citing.html)
Come join us on Slack! An invitation to the pysat workspace is available
in the 'About' section of the [pysat GitHub Repository.](https://github.com/pysat/pysat)
Development meetings are generally held fortnightly.
# Main Features
* Instrument independent analysis routines.
* Instrument object providing an interface for downloading and analyzing a wide
variety of science data sets.
* Uses pandas or xarray for the underlying data structure;
capable of handling the many forms scientific measurements take in a
consistent manner.
* Standard scientific data handling tasks (e.g., identifying, downloading,
and loading files and cleaning and modifying data) are built into the
Instrument object.
* Supports metadata consistent with the netCDF CF-1.6 standard. Each variable
has a name, long name, and units. Note units are informational only.
* Simplifies data management
* Iterator support for loading data by day/file/orbit, independent of data
storage details.
* Orbits are calculated on the fly from loaded data and span day breaks.
* Iterate over custom seasons
* Supports rigorous time-series calculations that require spin up/down time
across day, orbit, and file breaks.
* Includes helper functions to reduce the barrier in adding new science
instruments to pysat
# Installation
## Starting from scratch
* Python and associated packages for science are freely available. Convenient
science python package setups are available from https://www.python.org/,
[Anaconda](https://www.anaconda.com/distribution/), and other locations
(some platform specific). Anaconda also includes a developer environment that
works well with pysat. Core science packages such as numpy, scipy, matplotlib,
pandas and many others may also be installed directly via pip or your
favorite package manager.
* Installation through pip
```
pip install pysat
```
* Installation through github
```
git clone https://github.com/pysat/pysat.git
cd pysat
python setup.py install
```
An advantage to installing through github is access to the development branches.
The latest bugfixes can be found in the `develop` branch. However, this branch
is not stable (as the name implies). We recommend using this branch in a
virtual environment or using `python setup.py develop`.
```
git clone https://github.com/pysat/pysat.git
cd pysat
git checkout develop
python setup.py develop
```
* Note that pysat requires a number of packages for the install.
* dask
* netCDF4
* numpy
* pandas
* portalocker
* scipy
* toolz
* xarray
* The first time the package is run, you will need to specify a directory to
store data. In python, run:
```
pysat.params['data_dirs'] = 'path/to/directory/that/may/or/may/not/exist'
```
* Nominal organization of data is top_dir/platform/name/tag/inst_id/files
%package -n python3-pysat
Summary: 'Supports science analysis across disparate data platforms'
Provides: python-pysat
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pysat
# pysat: Python Satellite Data Analysis Toolkit
[![PyPI Package latest release](https://img.shields.io/pypi/v/pysat.svg)](https://pypi.python.org/pypi/pysat)
[![Build Status](https://github.com/pysat/pysat/actions/workflows/main.yml/badge.svg)](https://github.com/pysat/pysat/actions/workflows/main.yml/badge.svg)
[![Documentation Status](https://readthedocs.org/projects/pysat/badge/?version=latest)](http://pysat.readthedocs.io/en/latest/?badge=latest)
[![Coverage Status](https://coveralls.io/repos/github/pysat/pysat/badge.svg?branch=main)](https://coveralls.io/github/pysat/pysat?branch=main)
[![DOI](https://zenodo.org/badge/33449914.svg)](https://zenodo.org/badge/latestdoi/33449914)
The Python Satellite Data Analysis Toolkit (pysat) is a package providing a
simple and flexible interface for downloading, loading, cleaning, managing,
processing, and analyzing scientific measurements. Although pysat was initially
designed for in situ satellite observations, it now supports many different
types of ground- and space-based measurements.
Full [Documentation](http://pysat.readthedocs.io/en/latest/index.html)
JGR-Space Physics [Publication](https://doi.org/10.1029/2018JA025297)
[Citation Info](https://pysat.readthedocs.io/en/latest/citing.html)
Come join us on Slack! An invitation to the pysat workspace is available
in the 'About' section of the [pysat GitHub Repository.](https://github.com/pysat/pysat)
Development meetings are generally held fortnightly.
# Main Features
* Instrument independent analysis routines.
* Instrument object providing an interface for downloading and analyzing a wide
variety of science data sets.
* Uses pandas or xarray for the underlying data structure;
capable of handling the many forms scientific measurements take in a
consistent manner.
* Standard scientific data handling tasks (e.g., identifying, downloading,
and loading files and cleaning and modifying data) are built into the
Instrument object.
* Supports metadata consistent with the netCDF CF-1.6 standard. Each variable
has a name, long name, and units. Note units are informational only.
* Simplifies data management
* Iterator support for loading data by day/file/orbit, independent of data
storage details.
* Orbits are calculated on the fly from loaded data and span day breaks.
* Iterate over custom seasons
* Supports rigorous time-series calculations that require spin up/down time
across day, orbit, and file breaks.
* Includes helper functions to reduce the barrier in adding new science
instruments to pysat
# Installation
## Starting from scratch
* Python and associated packages for science are freely available. Convenient
science python package setups are available from https://www.python.org/,
[Anaconda](https://www.anaconda.com/distribution/), and other locations
(some platform specific). Anaconda also includes a developer environment that
works well with pysat. Core science packages such as numpy, scipy, matplotlib,
pandas and many others may also be installed directly via pip or your
favorite package manager.
* Installation through pip
```
pip install pysat
```
* Installation through github
```
git clone https://github.com/pysat/pysat.git
cd pysat
python setup.py install
```
An advantage to installing through github is access to the development branches.
The latest bugfixes can be found in the `develop` branch. However, this branch
is not stable (as the name implies). We recommend using this branch in a
virtual environment or using `python setup.py develop`.
```
git clone https://github.com/pysat/pysat.git
cd pysat
git checkout develop
python setup.py develop
```
* Note that pysat requires a number of packages for the install.
* dask
* netCDF4
* numpy
* pandas
* portalocker
* scipy
* toolz
* xarray
* The first time the package is run, you will need to specify a directory to
store data. In python, run:
```
pysat.params['data_dirs'] = 'path/to/directory/that/may/or/may/not/exist'
```
* Nominal organization of data is top_dir/platform/name/tag/inst_id/files
%package help
Summary: Development documents and examples for pysat
Provides: python3-pysat-doc
%description help
# pysat: Python Satellite Data Analysis Toolkit
[![PyPI Package latest release](https://img.shields.io/pypi/v/pysat.svg)](https://pypi.python.org/pypi/pysat)
[![Build Status](https://github.com/pysat/pysat/actions/workflows/main.yml/badge.svg)](https://github.com/pysat/pysat/actions/workflows/main.yml/badge.svg)
[![Documentation Status](https://readthedocs.org/projects/pysat/badge/?version=latest)](http://pysat.readthedocs.io/en/latest/?badge=latest)
[![Coverage Status](https://coveralls.io/repos/github/pysat/pysat/badge.svg?branch=main)](https://coveralls.io/github/pysat/pysat?branch=main)
[![DOI](https://zenodo.org/badge/33449914.svg)](https://zenodo.org/badge/latestdoi/33449914)
The Python Satellite Data Analysis Toolkit (pysat) is a package providing a
simple and flexible interface for downloading, loading, cleaning, managing,
processing, and analyzing scientific measurements. Although pysat was initially
designed for in situ satellite observations, it now supports many different
types of ground- and space-based measurements.
Full [Documentation](http://pysat.readthedocs.io/en/latest/index.html)
JGR-Space Physics [Publication](https://doi.org/10.1029/2018JA025297)
[Citation Info](https://pysat.readthedocs.io/en/latest/citing.html)
Come join us on Slack! An invitation to the pysat workspace is available
in the 'About' section of the [pysat GitHub Repository.](https://github.com/pysat/pysat)
Development meetings are generally held fortnightly.
# Main Features
* Instrument independent analysis routines.
* Instrument object providing an interface for downloading and analyzing a wide
variety of science data sets.
* Uses pandas or xarray for the underlying data structure;
capable of handling the many forms scientific measurements take in a
consistent manner.
* Standard scientific data handling tasks (e.g., identifying, downloading,
and loading files and cleaning and modifying data) are built into the
Instrument object.
* Supports metadata consistent with the netCDF CF-1.6 standard. Each variable
has a name, long name, and units. Note units are informational only.
* Simplifies data management
* Iterator support for loading data by day/file/orbit, independent of data
storage details.
* Orbits are calculated on the fly from loaded data and span day breaks.
* Iterate over custom seasons
* Supports rigorous time-series calculations that require spin up/down time
across day, orbit, and file breaks.
* Includes helper functions to reduce the barrier in adding new science
instruments to pysat
# Installation
## Starting from scratch
* Python and associated packages for science are freely available. Convenient
science python package setups are available from https://www.python.org/,
[Anaconda](https://www.anaconda.com/distribution/), and other locations
(some platform specific). Anaconda also includes a developer environment that
works well with pysat. Core science packages such as numpy, scipy, matplotlib,
pandas and many others may also be installed directly via pip or your
favorite package manager.
* Installation through pip
```
pip install pysat
```
* Installation through github
```
git clone https://github.com/pysat/pysat.git
cd pysat
python setup.py install
```
An advantage to installing through github is access to the development branches.
The latest bugfixes can be found in the `develop` branch. However, this branch
is not stable (as the name implies). We recommend using this branch in a
virtual environment or using `python setup.py develop`.
```
git clone https://github.com/pysat/pysat.git
cd pysat
git checkout develop
python setup.py develop
```
* Note that pysat requires a number of packages for the install.
* dask
* netCDF4
* numpy
* pandas
* portalocker
* scipy
* toolz
* xarray
* The first time the package is run, you will need to specify a directory to
store data. In python, run:
```
pysat.params['data_dirs'] = 'path/to/directory/that/may/or/may/not/exist'
```
* Nominal organization of data is top_dir/platform/name/tag/inst_id/files
%prep
%autosetup -n pysat-3.0.6
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pysat -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 3.0.6-1
- Package Spec generated