%global _empty_manifest_terminate_build 0
Name:		python-calamari-ocr
Version:	2.2.2
Release:	1
Summary:	please add a summary manually as the author left a blank one
License:	Apache License 2.0
URL:		https://github.com/Calamari-OCR/calamari
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/29/96/71b03c7c955b0fd718154303c8c6f4b8cba5f4413e3fa3efddedbf765898/calamari_ocr-2.2.2.tar.gz
BuildArch:	noarch

Requires:	python3-edit-distance
Requires:	python3-h5py
Requires:	python3-lxml
Requires:	python3-bidi
Requires:	python3-tensorflow
Requires:	python3-tfaip
Requires:	python3-xlsxwriter

%description

![logo](resources/logo/calamari_200.png)

[![Python Test](https://github.com/Calamari-OCR/calamari/actions/workflows/python-test.yml/badge.svg)](https://github.com/Calamari-OCR/calamari/actions/workflows/python-test.yml)
[![Upload Python Package](https://github.com/Calamari-OCR/calamari/actions/workflows/python-publish.yml/badge.svg)](https://github.com/Calamari-OCR/calamari/actions/workflows/python-publish.yml)
[![Lint](https://github.com/Calamari-OCR/calamari/actions/workflows/black.yml/badge.svg)](https://github.com/Calamari-OCR/calamari/actions/workflows/black.yml)

OCR Engine based on OCRopy and Kraken using python3.
It is designed to both be easy to use from the command line but also be modular to be integrated and customized from other python scripts.

![preview](resources/preview.png)

## Documentation

The documentation of Calamari is hosted [here](https://calamari-ocr.readthedocs.io).

##  Pretrained model repository
Pretrained models are available at (https://github.com/Calamari-OCR/calamari_models).
The current release can be accessed [here](https://github.com/Calamari-OCR/calamari_models/archive/2.0.zip) (255 MB).

## Installing

Calamari is available on [pypi](https://pypi.org/project/calamari-ocr):

```shell
pip install calamari-ocr
```

Read the [docs](https://calamari-ocr.readthedocs.io) for further instructions.

## Command-Line Interface

See the [docs](https://calamari-ocr.readthedocs.io) to learn how to use Calamari from the command line.

## Calamari API

See the [docs](https://calamari-ocr.readthedocs.io) to learn how to adapt Calamari for your needs.

## Citing Calamari

If you use Calamari in your Research-Project, please cite:

> Wick, C., Reul, C., Puppe, F.: *Calamari - A High-Performance Tensorflow-based Deep Learning Package for Optical Character Recognition.* Digital Humanities Quarterly **14**(1) (2020)

```
@article{wick_calamari_2020,
    title = {Calamari - {A} {High}-{Performance} {Tensorflow}-based {Deep} {Learning} {Package} for {Optical} {Character} {Recognition}},
    volume = {14},
    number = {1},
    journal = {Digital Humanities Quarterly},
    author = {Wick, Christoph and Reul, Christian and Puppe, Frank},
    year = {2020},
}
```




%package -n python3-calamari-ocr
Summary:	please add a summary manually as the author left a blank one
Provides:	python-calamari-ocr
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-calamari-ocr

![logo](resources/logo/calamari_200.png)

[![Python Test](https://github.com/Calamari-OCR/calamari/actions/workflows/python-test.yml/badge.svg)](https://github.com/Calamari-OCR/calamari/actions/workflows/python-test.yml)
[![Upload Python Package](https://github.com/Calamari-OCR/calamari/actions/workflows/python-publish.yml/badge.svg)](https://github.com/Calamari-OCR/calamari/actions/workflows/python-publish.yml)
[![Lint](https://github.com/Calamari-OCR/calamari/actions/workflows/black.yml/badge.svg)](https://github.com/Calamari-OCR/calamari/actions/workflows/black.yml)

OCR Engine based on OCRopy and Kraken using python3.
It is designed to both be easy to use from the command line but also be modular to be integrated and customized from other python scripts.

![preview](resources/preview.png)

## Documentation

The documentation of Calamari is hosted [here](https://calamari-ocr.readthedocs.io).

##  Pretrained model repository
Pretrained models are available at (https://github.com/Calamari-OCR/calamari_models).
The current release can be accessed [here](https://github.com/Calamari-OCR/calamari_models/archive/2.0.zip) (255 MB).

## Installing

Calamari is available on [pypi](https://pypi.org/project/calamari-ocr):

```shell
pip install calamari-ocr
```

Read the [docs](https://calamari-ocr.readthedocs.io) for further instructions.

## Command-Line Interface

See the [docs](https://calamari-ocr.readthedocs.io) to learn how to use Calamari from the command line.

## Calamari API

See the [docs](https://calamari-ocr.readthedocs.io) to learn how to adapt Calamari for your needs.

## Citing Calamari

If you use Calamari in your Research-Project, please cite:

> Wick, C., Reul, C., Puppe, F.: *Calamari - A High-Performance Tensorflow-based Deep Learning Package for Optical Character Recognition.* Digital Humanities Quarterly **14**(1) (2020)

```
@article{wick_calamari_2020,
    title = {Calamari - {A} {High}-{Performance} {Tensorflow}-based {Deep} {Learning} {Package} for {Optical} {Character} {Recognition}},
    volume = {14},
    number = {1},
    journal = {Digital Humanities Quarterly},
    author = {Wick, Christoph and Reul, Christian and Puppe, Frank},
    year = {2020},
}
```




%package help
Summary:	Development documents and examples for calamari-ocr
Provides:	python3-calamari-ocr-doc
%description help

![logo](resources/logo/calamari_200.png)

[![Python Test](https://github.com/Calamari-OCR/calamari/actions/workflows/python-test.yml/badge.svg)](https://github.com/Calamari-OCR/calamari/actions/workflows/python-test.yml)
[![Upload Python Package](https://github.com/Calamari-OCR/calamari/actions/workflows/python-publish.yml/badge.svg)](https://github.com/Calamari-OCR/calamari/actions/workflows/python-publish.yml)
[![Lint](https://github.com/Calamari-OCR/calamari/actions/workflows/black.yml/badge.svg)](https://github.com/Calamari-OCR/calamari/actions/workflows/black.yml)

OCR Engine based on OCRopy and Kraken using python3.
It is designed to both be easy to use from the command line but also be modular to be integrated and customized from other python scripts.

![preview](resources/preview.png)

## Documentation

The documentation of Calamari is hosted [here](https://calamari-ocr.readthedocs.io).

##  Pretrained model repository
Pretrained models are available at (https://github.com/Calamari-OCR/calamari_models).
The current release can be accessed [here](https://github.com/Calamari-OCR/calamari_models/archive/2.0.zip) (255 MB).

## Installing

Calamari is available on [pypi](https://pypi.org/project/calamari-ocr):

```shell
pip install calamari-ocr
```

Read the [docs](https://calamari-ocr.readthedocs.io) for further instructions.

## Command-Line Interface

See the [docs](https://calamari-ocr.readthedocs.io) to learn how to use Calamari from the command line.

## Calamari API

See the [docs](https://calamari-ocr.readthedocs.io) to learn how to adapt Calamari for your needs.

## Citing Calamari

If you use Calamari in your Research-Project, please cite:

> Wick, C., Reul, C., Puppe, F.: *Calamari - A High-Performance Tensorflow-based Deep Learning Package for Optical Character Recognition.* Digital Humanities Quarterly **14**(1) (2020)

```
@article{wick_calamari_2020,
    title = {Calamari - {A} {High}-{Performance} {Tensorflow}-based {Deep} {Learning} {Package} for {Optical} {Character} {Recognition}},
    volume = {14},
    number = {1},
    journal = {Digital Humanities Quarterly},
    author = {Wick, Christoph and Reul, Christian and Puppe, Frank},
    year = {2020},
}
```




%prep
%autosetup -n calamari-ocr-2.2.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-calamari-ocr -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 2.2.2-1
- Package Spec generated