%global _empty_manifest_terminate_build 0
Name: python-funkify
Version: 0.4.5
Release: 1
Summary: Funkify modules so that they are callable
License: MIT
URL: https://github.com/dynamic-graphics-inc/dgpy-libs/tree/main/libs/funkify
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/0b/ea/d095d1799770c9083dd8fd88e63f49f353abc0f41edb41157ac8e8ea4128/funkify-0.4.5.tar.gz
BuildArch: noarch
%description
# funkify
[![Wheel](https://img.shields.io/pypi/wheel/funkify.svg)](https://img.shields.io/pypi/wheel/funkify.svg)
[![Version](https://img.shields.io/pypi/v/funkify.svg)](https://img.shields.io/pypi/v/funkify.svg)
[![py_versions](https://img.shields.io/pypi/pyversions/funkify.svg)](https://img.shields.io/pypi/pyversions/funkify.svg)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
**Install:** `pip install funkify`
Make a module/package/script callable.
## Usage:
### 1) Write a file called `a_module.py` with some function and decorate said function with funkify
```python
import funkify
@funkify
def some_funk_name_doesnt_matter():
return 'howdy'
```
### 2) Import a_module and call it like you would a function!
```python
import a_module
a_module.some_funk_name_doesnt_matter_what_it_is() # returns 'howdy'
a_module() # ALSO returns 'howdy'
```
%package -n python3-funkify
Summary: Funkify modules so that they are callable
Provides: python-funkify
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-funkify
# funkify
[![Wheel](https://img.shields.io/pypi/wheel/funkify.svg)](https://img.shields.io/pypi/wheel/funkify.svg)
[![Version](https://img.shields.io/pypi/v/funkify.svg)](https://img.shields.io/pypi/v/funkify.svg)
[![py_versions](https://img.shields.io/pypi/pyversions/funkify.svg)](https://img.shields.io/pypi/pyversions/funkify.svg)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
**Install:** `pip install funkify`
Make a module/package/script callable.
## Usage:
### 1) Write a file called `a_module.py` with some function and decorate said function with funkify
```python
import funkify
@funkify
def some_funk_name_doesnt_matter():
return 'howdy'
```
### 2) Import a_module and call it like you would a function!
```python
import a_module
a_module.some_funk_name_doesnt_matter_what_it_is() # returns 'howdy'
a_module() # ALSO returns 'howdy'
```
%package help
Summary: Development documents and examples for funkify
Provides: python3-funkify-doc
%description help
# funkify
[![Wheel](https://img.shields.io/pypi/wheel/funkify.svg)](https://img.shields.io/pypi/wheel/funkify.svg)
[![Version](https://img.shields.io/pypi/v/funkify.svg)](https://img.shields.io/pypi/v/funkify.svg)
[![py_versions](https://img.shields.io/pypi/pyversions/funkify.svg)](https://img.shields.io/pypi/pyversions/funkify.svg)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
**Install:** `pip install funkify`
Make a module/package/script callable.
## Usage:
### 1) Write a file called `a_module.py` with some function and decorate said function with funkify
```python
import funkify
@funkify
def some_funk_name_doesnt_matter():
return 'howdy'
```
### 2) Import a_module and call it like you would a function!
```python
import a_module
a_module.some_funk_name_doesnt_matter_what_it_is() # returns 'howdy'
a_module() # ALSO returns 'howdy'
```
%prep
%autosetup -n funkify-0.4.5
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-funkify -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue May 30 2023 Python_Bot - 0.4.5-1
- Package Spec generated